Torchlight II

Torchlight II

View Stats:
Rob Jan 21, 2017 @ 5:36pm
Wont launch on Linux
Using Fedora 24, the launcher never shows up just a frozen window with a snapshot of whatever was in the background, usually the steam window that says "Preparing to Launch Torchlight II...".
< >
Showing 1-15 of 26 comments
Rob Jan 21, 2017 @ 6:06pm 
Yup it does support linux, and I have tried all those things. even tried running through the console, but no luck.
MICRODEVICES Feb 9, 2017 @ 8:52am 
I'm experiencing same problem with Fedora 25.
黑色_22 Feb 15, 2017 @ 6:16pm 
Originally posted by MICRODEVICES:
I found this.
https://www.reddit.com/r/Fedora/comments/5rk3ru/problems_launching_torchlight_2/
That works! Great thanks to you!
Zeadar Sagaena Feb 16, 2017 @ 2:49pm 
It appears to me that for some reason steam tries to load thier 32-bit steam overlay application for 64-bit Torchlight 2 which resuslts in an ELF class error.

A workaround which worked for me is to go Torchlight's properties, clicking set launch options and then add
LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command%
This will manually load steam overlay plugin for the correct architecture.

That said however, just disabling steam overlay in properties doesn't seem to discourage steam from loading the wrong file and while we now load the correct file: steam overlay doesn't work ingame. :2016imnotcrying:
Schotty Mar 4, 2017 @ 4:02pm 
Originally posted by Zeadar:
A workaround which worked for me is to go Torchlight's properties, clicking set launch options and then add
LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command%

Thanks, this fixed the same issue for me on RHEL7.
gotzl Jun 14, 2017 @ 5:04pm 
Thanks alot ! Fixed it for me on gentoo.
Sel3ctarr Jul 13, 2017 @ 12:05am 
Originally posted by Schotty:
Originally posted by Zeadar:
A workaround which worked for me is to go Torchlight's properties, clicking set launch options and then add
LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command%

Thanks, this fixed the same issue for me on RHEL7.


Thanks, this also fixed the issue for me on Fedora 26.
Last edited by Sel3ctarr; Jul 13, 2017 @ 12:05am
Fenrir Jul 22, 2017 @ 5:09am 
Can confirm this behaviour under Fedora 26, as well and also that the workaround does the job for me on this one.
sonik_bhoom Jul 31, 2017 @ 7:18pm 
CentOS7 w/kernel 4.12: this fix worked for me. So did the above reddit post...

reddit fix:
cd [game directory] echo "200710" > steam_appid.txt ./ModLauncher.bin.x86_64

Zeadar launch options fix:
LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command%

Originally posted by Zeadar:
It appears to me that for some reason steam tries to load thier 32-bit steam overlay application for 64-bit Torchlight 2 which resuslts in an ELF class error.

A workaround which worked for me is to go Torchlight's properties, clicking set launch options and then add
LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command%
Last edited by sonik_bhoom; Mar 13, 2019 @ 1:20pm
s.chebotar Apr 16, 2018 @ 11:49pm 
Unable to fix this issue in flatpak version of Steam. Tried to change the path to gameoverlayrender.so file in properties to the flatpak location of this. No luck.
Axurez Jul 14, 2018 @ 11:57am 
`~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so` does not exist on the version on ArchLinux currently.
Schotty Jul 14, 2018 @ 3:05pm 
Originally posted by Axurez:
`~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so` does not exist on the version on ArchLinux currently.
Where is your user's steam data found then? change ~/.local/share/ to that. You can find this in your settings, in the downloads section.
Last edited by Schotty; Jul 14, 2018 @ 3:08pm
Axurez Jul 14, 2018 @ 9:10pm 
Originally posted by Schotty:
Originally posted by Axurez:
`~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so` does not exist on the version on ArchLinux currently.
Where is your user's steam data found then? change ~/.local/share/ to that. You can find this in your settings, in the downloads section.
It is `~/.local/share/` I believe. The 32bit version of `gameoverlayrender.so` (at `ubuntu12_32`) exists though. I chose to manually start the 32bit version of the game (`Torchlight2.bin.x86`) as a workaround.
DaKine Feb 5, 2019 @ 3:43pm 
Try to start the launcher from terminal if error is like

"... symbol lookup error: /lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var"

navigate inside the games folder (properties show files) open a terminal and do

$ rm ./lib/libfreetype.so.6 ./lib64/libfreetype.so.6

in addition use the

LD_PRELOAD=~/.local/share/Steam/ubuntu12_64/gameoverlayrender.so %command%

as mentioned above

and the launcher will start again ...
Last edited by DaKine; Feb 5, 2019 @ 3:52pm
< >
Showing 1-15 of 26 comments
Per page: 15 30 50