Oil Rush
 This topic has been pinned, so it's probably important
Brandt May 9, 2013 @ 6:26pm
[Linux] Oil Rush now starts
Hi everyone!

Like many others I tried to run Oil Rush on Ubuntu 13.04 (32 bits) with Intel HD without success, when I opened Steam with terminal I saw this error when lauching Oil Rush:

Error of failed request: GLXBadFBConfig
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 34 ()
Serial number of failed request: 52
Current serial number in output stream: 51

After some search I saw this are related with an >3.0 OpenGL extension - last official MESA drives implements OpenGL 3.0, theoretically - but thanks to this tip and the latest MESA driver (9.2.0) now Oil Rush runs smoothly at 50fps!

You can try this by editing the file "launcher_steam.sh" inside the folder Steam/SteamApps/common/Oil Rush doing this:

On a Terminal:
gedit ~/.steam/steam/SteamApps/common/Oil\ Rush/launcher_steam.sh

Paste this BEFORE the "./launcher..." in the last line:

So, your ENTIRE LAST LINE will look like THIS:
MESA_GL_VERSION_OVERRIDE=3.2FC MESA_GLSL_VERSION_OVERRIDE=150 ./launcher_x86 -config ../data/launcher/launcher_steam.xml
Save the file and try to run on Steam.
If still not works, try to update your MESA drivers using the xorg-edgers repository:

On a Terminal
sudo add-apt-repository -y ppa:xorg-edgers/ppa && sudo apt-get update && sudo apt-get upgrade
Restart Ubuntu before try

To check OpenGL and MESA version, on a Terminal:
glxinfo | grep 'OpenGL version'
Last edited by s1lent; Jun 5, 2013 @ 9:31am
< >
Showing 1-15 of 25 comments
Kerias May 16, 2013 @ 11:23pm 
Works for me. Thanks for sharing!
s1lent  [developer] May 20, 2013 @ 12:06am 
Thanks for the instructions! Pinned :)
UbuntuIsFriendly May 24, 2013 @ 9:40pm 
Thank you for writing such a detailed workaround! Much appreciated.
Gustavo Jun 4, 2013 @ 7:53pm 
Thanks, it worked!
Kryuko [GNU/NT] Jun 5, 2013 @ 2:52am 
i get the error ./launcher_x86: not found
Uniquely Named Jun 5, 2013 @ 4:13am 
@Kryuko You must cd path/to/OilRush-1.35 then run ./launcher.sh.
Uniquely Named Jun 5, 2013 @ 4:20am 
Apparently this will be more widely supported when mesa 9.2 is out (Unigine needs GL_ARB_texture_multisample).

Implementing GL_ARB_compatibility in mesa and in Unigine would probably remove the need to tweak the launcher script.

allenmaher Jun 5, 2013 @ 6:12am 
Thanks for this!
a100167 Jun 6, 2013 @ 12:08am 
Outstanding Brandt, though I don't use Intel hardware it's good to know and thank you for posting such a detailed workaround :)
Freak_NL Jun 6, 2013 @ 1:01pm 
Thanks for the tip. Upgrading the drivers works.
Kryuko [GNU/NT] Jun 6, 2013 @ 2:55pm 
Not work for me. When i start the game, the launcher start, but if i click the botton to run the game, the game stop working and crashed.
Kryuko [GNU/NT] Jun 6, 2013 @ 3:02pm 
Uhm, this tutorial works only in 32bit, right?
allenmaher Jun 6, 2013 @ 3:10pm 
No I am running this fix in 64 bit. works fine.
Kryuko [GNU/NT] Jun 6, 2013 @ 3:11pm 
D: i don't know why but for me doesn't work :(
allenmaher Jun 6, 2013 @ 3:23pm 
You can try putting the override into an export command.

< >
Showing 1-15 of 25 comments
Per page: 1530 50