Prince of Persia

Prince of Persia

swankyfella Dec 20, 2012 @ 10:19pm
Game won't launch
Every time i try to launch the game, the launcher app starts up fine, but when i tell it to actually start the game, it closes and nothing happens. Is anyone else having this problem?
< >
Showing 1-15 of 22 comments
koskenbleu Dec 21, 2012 @ 4:01am 
Same here, I click the start game, and it completely freezes in the loading screen... weird.
Casttom94 Dec 21, 2012 @ 5:11am 
Same problem
brune Dec 21, 2012 @ 5:23am 
I noticed the games was XP and Vista only when I considered buying it, are you fellas on Win7 by any chance?
Praxius Dec 21, 2012 @ 6:28am 
Same issue.... Running under Windows 8 - 64 bit. Bought it with the PoP pack. So far, every other game runs just fine.

Switching compatability to XP or run under Admin does not resolve the issue. All files have been verified.

.... Apparently this isn't a new issue either and has occurred during Windows Vista's days:

I'm just about to test one of the possible solutions from the above link.... one moment.
Last edited by Praxius; Dec 21, 2012 @ 6:33am
Praxius Dec 21, 2012 @ 7:04am 
Dum da Dum Dum Duuuummmmbbbbb......

After the DirectX install is complete, even though it doesn't state that you have to..... restart your system.

When you reboot it will take a bit longer to get to your desktop and you will hear your HD doing a bit of work updating this and rewriting that due to the DirectX setup earlier....

Once you have restarted, launch the game.

koskenbleu Dec 21, 2012 @ 8:38am 
hmm, doesn't work for me... running w/ Windows 7 64-bit.
koskenbleu Dec 21, 2012 @ 8:39am 
also tried to switch comp. to Xp but that just didn't work at all for me either
Ashy :3 Dec 21, 2012 @ 12:43pm 
I also am having some issues. Whenever I try to play it says "Failed to start game (Unkown Error) "
kr00l Dec 21, 2012 @ 1:07pm 
The easy way to get this game to run is: Buy it from for $4.99. It will work on every windows OS.
Praxius Dec 21, 2012 @ 4:34pm 
Some others in the above link I supplied noted that you may need to change the exe file names in order to work:

maximus007 -
Ok guys good news...well at least for me.

I decided to take the file PrinceOfPersia_Launcher.exe
and renamed it as "Prince Of Persia.exe" and this work right away.
When you are going to rename the file make sure you have the spaces in between. Again for some reason that worked for me right away as soon as I renamed the original file "PrinceOfPersia_Launcher.exe"

further detail:

lp3hora -
Guys, I discovered how to solve this problem:

On the tip of maximus007, you must do the following: Make CTRL + C and CTRL + V in the file "PrinceOfPersia_Launcher.exe" and rename the new file to "Prince Of Persia.exe".

Thus, in the game folder there should be two files ".exe": one with the name "PrinceOfPersia_Launcher.exe" and another named "Prince Of Persia.exe".

I hope have helped you.

I just had to restart and it worked for me without having to do any of the above, but who knows?
Last edited by Praxius; Dec 21, 2012 @ 4:37pm
Somato Dec 21, 2012 @ 9:58pm 
had the same problem, tried all the things people said to get it to work but none of it worked. till i ticked vsync. so do that
AnBi22 Dec 21, 2012 @ 11:51pm 
Vsync on worked for me also
Awesam Dec 23, 2012 @ 9:27pm 
Restarting my computer worked for me.
DePhoegon Dec 25, 2012 @ 11:52pm 
Yep, simple reboot did the trick. :P
kitarefo Jan 9, 2013 @ 6:53am 
The Vsync solved the prob. for me, THX !
< >
Showing 1-15 of 22 comments
Per page: 15 30 50