Two Worlds: Epic Edition

Two Worlds: Epic Edition

kaay Feb 13, 2013 @ 3:05pm
Official Nvidia fix for the startup crash
On the Nvidia site there is the "Nvidia PhysX Legacy Software" which fixes all problems related to older games requiring older versions of PhysX drivers.
It will not affect your newer version of PhysX drivers.
The link is here http://www.nvidia.com/object/physx-9.12.1031-legacy-driver.html
< >
Showing 1-15 of 177 comments
Mastertesla Feb 26, 2013 @ 11:28pm 
Dude, Thanks!

Many THANKS!!!
Last edited by Mastertesla; Feb 26, 2013 @ 11:30pm
meatee Apr 1, 2013 @ 8:10pm 
Thanks! The game works perfectly on Windows 8 now.
Nightred Apr 6, 2013 @ 3:56pm 
I love you!
Last edited by Nightred; Apr 6, 2013 @ 3:57pm
lvfb068 May 16, 2013 @ 12:23pm 
I have installed and played the game and took off a couple off days now am getting a problem re-loading and playing, I am using Radeon HD 6570 Graphics card with newest available drivers but still get unknown error and game won't start Why?
Last edited by lvfb068; May 16, 2013 @ 12:24pm
kaay May 17, 2013 @ 7:20am 
Sorry i dont know anything about ATI cards, but if you played the game before and cant play anymore you might want to verify integrity of cache files (right click on game title in your list, select properties, then "local files" tab and select verify cache integrity).
Usually that fixes such problems for me.
Rez May 24, 2013 @ 6:47pm 
Thank you kaay for your Nvidia fix - worked perfectly for me!
Ears14U May 26, 2013 @ 11:18am 
I purchased this title from Amazon downloads and ran into the same problem (probably) that you guy's are. Here's what I found...The Nvidia Physics driver is probably the newer version which this game doesn't run with. Use a good uninstaller, and go in and uninstall the Nvidia Physics program. Then go to this site link and download this version and install it. You shouldn't have any problems any longer.......http://www.nvidia.com/object/physx-9.12.0613-driver.html This version is Version: 9.12.0613 and does work with Two Worlds epic edition. Sorry...I'm running a Windows 7 64bit machine if that's helpful at all....lol...
Kumoa Jul 19, 2013 @ 7:00pm 
I tried this and it did not work, still crashes
Blarzek Jul 21, 2013 @ 3:29pm 
Thank you so much! It works for me.
Ears14U Jul 21, 2013 @ 3:34pm 
I believe that both of these driver fixes will work. Maybe the link that KAAY did was for the Steam version, and the one I posted (and works) could be for the Amazon or other download sites. Try both!
Last edited by Ears14U; Jul 21, 2013 @ 3:34pm
Kumoa Jul 21, 2013 @ 5:09pm 
Originally posted by Ears14U:
I believe that both of these driver fixes will work. Maybe the link that KAAY did was for the Steam version, and the one I posted (and works) could be for the Amazon or other download sites. Try both!

i've tried them it still crashes....sigh.
kaay Jul 21, 2013 @ 5:13pm 
what are your specs Torakuma?
J.Jensen Jul 21, 2013 @ 5:19pm 
Thanks a lot kaay. I had no idea there was a legacy driver for PhyX that didn't interrupt with latest version.
Kumoa Jul 21, 2013 @ 5:20pm 
Originally posted by kaay:
what are your specs Torakuma?
Operating System: Windows 7 Home Premium 64-bit
Processor: AMD Phenom(tm) II X4 955 Processor (4 CPUs), ~3.2GHz
Memory: 8192MB RAM
DirectX Version: DirectX 11
Card name: NVIDIA GeForce GT 640 2048 MB vram
Nvidia driver: 9.18.13.2049
physx 8.0818


errror msg:

Problem signature:
Problem Event Name: APPCRASH
Application Name: TwoWorlds.exe
Application Version: 1.7.0.0
Application Timestamp: 47c7ebb8
Fault Module Name: TwoWorlds.exe
Fault Module Version: 1.7.0.0
Fault Module Timestamp: 47c7ebb8
Exception Code: c0000005
Exception Offset: 0035a8c1
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
Last edited by Kumoa; Jul 21, 2013 @ 5:24pm
kaay Jul 21, 2013 @ 5:29pm 
weird, either your drivers didnt install correctly, or your crash is not physix related, or maybe a problem with your install.
checked integrity of game cache? that helped me out of many weird problems.
re-install the game if nothing works, or try starting the game by double-click on the executable itself, sometimes the error message that you get by doing that gives you more info about the problem.
< >
Showing 1-15 of 177 comments
Per page: 15 30 50

Date Posted: Feb 13, 2013 @ 3:05pm
Posts: 177