This topic has been pinned, so it's probably important
Alex_Merge  [developer] Jan 31 @ 5:56am
General Pixelshire Demo Feedback, Suggestions and Ideas
Welcome to the General Demo Feedback, Suggestions and Ideas sub!

We would love to hear all your ideas and suggestions.

Is a system a little too complicated for your taste? A specific user interface feature that would make things easier?

Let us know your ideas and we'll see what we can implement in the game.
< >
Showing 1-15 of 38 comments
MrStone Jan 31 @ 6:54am 
Great art, and the gameplay seems promising! I just played for a bit due to time constraints, but first piece of feedback from me would be considering the ability of closing menus with "Escape" key, and when not on any menu, then pause/open up the pause menu.
MrStone Jan 31 @ 7:24am 
- The text, more specifically in the guidebook, may be a bit hard to read with the small size and the pixelated font.
- It would probably be better to hide the locked bag until unlocked, I thought clicking on the bag didn't open the bag, which it does, but it is the one on the left.
- Overall, the interface feels a bit intimidating at first, too much graphical importance/information. A simplified/reorganized UI and tooltips on elements of the interface (for example, the bags, the top left indicators, which could use a tooltip like HP X/Y, Energy X/Y, etc) would probably help.

Gameplay wise, really amazed with the little I've been able to interact with. Features seem to work well together. It really shows the care and passion with this game, looking forward to the release, probably day one buy!
Corence Jan 31 @ 12:36pm 
I cannot figure out how to change shop tabs so I can't buy Margarita's tomato seeds. I see the 1/3 which makes me think there are two other shop pages but no idea how to get to them. Playing on KB+M and not controller.

In general using a mouse seems to be clicking on things in the background while I'm in menus giving errors at the top of the screen that I'm missing equipment.
Normaly i play with 1600x900 so the other sizes asside from fullscreen seem kinda small. Also the game doesn't even keep remembering the size
Konidias Jan 31 @ 2:41pm 
Originally posted by Corence:
I cannot figure out how to change shop tabs so I can't buy Margarita's tomato seeds. I see the 1/3 which makes me think there are two other shop pages but no idea how to get to them. Playing on KB+M and not controller.

In general using a mouse seems to be clicking on things in the background while I'm in menus giving errors at the top of the screen that I'm missing equipment.
There are very hard to see arrows on either side of the book, which don't stand out enough and took me a while to find as well
Konidias Jan 31 @ 2:52pm 
Excited to finally try the game! So I checked out the demo and just a few things I want to note from the brief time I was able to play it:

1. The book is a nice idea but it's a bit too much text to read just at the start of the game. I think mainly the issue is that there's just a huge wall of text instead of it being broken up into small sentences over multiple pages. Feels too long-winded and a lot of the stuff is self-explanatory and could be cut from the writing.

2. The interfaces look great but are kind of frustrating to use. As the other person mentioned, I would expect to close out of interface windows hitting ESC but you have to manually click the close button every time. I found myself fighting the interface a lot, and it's just a bit overwhelming with how much stuff is presented to you all at once.

3. Using tools isn't very intuitive. I went to my bag and equipped them but because I couldn't immediately see them as equipped I was confused as to where they went. There is no visual indicator of where the tool goes after right clicking it in the bag. Then when I attempted to click with the mouse to use the tool, I kept seeing a prompt about not having a tool equipped, which was a bit annoying. Once I finally found the tool wheel it *sort of* made sense, but even then it was confusing that I see all of the tools in the wheel but I only technically had the water can and hoe. Unequipped tools should gray out those icons or something so it's clear you don't have anything there.

4. Even after equipping the hoe I was still seeing the tool message a lot of the time. It was also unclear when I was able to use the hoe and when I couldn't. I would click on a square and nothing happened. Then I'd move slightly and click on the same square and it would work. Same for the water can.

5. Speaking of the water can, if you tap really fast it almost instantly drains all the water in the can, but only shows you watering like 2 times. If you hold down the button while using the can, it constantly loops the watering can animation but the water doesn't go down...

6. The compass is a bit broken. After meeting the first townsfolk it told me to talk to the lady to get started with farming... the arrow pointed straight down so I followed it to the bottom of the island area... but the lady wasn't there. I walked along the entire bottom portion of the map and the arrow just kept telling me to go further South. Finally I gave up and went toward the center of the map and suddenly the arrow completely changed direction to point toward the center of the map.

7. I alt tabbed out of the game for a couple of minutes and when I came back, the game was stuttering and felt like I was getting about 10fps... I couldn't play so I had to just quit.

That's as far as I managed to get. Overall it's good that the demo is out because there's a whole lot of bugs/issues that need addressing, so hopefully more people can play and report their experience. The game has potential but currently I am sad to say I'd probably stop playing this after 10-15 minutes and refund it if it was released in its current state.
Last edited by Konidias; Jan 31 @ 2:55pm
not sure if i soft-locked myself... couldn't for the life of me figure out how to harvest the tomatoes and ended up destroying them. Not clear if i missed instructions somewhere but the equip for me is hard to determine what does what. hence thinking i had to use the hoe to harvest. NOPE. Now i am just standing outside unsure of what to do since i can't complete Margarita's quest.
Planting/Hoeing is also difficult to use. Sometimes the hoe works and sometimes it takes multiple swipes for it to interact with the ground.
Ok so I'm pretty bad at explaining things so I apologize if my wording is hard to understand at any point. I also apologize for how long this is going to be.

1. I have to agree with the majority here tht the book is pretty overwhelming. I think having less words and making the words a bit bigger maybe even bold aswell to stand out more would help.

2. The fishing isn't all tht bad once u understand how. I read the book to figure out how to do it. However with tht being said a few things tht might help make it better is: ¹making the reel spin a bit slower, ²instead of a darker orange and flashing to signal wht one to click on maybe make it a different color all together to make it easier to see, ³I also think having an initial click to start the minigame to catch the fish would definitely be nice.

3. The book quests process slow and u CAN NOT go ahead of the book quest order on the little side menu tht tells u wht to do next. U have to do it slowly and not go ahead or it WILL NOT let u finish the book quest as it doesn't register u already completing parts of it which can get rather annoying and tht definitely is something tht needs to change.

4. I think the information about not building at night and the guest room should be given when u first talk to Eva as I took too long exploring I didn't get done till it was night as I wasn't able to set the workbench down to learn said information. I closed to gane and restarted and rushed it and then learned the information.

5. I think there definitely needs to be a way to set keybinds and better optimize the game for not so great PCs as mine kinda sucks and I'd love to play this game but I lag heavily in the forest and occasionally in the town. It's ok if there's no way on ur end to better optimize the game if tht is the case maybe have settings for individuals to change more settings. Also the esc button would be so nice to close menus.

6. The tool wheel is nice but I do think it should grey out or not show unowned or broken tools.

7. Customization is definitely a big thing I think many of us would like to see however it isn't necessary.

8. The compass is a bit broken unfortunately I wasted a quarter og the day looking for someone the complete opposite direction of their location.

9. An indication for where and wht u can use tool on would be nice as they don't make tht clear.

10. Definitely think the range of where/how u can use the tool should be changed as sometimes I'll be next to a rock or a tillable area and I can't use my tool until I change where I'm standing.

11. The machines- I think u should allow the use of machines in a certain range and if it's meant to be tht way already then it doesn't work as I was against the workbench and furnace and couldn't use the furnace even with my face touching it. NOW if u want it to be like Minecraft and use them individually then I suggest not showing everything in the crafting book when in a certain machine as it got a little confusing. Maybe have each machine show it's own interface of wht tht machine can do.
Hurrshire Feb 1 @ 1:23pm 
I just finished the demo for the first time and I've got some initial thoughts. First off, I love the look of this game. It's adorable and I'm looking forward to sinking a lot of hours into this. Here's some thoughts I had while playing, in no particular order:

1. I found that the rotate function didn't really work when placing furniture and I only found it by pressing random buttons

2. SFX was SUPER loud for tool use and fishing, even after turning it almost off in settings
3. Tool use is a bit laggy, especially the sword which makes combat feel unnatural. I found many times using the axe that when I released the button, it took a couple seconds (and an extra chop or two) to stop the animation.

4. Tool durability is frustrating.

5. The hit box for trees and stones (and watering crops) seems too small and it's easy to miss completely if you aren't standing almost on top of the item you're trying to hit.

6. Target location (the white outline box showing what your mouse is targeting) doesn't function as expected, where I would generally expect this to act as an action location which would turn the character to hit whatever is in that square. Instead the character direction dictates where the tool will hit.

7. Tutorial day went quickly while I was learning my way around and by the time it came to place the workbench, it was already night time and I got the notice about not being able to build at night. I went to sleep and the next day after I placed the bench, I got the quest to go to sleep and could not progress until I did so. Feels like I lost a whole day of the demo where I could have explored more of the game.

8. Sometimes the equipment wheel would not open. It would be cool if we could use the mouse wheel or even 1-9 number keys to change equipment.

9. I found it frustrating that there was no immediately obvious hotkey to quickly transfer items from the inventory to a chest or from workbenches into the inventory. Shift click is usually what does it, but in this case it would only take 1 item from a stack.

10. Fishing was incredibly unfun. Where the tool use feels laggy, the fishing is PRECISE. I found it very difficult to go from the slow speed of everything else to needing to be seriously on my game to catch a single fish. Please add an accessibility option to turn off the fishing minigame.
Merder Feb 1 @ 7:11pm 
I thought the demo was pretty good overall. The characters were interesting. The graphics were top notch.

The tutorial has a lot of text. Some players just want to jump in and start interacting with the game without reading a lot. I suggest that the most important bits should be at the very beginning of each tutorial section with the less important information following that. For example, I glossed over the fact that you have to right click to harvest and that soft locked my game due to the fact that I destroyed the tomatoes I was supposed to harvest. I didn't mind starting over but I think it could have been avoided by making that information stand out more.

I'm sure this is a known issue, but sometimes the NPC sprites get "jittery". They sort of just glitch out and start flickering.

It's not super clear that you have to right click a crafting station to use it. The message that pops up just says you need to be standing near it.

Fishing needs a rework. It's not at all clear where or when you are supposed to be clicking. The mini-game is over before you really even have an opportunity to understand how it works. I think you should just redesign the fishing game so that it's similar to other farming games.

I was disappointed with the abrupt end of the demo. I assume it's set to a number of days. I was going to sleep and save the game to come here and ask a question and suddenly the demo was over and my save was erased. That was a real bummer. I doubt I'll start over again because I had almost reached the end of the tutorial and I don't want to do everything over again.

Overall I liked the demo and the game seem like something I'd enjoy playing more once it's fully developed.
  • Art style looks good.
  • Tab style of NPC interaction instead of the usual dialogue menu navigation through chat options.
  • Each NPC has their own "shop" and that you can sell items to them.
  • Relative freedom to place structures and machines.
  • The guidebook explanations and illustrations/videos were very helpful.
  • Nice variety and density of plants and other harvestables.
  • Nice to see something other than just bats and slimes in the mines.
  • Appreciate that the fishing mechanic is more about timing rather than rapid clicking.

  • Would be nice to see the numeric value of the players stats in the top left (i.e. health/stamina).
  • Would like to see an actual time or some numerical representation of how much of the day remains.
  • [Fishing] - Slow the reel movement by 50%
  • [Fishing] - Make clicking the reel at the wrong time take a chunk out of the fishing timer rather than instantly fail.
  • Couldn't tell if the gifting is working. Didn't indicate whether or not the NPC accepted the gift even though the item was consumed.
  • Allow the player to exit the mines while in combat.
  • Allow some of the tools to do some melee damage (shovel/pickaxe/axe) in the case where the player's weapon durability is gone with no backup.
  • If the player's timing is off enemies can interrupt/cancel the player's attacks. Not sure if this is an intended mechanic or not.
  • Sometimes in combat with enemies, if they pin you on something when they swing to do one attack, it can hit you 2-4 times. This could prove deadly for harder enemies and I'm not sure if it's intended.
  • Perhaps I'm doing it wrong, but there were a lot of seemingly legitimate water sources I couldn't fill my water can from.
  • The sell prices for easily collected raw materials probably might need to be adjusted. Just selling stacks of stone/mushrooms yields quite a bit of currency. Though I suppose without knowing the currency sinks in the game, perhaps it's intended.

Overall I had a very positive experience and am looking forward to trying out the next build during the upcoming Steam Next event. Perhaps there will be no in-game day time limit on it :lunar2019grinningpig:
I've been looking forwards to this since the moment I first saw it, immediately caught by the lovely art style. So glad to finally have a demo to play out!
Some suggestions:

Agree with the others that the fishing minigame needs tweaking. I eventually gave up on it because it was so finicky it only seemed to register my clicks when it felt like it. But I do appreciate doing something different with fishing, I haven't seen something like that in other similar games. The idea is solid!

Controls feel a little sluggish. It wasn't an issue most of the time, but when fighting it really showed. I fully understand that combat isn't the main focus but it seemed up in the air if the swing would hit. Dodging works fine most of the time though. It's just that swinging the sword is slow and the enemies are faster than you with it. Plenty of available healing items make up for damage taken, but still.

This may have been a bug, as I didn't see anyone else mention it here, but I could not plant two seeds beside each other, there had to be an empty square between them (tried both vertically and horizontally). Since the tomatoes we harvest as part of a quest are all planted in a row I assume it should be possible.

It wasn't always clear why I could not place for example the house or a furnace in a certain spot. Areas would appear to be cleared, but something was in the way or too close and the problem wasn't obvious. Highlighting the problem when trying to place something (like having different colors of the grid of the thing you're placing) would be very helpful.

The font of the book gave me some issues when I was trying to figure out how to open the tool dial. I actually was convinced that the Q symbol meant the middle mouse button and that it wasn't working, it took me a minute to figure out.

This is 100% a question of preference, but I felt the character portraits doesn't match the rest of the graphics. Everything else is so round and soft, that the portraits having more (comparatively) realistic features broke away from everything else.

Really looking forwards to playing more of this, I had a lovely time with the demo overall!
Lidaaaa Feb 5 @ 11:51am 
I've been waiting on this game for a few months now and have just played the demo although I got myself soft-locked on day 3 when trying to complete bron's quest as I bought the friendship point to mine iron before the quest told me to.

Here are a few things from my short time playing the demo:
1. When trying to get out of the menus I keep pressing ESC which pauses the game instead of closing the menu, the fact that time doesn't stop while in menus is a nice change of pace from other farming sims I've played. although the fact that it says I'm still trying to use tools while in the menus is annoying

2. The number of walls of text within the game is not at all necessary and it feels like it doesn't give that much information anyway as I am still having to figure out the keybindings for myself.

3. The tool usage feels very sluggish, especially the combat the fact that it feels like you can get knocked out of an attack, and don't swing quick enough to get in between the attacks of the enemy.

4. It feels like the location marker is useless if you point to the left of the character while your character is facing right they will still use their tool to the right and not where you are pointing, possibly make the location marker grey out when it isn't affecting the hit location.

5. While the graphics are beautiful, it feels like you can get hidden in the grass and tree's very easily, and i would feel the if the grass sprite was cut down to about halfway or when your characters sprite gets hidden a grey overlay of them would appear on top of everything so you can still see where you are walking.

6. The fact that some fish sell for 0 Gold really doesn't feel correct.

7. The fact that fetch quests need to you accept the quest before you go off and gather it is annoying even if you have the required items in your inventory already.

8. Tool durability, when my tool runs out of durability and breaks I really don't feel like having to go and find the correct shopkeeper to get a new one, (I also couldn't find a vendor for a new axe), may be either scrap the durability entirely or make it so you can repair the tools when they break or something.
Throhk Feb 6 @ 12:25pm 
I just started the demo, and I've noticed that the characters tend to get stuck. They'll be alternating facing left then right very quickly. It happened with the dog and I couldn't get at the tomatoes to complete the tomato quest for quite a while. I think it moved on its own when it started getting dark.
Kawarri Feb 6 @ 9:17pm 
The controls barely work for me, maybe 10% of the time. I could not use the hotkeys for the bag or tool menu on my first attempt, so I was utterly lost until I started a second new game.

The hotkeys worked then, but upon equipping the tools, using them took a lot of repeated effort. I believe using the tools was also not exactly explained in the book. I am still unsure if it is leftclick or rightclick, as both seemed to work, albeit rarely.

I could only grab one of the tomato plants, which it seemed like it wanted me to grab all 3. I experimented with a flower afterward, and after repeated effort (and seemingly literally dragging the plant away from the ground?), a few of them were able to be collected.

I checked the book to make sure I was not missing control explanations. I also noticed a fair bit of typos at this point. I eventually got the sword despite the quest asking me to go another direction, and once again, it rarely worked upon trying to use it. I closed the game at this point in frustration.

Being an alpha demo is fine, plenty of things to work out. But if basic mouse/keyboard controls dont work, then I think this is literally unplayable in its current state. I also wish to echo some prior comments - in that there is a fair bit of text for how much is on screen at once, and there was some odd jittery movements that were unpleasant. Possibly just unoptimized or some lower-end system limitations.
< >
Showing 1-15 of 38 comments
Per page: 1530 50