Source Filmmaker

Source Filmmaker

ZombeeDeath May 25, 2013 @ 12:25am
Volumetric Lighting problem
When I enable volumetric lighting on any lights, it produces white lines/squares where the volume should be. They are still there when increasing/decreasing the volume intensity.

I was one of the users effected by the Integrated Intel graphics card problem, if this helps.

Laptop Specs:

Windows 8
Nvidia Geforce GTX 675MX
Source Filmmaker

Is there any fix? Or do I need to wait for a patch?

Thanks in advance.
< >
Showing 1-15 of 18 comments
teruh May 26, 2013 @ 8:12am 
It probably has to do with you using a laptop. SFM doesn't work to well with them. Also, when you say you were affected by the Intel Graphics problem, does that mean you have one in your laptop?
ZombeeDeath May 26, 2013 @ 5:07pm 
My other laptop can run the sfm with volumetric lighting, and it has no intergrated graphics and also has a worse graphics card than the one i have now.

Yes I have Intel intergrated graphics in this laptop.
Xelabo May 27, 2013 @ 12:58pm 
Since you mention a dedicated gpu in your specs, you should be able to use that instead of Integrated Graphics by switching the output to that card. This is usually done via control panel or the nVidia control panel. Having the Intel Graphics chip shouldn't make a difference if you use your nVidia as the default or primary card.
ZombeeDeath May 27, 2013 @ 6:55pm 
Yeah, i have tried that. As it was apparently a potential fix for the Intel problem (before it was patched by Valve), and I have kept it the same since. So in the control panel at this current time, and has been for a couple weeks, says that SFM is using the High-end Nvidia instead of the Integrated.
KKiONI May 27, 2013 @ 8:06pm 
I have the same problem as well, but I've got a GT 640M with an Intel HD Graphics 4000. I managed to fix it by doing the following:
1. Go to your Nvidia Control Panel.
2. Go to Manage 3D Settings
3. Under the "Global Settings" tab, have it always use the Nvidia processor.

I would assume the cause of this is another program handles the lighting calculations. It definitely explains why configuring sfm.exe in the control panel does not work.

If it is in fact the case, it would be nice to know where that program is located so I can keep in Nvidia card for the intense processes only.
ZombeeDeath May 28, 2013 @ 2:10am 
My global settings were already set to use the Nvidia processor, i tried again and but still did not work.
E.y.3 May 28, 2013 @ 2:38pm 
actually i have a good laptop but a intel hd graphics 4000 . i canrun sfm but still trouble with volumetrics light ( big rays useless) wiht update it seems now i can use bloomscale from camera ) .But still same trouble with volumetrics lights (i can't use them i have to disable it .
But on a bad laptop of a friends of mine (i3 240 M ) he can use sfm with volumetrics etc....
ZombeeDeath May 28, 2013 @ 5:42pm 
Thats exactly the same with my Dreamer.

My old laptop (no integrated intel) which is 4 times worse than my current one (integrated intel) could run volumetric lights.
E.y.3 May 29, 2013 @ 1:28am 
and on my oldest comp q6600 8800GT (i have all working. its so frustrating when we knows that volumetrics make the shiiit so real. For everything like lamp flare ambiant light. I had to put some fog instead which kinda bad..i would understand if i had a hd oldest version graphics but mine its the latest hd4000 graphics (even if OKKKK its not fit for making 3D stuff) . It doesnt make sens that this chipset can't run a 5 years old engine. Everytime i turn on sfm on my laptop saying dx9 stuff now it dont say anymore ( thanks latest update ) but still can't use volumetrics . (at least now i can use bloomscale from camera. Please fix it valve i can make return since im a intel HD graphic user .( but you zombie you got a gt 675 you should be able you have to make something ) i saw some people having same trouble using element 3D for after effect . I think there is something to do to force sfm using your graphic card instead intel chipset
Punch May 29, 2013 @ 5:58pm 
can you post a picture?
E.y.3 May 30, 2013 @ 6:16am 
for me it's exactly the same as Zombie . we can't use volumetrics light .
Despite i have the latest intelHD chipset
KKiONI May 30, 2013 @ 9:14am 
Yeah, that was the exact same problem I had, but I resolved it using my solution mentioned above. I am going to go process hunting and see if there might actually be another program running alongside SFM.

Edit: As far as I can see, I cannot find any other processes linked to SFM. Certainly makes me wonder how my solution solved it now.
Last edited by KKiONI; May 30, 2013 @ 9:22am
E.y.3 May 31, 2013 @ 4:19pm 
Hey Guys i send message 2 days ago and did they made a short update ? BECAUSE LIGHT VOLUMETRICS ♥♥♥♥ING WORKS NOW I'ms so glad . How this is much more badass look now . thanks you SFM team for making it works on intel HD . Let me know guys if you it's also working (i didnt make mort test ) i just open sfm and saw volumetrics light
raptornx01 May 31, 2013 @ 4:32pm 
I noticed a small update. that must have been it.
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Date Posted: May 25, 2013 @ 12:25am
Posts: 18