Source Filmmaker
Source Filmmaker > กระดานสนทนาทั่วไป > รายละเอียดกระทู้
Source Filmmaker won't start (window stays minimized)
Hey there SFM-Users,
I have a problem with the Source Filmmaker. Since SFM crashed while loading one of my project-files, it does not work anymore. When I try to start it, two windows open. The one is minimized and the other one is the window where you can choose whether you want to create a new project or open an existing one. It does not matter what I choose, it will always end up in the main window staying minimized. When going over the minimized Window in the Taskbar, Aero-Peek shows only the Menubar (File, Edit, etc...). Clicking on it doesn't bring it up. I already tried to reinstall SFM several times but it does not help. I also let Steam check the local files and it said that 28 files were unable to read and it will download them again from the server but it also didn't help anything. Please help me.
< >
กำลังแสดง 1-15 จาก 33 ความเห็น
In AeroPeek, is one of the options Windows? If yes try and click on that the select Layouts and from there click reset layouts.

If that doesn't work or is not an option, hover your mouse over the taskbar Icon, when aeropeek shows you the window right click on it and select maximize, see if that opens the SFM session.

If that doesn't work, hover your mouse over the taskbar Icon, when aeropeek shows you the window right click on it and select size, your cursor should change into an arrow that points in 4 directions. Move to the minimized SFM window and try to resize the 4 sides into something you can see. Once you can see the SFM menu bar, try the Windows, Layout method I described above.

If nothing works, this is your last resort as you have already tried to validate your cache files (good job on that)... Make sure you have a backup of your custom content (move it out of the SFM folders), also make a copy of your modified gameinfo.txt file found in Usermod. Now go into your Steam Client and find Source Filmmaker in the All Software area of your Library, Right click and select Delete Local Content. Yup, Delete It, then reinstall.
Thanks for responding. Unfortunately the first three suggestions won't work. I cannot even right-click the window in AeroPeek. :(
I already tried deleting the Local Content and reinstalling SFM,
Also deleting the SourceFilmmaker-Folder in "Steam->SteamApps->common" first and then deleting the Local Content and reinstalling it didn't work
AND I tried to uncheck the option that adapts the local files with the files in the Steam Cloud, because I thought that maybe the problem is in a file which the Steam Cloud stores for me. After that I repeated the deleting folder-, deleting Local Content- and Reinstalling-stuff.
I'm really running out of ideas... ^^'
Did you uninstall properly, the way I said to do it? or did you just delete files?
I deleted folders additional to the deleting through the library, after it didn't work the normal way.
But I guess I found my problem. I didn't right-clicked it and selected "Delete Local Content". I always went to "Properties -> Local Files -> Delete Local Application Content".
So I guess, that should make the difference... hopefully..
I don't think so, that is they are both the same delete routine
Hmm... :/
Should I reinstall Steam?
Don't think so, unless you want to refresh all your games as well. For me that would be a 2 or 3 day effort...
I watched your video ( ) and did everything step by step, so, after 4-5 tries, I am pretty sure, that reinstalling Source Filmmaker won't solve my problem.
Is there anything, except SFM itself, that could cause it to stay minimized (or crashing in general) ?
A registry entry, If you do do an unimstall, make sure that you close Steam and reboot your computer before reinstalling, that should clear left over registry entries. OR grab something like CCleaner and purge the registry of anything related to SFM (if it comes up).
I rebooted my computer and purged the registry with CCleaner.
BUT there was one "unused file extension" (hopefully Google Translator did a good job. ^^) which always remained, no matter how often I tried to get rid of it. oO
* I rebooted my computer and purged the registry with CCleaner before I reinstalled it.
Yes, if you google that one you find it always comes back, it has noting to do with SFM anyaway. reboot and reinstall SFM, hopefully this will work for you
I already rebooted und purged the registry before the last reinstalling. :/
One of my friends told me, that SFM maybe doesn't work, because of the last steam pipe update. He said, that's an update which rearranges source files and can sometimes cause Games and Programms based on Source to crash. Or something like that...
Ah, I've been having this problem, but no one responded to my thread. Glad I'm not the only one with this problem. I did try to use later versions of sfm, and let me say it doesn't work, as far as I know. I'll try again and let you know if you should do it or not.
Reinstalling Steam solved the problem. So, if anything else doesn't work for you too, I recommend you that.
< >
กำลังแสดง 1-15 จาก 33 ความเห็น
ต่อหน้า: 15 30 50

Source Filmmaker > กระดานสนทนาทั่วไป > รายละเอียดกระทู้