Source Filmmaker

Source Filmmaker

Jayy Aug 4, 2015 @ 11:39am
Unable to load ifm.dll error
Hello,

So as of a few days ago, my sfm began to give me this error.. I was unsure how to fix it so I looked in the older sfm discussions and found some possible answers.. I tried to opt in and out of beta participation and I tried to reset configs in SDK.. Neither worked. I look in my files and I had all 4 of the files in the tools folder, including the ifm.dll.

Please help!

- Jayy :maxwell:
< >
Showing 1-15 of 16 comments
Pte Jack Aug 4, 2015 @ 8:49pm 
This may not work, but try it anyway, When you launch SFM, instead of selecting Launch SFM, select the Launch SDK option. Find "Reset Game Configurations" and click on it. Answer OK to the prompts. Close everything including Steam. Relaunch STEAM and try SFM again.
Jayy Aug 4, 2015 @ 8:51pm 
Alright, let me try that.
Zappy Aug 5, 2015 @ 1:36am 
Originally posted by Pte Jack:
Close everything including Steam.
And the computer, as it messes with system environment variables, which, at least in Windows 7 for me, very often required a reboot to take full effect.
Jayy Aug 5, 2015 @ 8:33am 
I forgot to mention, this began happening with the recent Windows 10 update.. Could that be the problem in itself?
Pte Jack Aug 5, 2015 @ 8:47am 
I'll find out in about an hour if it is... Just starting the trek to upgrade computers now. First machine is at 3% installed. But a quick question on the side, did you check your Graphics Card manufacturer's website for a Windows 10 Driver for your card? It might not be the answer to your problem, but with SFM, one never knows.
Last edited by Pte Jack; Aug 5, 2015 @ 8:50am
Zappy Aug 5, 2015 @ 11:50am 
Originally posted by Jayy⁵:
Could that be the problem in itself?
Not for me, going from Windows 7 to 10.
Pte Jack Aug 5, 2015 @ 7:42pm 
I'm on a laptop that I've just updated to Win10, I have a AMD Radeon HD5800 series embedded Chipset. I haven't upgraded to the Win10 Drivers for it yet and everything is rendering just the same as it did with Win8.1 without upgrading drivers. So I don't think Win10 that is causing your problem as far as I can see from my experience so far. I do find SFM slower at loading things in Win10, but that may simply be because this is the first load I've done. Won't know until I use it more.
zfan121 Aug 5, 2015 @ 7:48pm 
In BIN folder for SFM there are two C++ redistributable installers (one for 64 and one for 86) run both of these and this should fix it.
I tried it on my laptop (a new Asuse 2 in 1 with a Nvidia Geforce 840M intergrated graphics card) And it now launches SFM no problem.
Jayy Aug 7, 2015 @ 11:43am 
Well, whilst looking through older forum posts.. I saw that someone said going to

C:\ProgramFiles(x86)\Steam\SteamApps\common\SourceFilmmaker\_CommonRedist\vcredist\2010

and repairing the vcredist_x64 and x86 and it worked... Not sure why, but it did.
Pte Jack Aug 7, 2015 @ 12:52pm 
Well Jayy, if you want to fiddle around with core programs used by SFM and really screw things up, help yourself. Your computer. But if your not highly advanced computer savvy, I wouldn't suggest you do it...
Jayy Aug 7, 2015 @ 12:55pm 
Yeah, it was a risk, I guess But it worked, and that's all I wanted. Thanks for all the help :)
Dai Jun 16, 2016 @ 9:31am 
Originally posted by Jayy⁵:
Well, whilst looking through older forum posts.. I saw that someone said going to

C:\ProgramFiles(x86)\Steam\SteamApps\common\SourceFilmmaker\_CommonRedist\vcredist\2010

and repairing the vcredist_x64 and x86 and it worked... Not sure why, but it did.

exactly how did yuo "repariring" those files?
Feral Oct 4, 2016 @ 2:25pm 
Originally posted by D:
Originally posted by Jayy⁵:
Well, whilst looking through older forum posts.. I saw that someone said going to

C:\ProgramFiles(x86)\Steam\SteamApps\common\SourceFilmmaker\_CommonRedist\vcredist\2010

and repairing the vcredist_x64 and x86 and it worked... Not sure why, but it did.

exactly how did yuo "repariring" those files?

I had the exact problem, but just managed to fix it no problem. Just click on both x64 and x86 for the computer to run em, and when it asks to repair then you repair it. Close out, restart steam. Load it up. Best of luck. It helps to also Reset Game Configuration as well.
Dai Oct 4, 2016 @ 10:47pm 
Originally posted by FarrMan94:
Originally posted by D:

exactly how did yuo "repariring" those files?

I had the exact problem, but just managed to fix it no problem. Just click on both x64 and x86 for the computer to run em, and when it asks to repair then you repair it. Close out, restart steam. Load it up. Best of luck. It helps to also Reset Game Configuration as well.
Now I'm having this problem instead:
https://youtu.be/8U081i9Fsds
Originally posted by Pte Jack:
This may not work, but try it anyway, When you launch SFM, instead of selecting Launch SFM, select the Launch SDK option. Find "Reset Game Configurations" and click on it. Answer OK to the prompts. Close everything including Steam. Relaunch STEAM and try SFM again.
I did that but it did not work :(
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Date Posted: Aug 4, 2015 @ 11:39am
Posts: 16