Source Filmmaker

Source Filmmaker

Jekyde Jun 1, 2014 @ 10:56pm
Checksum error?
I don't know if there was an update or something, but I do know that I haven't changed anything with my SFM. One day my model was working, the next it isn't.

This is the error I'm getting:

Any help would be appreciated, thank you!
< >
Showing 1-15 of 33 comments
Pte Jack Jun 1, 2014 @ 11:03pm 
Sometimes this happens for custom models that are using the sme path\model names of a model that has already been cached in SFM. I find that when this happens, closing and restarting SFM fixes the problem (most times)...
Jekyde Jun 1, 2014 @ 11:08pm 
Yeah I tried that. There was a looooong list of this before I searched for help, and it's something with the Aperture Scout model, so I removed it from my gameinfo since I never use it. Now there's only four lines instead of a full page saying the above.

I'm not sure what else to do.
Pte Jack Jun 1, 2014 @ 11:11pm 
I posted the aperture scout model, hmmm, the way I did him and compiled him using the SFM sdk tools, he should not affect any other model. Unless you are using the GMod version of him. If that's the case, he is available in the SFM workshop now.
Last edited by Pte Jack; Jun 1, 2014 @ 11:13pm
Jekyde Jun 1, 2014 @ 11:27pm 
I'll check it out, though I'm not too concerned with that one right now. I had created a whole new scout by using MDL hexer, and I never had any issues with it until just now. I haven't added anything new to SFM and the model was working fine just last week. I tried subscribing to the Aperture Scout a moment ago, thinking it might fix something but no. I still have this going on:

The bones are there, but the texture is missing. I looked at your tutorial to see if I could fix that (where you're intentionally screwing up downloading the Fem!Sniper), but that isn't the same issue I'm having. This is pretty sudden and without me downloading anything.
Last edited by Jekyde; Jun 1, 2014 @ 11:27pm
Jekyde Jun 1, 2014 @ 11:28pm 
At least now it isn't filled with that checksum error. There's only a few lines.

EDIT: I spoke too soon. This is what I get when I clear the console and load that model:
Last edited by Jekyde; Jun 1, 2014 @ 11:33pm
Pte Jack Jun 2, 2014 @ 9:20am 
Your problem is with scout models that lie in a "\player\" path. The it might be "game\something\player\scout.mdl" and the original "game\tf\player\scout.mdl". This is the problem of using hexed game models. If the hierarchy of 2 (or more) models that use the same \path\modelname.mdl" and have the same hierarchy, SFM can't determine which model is which.

I hate the way the Windows 8 file search works now but, what you have to do is to ferret out all scout.mdl models and see which one is causing the problem by either renaming the mdl file or temporarily moving it.

Jekyde Jun 2, 2014 @ 2:33pm 
Hrm. Alright. The only scout models I have are the original TF2 model, and mine which is a copy of the original with the paths changed via MDL Hexer. They're in two different folders (one is "tf_movies" or just "tf", and mine is "johnny"). What's odd is that they were working just fine before I added the Aperture Scout to the gameinfo and then everything broke.

So, basically, find everything named "scout.mdl" and remove it to see which one is causing the problem? Once that's done, then what? I'll be missing one of my models, wouldn't I? I want to keep the original to be able to have him and my own model in the same video/poster.

Sorry about all of the questions. This is kinda frustrating since I just made a poster with this model and now poof-gone. I'm hoping I won't have to hex it again. It isn't hard, no. But it's just time consuming with changing all the original paths.
Jekyde Jun 2, 2014 @ 2:35pm 
Alright, so.. I went into my johnny folder, which is:


and changed scout.mdl into johnny.mdl, and it comes up as an error. The bones are there, but he's just one huge red flashing error now.
R234 Jun 2, 2014 @ 2:37pm 
Renaming the model isn't enough, you need to hex it too:
Jekyde Jun 2, 2014 @ 2:44pm 
It's already hexed. Read back up at the top. I created Johnny from the original scout.mdl. Made his own folder, hexed him, and he's been working fine for the last year. I had downloaded the Aperture Scout (I think it was the gmod version), and kept it to its own folder instead of tossing it into usermod. But I never added it to my gameinfo file.

I did that a few days ago, next thing I know my Johnny isn't working any more. I keep getting a checksum error. That's the issue.

Thanks for the attempt to help, though! It's very appreciated.
R234 Jun 2, 2014 @ 2:58pm 
If it's throwing checksum errors saying it's looking for scout.mdl then it's usually because it wasn't hexed...

But then I've had models behave as if they were hexed even though the hex editor said they weren't, so there's gotta be something else we're missing...
Jekyde Jun 2, 2014 @ 3:18pm 
Yeah I do really think there's something else. This model has been working top notch for the last year. I looked at the date he was created and it's 7/12/13.

I don't know what happened. He was just working last week when I made my most recent poster. I can only blame it on the Aperture Scout that I added into the gameinfo file.

I might have to start all over after all. Delete the johnny folder (saving the textures I did of course) and rehex the original Scout. I just.. really don't want to.
Jekyde Jun 2, 2014 @ 3:19pm 
I was thinking that I'm having this issue also because I never changed johnny's model to johnny.mdl. It's still scout.mdl, which might be causing some conflict with the original. I have.. no idea. My knowledge about this stuff is rudimentary at best.
R234 Jun 2, 2014 @ 3:28pm 
Wait, so it's the same name? It's not hexed then. That's what hexing is all about, making a copy of a model's files, give it a different name, and modify the MDL file in a hex editor to link to the new name...
Jekyde Jun 2, 2014 @ 3:49pm 
It *is* hexed... I keep saying this over and over again. I just didn't change the original name because it has its own complete folder. I've never had a problem with it until I downloaded the Aperture Scout model.

Like I mentioned, I had this model for a year and I've used BOTH the original scout and Johnny in one picture before with absolutely no problems. You can keep the names the same. My medic (hans) has the same name as the original medic.mdl. All of these models are in their own custom private folder, not in the usermod folder all cluttered together.

I probably should have changed it to johnny.mdl in the beginning, but since there wasn't a problem I kept it as scout.mdl.
< >
Showing 1-15 of 33 comments
Per page: 15 30 50

Date Posted: Jun 1, 2014 @ 10:56pm
Posts: 33