Synergy

Synergy

View Stats:
Synergy > General Discussion > Topic Details
Problems with multiplayer
Will this game ever be updated to function without port forwarding or the hamachi nonsense? If this is the case, please contact me.
Originally posted by Uncle Sam:
Sorry guys, I just realized I don't have that password anymore. This is too much effort. If the game ever gets updated to a modern day multiplayer, please do tell. Port forwarding like this just isn't fun. If my friend too, has to do all this, well.. It won't work out. Thanks for your help anyways
< >
Showing 1-15 of 32 comments
Ishnifan Jan 28 @ 1:13am 
@uruk-hai do you have half-life 2? because its required
Originally posted by i have no idea for a name:
@uruk-hai do you have half-life 2? because its required

Half life 2, it's episodes, BM:S, half life: source, the whole package, sir.
- - Jan 28 @ 7:05am 
Port Forwarding is only used if you're connected through a Router and is not necessarily 'needed' but is used to guarantee the data packets are being sent to the correct PC and not just sent in hopes the correct one picks them up. If it is not configured correctly it will not work.

Some ISPs block certain ports, so it could be your ISP that is causing the problem. You would need to investigate or call your ISP to find out if they are blocking the ports you need open.

Never use Hamachi, programs like this open your system to hackers unless you really know what you're doing!
Originally posted by Sobeit:
Port Forwarding is only used if you're connected through a Router and is not necessarily 'needed' but is used to guarantee the data packets are being sent to the correct PC and not just sent in hopes the correct one picks them up. If it is not configured correctly it will not work.

Some ISPs block certain ports, so it could be your ISP that is causing the problem. You would need to investigate or call your ISP to find out if they are blocking the ports you need open.

Never use Hamachi, programs like this open your system to hackers unless you really know what you're doing!

Thanks for the advice, I knew hamachi was a scam all along.. Still good to hear it from an expert though. I was trying to play with a friend of mine, sven_coop we tried first, but that had the same issue. Whatever the issue is, I can't get to play with my friends, which is sad as we were really eager to play. I don't know why games are still using these old tech things, stuff like this could be so much easier.. Well.. It's not my place to complain as it won't solve anything.. However I would enjoy a more suitable multiplayer xD I'd love to play, as would my friends.
However.. Anyone know a different way..?
- - Feb 5 @ 2:28am 
I just don't understand why so many have issues with this when I've never had a problem...

All I have done is open ports 27010 thru 27030 in my router setup and created a listenserver.cfg in ...\Steam\steamapps\common\Synergy\synergy\cfg\ containing:

hostname "My Server"
rcon_password "my rcon password"
sv_password "player password"

All I need to do is open Synergy and load a map via the console and it works, always has. In fact it was getting annoying when testing a map and others were joining the server that prompted me to create the cfg to add a password.

I open the full range of ports Synergy can use so I'm guaranteed the one it decides to use is opened. It defaults to a 6 player server this way and is password protected so only those I give the pass to can join.

The only time I have had issues was when I opened a single port and Synergy, for whatever reason, couldn't use that port and defaulted to another. Since opening all ports it can use I've had no issues unless my router or network was acting up.

Your firewall can also be an issue, but in my case, before I added an exception, it automatically popped up a message asking me if I wanted to allow it and add an exception so I did. This was a 1 time thing and I haven't had to mess with the firewall settings again.
Last edited by - -; Feb 5 @ 2:33am
Well, if it was my firewall, it wouldn't say something concerning port forwarding.. Because that seems to be the issue with me and my friends.. We just can't get it done. And as you said, Hamachi is very tricky, so using that's also not gonna work out.
- - Feb 5 @ 3:53am 
So you're getting a message about forwarding ports? you never mentioned it but if so, what is the specific message and whats generating it? Your firewall wouldn't say anything about forwarding but yes it can have ports blocked.
Well no, it's a message saying "Connection Error, Connection Refused". I looked it up online and a dozen pages say it's due to port forwarding going wrong. It's all I know..
If the game gets updated.. And the port forwarding connection is replaced with modern time multiplayer connection mechanics, hundreds of people can be helped.
Connection Refused makes me think it is a firewall problem. Your game is being broadcasted to the master servers, but when someone joins, it is most likely stopped at your firewall.
You can look through the Windows Firewall part of this comment for some info:
http://steamcommunity.com/app/17520/discussions/0/154644928866025620/#c154644928866349885

You should be able to go to control panel, security, Windows Firewall, allow a program and browse to Steam\steamapps\common\Synergy\synergy.exe Could also add srcds.exe and hl2.exe just in case. Then set it to allow.
Okay, well I've went to the windows firewall and it's allowing both sven coop and Synergy through the firewall.. So that can't be it.
- - Feb 5 @ 3:49pm 
You need to check the firewall advanced settings for Synergy, inbound, allow all ports for UDP and TCP. Just because Synergy is listed in the general settings doesn't mean it is properly configured.
Originally posted by Sobeit:
You need to check the firewall advanced settings for Synergy, inbound, allow all ports for UDP and TCP. Just because Synergy is listed in the general settings doesn't mean it is properly configured.

I've tried a whole lot of things but nothing seems to lead me to "Advanced Firewall Settings for Synergy".
- - Feb 6 @ 2:54am 
Originally posted by Uncle Sam:
Originally posted by Sobeit:
You need to check the firewall advanced settings for Synergy, inbound, allow all ports for UDP and TCP. Just because Synergy is listed in the general settings doesn't mean it is properly configured.

I've tried a whole lot of things but nothing seems to lead me to "Advanced Firewall Settings for Synergy".

are you using Windows, what version, and have you installed different firewall or using windows provided firewall.
< >
Showing 1-15 of 32 comments
Per page: 15 30 50

Synergy > General Discussion > Topic Details