Dead Space

Dead Space

View Stats:
Dead Space > General Discussions > Topic Details
Rambone Jan 15, 2013 @ 8:08am
Game launches then crashes (Fixed)
I know there are a bunch of you guys out there that were having problems with Dead Space 1 +2 Crashing after launching it from Steam. The crash happens after launching the game from Steam and it loads up into a black screen and it seems like it is adjusting the resolution but then almost immediately after it crashes with a generic error. I recently had this issue and have no idea what initially triggered it. Searching the internet I found the following solutions (which none of them worked BTW).

*Disable all HID devices in the Control Panel (Included my 360 controller)
*Set Dead Space to Run in Compatibility Mode (Tried all configurations) + Administrator
*Disable Anti-Virus / Firewall
*Run CCleaner and Re-install C++ 2010 distribution packages
*Set your Nvidia Control Panel Card settings to Performance.
*Edit your Settings.txt file and put the correct resolution of your monitor.

There was another solution that I wasn't about to try because it basically is asking for trouble which was disabling Windows Management Instrumentation.

One of the solutions mentioned that there should be a settings.txt file in the C:\Users\(Account Name)\Appdata\Local\Electronic Arts\Dead Space directory ... (might also be an EA Games directory) but I could not locate this directory nor the settings.txt file to edit.

I was about to breakdown and buy the 360 version but then I finally resolved the crashing.

What I did.....
I own Dead Space 2 on Steam and I copied that settings.txt file and created a new directory which I wrote above for Dead Space. Simply launching Dead Space after this did not work. I had to edit the settings file and Disable V-SYNC and also set the Mouse Sensitivity from .05 to .02.

Trying to Launch the game again fixed the problem!!!! I can now play Dead Space 1 with no more crashing after launching from Steam!!!

If you do not own Dead Space 2 and are having the same issue, I will paste my settings.txt configuration below so that you can create your own settings.txt file.

Good luck guys and enjoy this truly incredible game! If this worked for you, just drop a comment :).

(If your running on an older graphics card you might need to adjust some of the graphic related settings down to false. You can probably still do this in game as well.)

Audio.AltNameColor = false
Audio.MusicVol = 1.00000000
Audio.Output = 0
Audio.SFXVol = 1.00000000
Audio.Subtitles = true
Audio.VoiceVol = 1.00000000
Control.AimAssistEnabled = true
Control.AimingPosition = 1
Control.ControllerSensitivity = 2
Control.FireButtonControls = true
Control.InvertX = false
Control.InvertY = false
Control.MouseSensitivity = 0.20000000
Control.Shock = true
Controls.AcL.X = 0x1105FF7E
Controls.AcL.Y = 0x0003100E
Game.PDiff = 1
Game.Played = 1
Misc.LastSaveSlot = 0
QualityOptions.ActorMotionBlur = true
QualityOptions.Bloom = true
QualityOptions.Blur = true
QualityOptions.ConfigType = 1
QualityOptions.Decals = true
QualityOptions.Distortion = true
QualityOptions.DoF = true
QualityOptions.EdgeAA = true
QualityOptions.Flare = true
QualityOptions.Glow = true
QualityOptions.HighLightQuality = true
QualityOptions.ManipColor = true
QualityOptions.ShaderQuality = 2
QualityOptions.Shadows = 2
Window.Fullscreen = true
Window.Gamma = 0.50000000
Window.Height = 1080
Window.Hz = 60
Window.Left = 0
Window.MessageNotification = 1
Window.State = 0
Window.Top = 0
Window.VSync = false
Window.Width = 1920


-------------------------------------------------------------

Update 8/12/2019

Another fix

As soon as you see the EA logon press ctr+alt+del and click on task manager.
Right click on dead space and go to Set Affinity... and click on all processors then click on the last CPU you have so the game only runs on 1 CPU. after that my game will run normally. :steamhappy:

Last edited by Rambone; Aug 12 @ 6:21am
< >
Showing 1-15 of 49 comments
Maxen May 22, 2013 @ 1:43pm 
Thanks! This worked for me.

Whenever I tried to play the game I got this error: "Could not initialize display hardware. Please restart Dead Space." Creating this settings.txt in the directory "C:\Users\(Account Name)\Appdata\Local\Electronic Arts\Dead Space" fixed it.
Deathlok May 25, 2013 @ 7:19am 
So you are saying to copy your config in Notepad and create a settings.txt with it in the appropriate Steam folder? The game is crashing because such a file does not already exist after installation?

I haven't had any crashes, but I did have all sorts of problems because of the game's application of vsync. I had to disable vsync in-game and use nvidia's control panel to force vsync and triple buffering before I could get past the ever-popular invisible-wall-blocking-the-doorway scripting bug.

I would like to know what this does:

Controls.AcL.X = 0x1105FF7E
Controls.AcL.Y = 0x0003100E

I already have a settings.txt file in my C:\Users\[me]\AppData\Local\Electronic Arts\Dead Space folder, but the above entries are not in it.

I'm wondering if they improve the mouse acceleration?
Last edited by Deathlok; May 25, 2013 @ 1:29pm
Rambone May 27, 2013 @ 9:39am 
You can give it a try at the very least, those two entries you listed were included in the dead space 2 settings.txt so I am not sure if this will improve mouse acceleration or not in DS1.

Originally posted by iamwileecoyote:
So you are saying to copy your config in Notepad and create a settings.txt with it in the appropriate Steam folder? The game is crashing because such a file does not already exist after installation?

I haven't had any crashes, but I did have all sorts of problems because of the game's application of vsync. I had to disable vsync in-game and use nvidia's control panel to force vsync and triple buffering before I could get past the ever-popular invisible-wall-blocking-the-doorway scripting bug.

I would like to know what this does:

Controls.AcL.X = 0x1105FF7E
Controls.AcL.Y = 0x0003100E

I already have a settings.txt file in my C:\Users\[me]\AppData\Local\Electronic Arts\Dead Space folder, but the above entries are not in it.

I'm wondering if they improve the mouse acceleration?
cerebrus Aug 23, 2013 @ 2:04am 
Thank you for that file, it solved my black screen problem.
Kampfhirn Aug 25, 2013 @ 11:20am 
Tanks a lot, your file solved the problem for me too, but only in combination with setting the 'Dead Space.exe' to 'Run as Administrator!
Thx again!
It'sCrisBro Oct 27, 2013 @ 4:20pm 
Still having the same issue :(
It'sCrisBro Oct 27, 2013 @ 4:20pm 
Any help?
CNMG Dec 13, 2013 @ 10:05pm 
Easiest fix goes as follows:
1.Drop your screen resolution to 1024 x 768 (default for Dead Space 2)
2. Launch game (if this fix works,game will launch with no issues), go to visual settings, and set the in-game resolution to what your computer screen's resolution should be.
3. Close the game and set your screen resolution back to normal. Game should now work.
As a side note, using this fix works on most launch issues for any game. That's if the game stops working IMMEDIATELY; if your game is crashing during play, resolution is not the problem.
Last edited by CNMG; Dec 13, 2013 @ 10:06pm
It'sCrisBro Dec 13, 2013 @ 11:45pm 
Originally posted by cnmollon:
Easiest fix goes as follows:
1.Drop your screen resolution to 1024 x 768 (default for Dead Space 2)
2. Launch game (if this fix works,game will launch with no issues), go to visual settings, and set the in-game resolution to what your computer screen's resolution should be.
3. Close the game and set your screen resolution back to normal. Game should now work.
As a side note, using this fix works on most launch issues for any game. That's if the game stops working IMMEDIATELY; if your game is crashing during play, resolution is not the problem.


Thanks! I just solved the issue i went to local files and created a settings files like the post said, i used 1200 x 800 and the issue solved! Thanks so much.
Kvaki Dec 30, 2013 @ 7:46pm 
tried all stuff. game still crashes on launch for me D: . any other suggestions?
Last edited by Kvaki; Dec 30, 2013 @ 7:46pm
Zealot Jan 6, 2014 @ 4:17pm 
Creating the 'settings.txt' with the text 'MasterMike569' provided worked for me. Plus I enabled V-Sync after I became able to start the game finally and the game worked normally after that. Thanks a lot man!
It'sCrisBro Jan 7, 2014 @ 9:07am 
Originally posted by Kvaki:
tried all stuff. game still crashes on launch for me D: . any other suggestions?

Try modifying it to other screen res. maybe it work, you have nothing lose.
Kvaki Jan 7, 2014 @ 11:36am 
This helped Disable all HID devices in the Control Panel (Included my 360 controller)

found the problem. Was Jumiamp; HID thing for a winamp remote for my pc or phone

thanx!
Last edited by Kvaki; Jan 7, 2014 @ 11:36am
Dorky_Biker Jan 17, 2014 @ 1:44am 
I've seen several say that disabling HID devices worked well for them, however, when I do that it disables my mouse and that simply isn't an acceptable solution for me. I'd rather not have to purchase a non-HID compliant mouse so are there any other ways around this?
Sgt.Shepard Jan 28, 2014 @ 11:36am 
SOMEONE HELP ME ABOUT THISS ERROR!!!
< >
Showing 1-15 of 49 comments
Per page: 15 30 50

Dead Space > General Discussions > Topic Details