Spore
Spore > General Discussions > Topic Details
Shadow Jul 20, 2013 @ 7:48pm
~Fixing~ the Spore Errors 2000 and 1004 TWO methods that WORK!
http://steamcommunity.com/sharedfiles/filedetails/?id=193458424


---------------------------------------------------------------------------------------------------------
METHOD #1 - This is an automated fix and works 90% of the time if you have the default Steam instalation path -
---------------------------------------------------------------------------------------------------------

A now friend of mine and good guy LordLeeCH threw together this small program that adds all the needed missing files from Spore, essentially fixing the 2000 and 1004 errors.

{LINK REMOVED}

Download that file, I have people that can vouch it isn't a virus.

You need to extract it then run it as admin so it can add the files

Works on Win8 as well. I have Win8 and it works perfectly for me.

Also if the file doesn't work for you or is dead just shoot me a PM or comment on my profile and I'll get it fixed asap

From ProphetOfDio - If anyone is having trouble with Win7, may work on vista and XP
NOTE TO EVERYONE HAVING PROBLEMS:
Select the app, and got to Properties.
Under Compatibility, select Run As Administrator.
It should work perfectly after that.

From LordLeeCH
You might not have permission to access the registry using my program. You either a.) need to be logged in as administrator or b.) need to run the program as an Administrator. The program does this EXACTLY:
1.) Finds to the path to Steam in the registry
2.) Creates the paths based on the Steam path
3.) Adds all values to the registry.

---------------------------------------------------------------------------------------------------------
METHOD #2 - This is the manual method, it requires more work but it's really not hard and ensures that the problem is fixed -
---------------------------------------------------------------------------------------------------------

The part that everyone is missing is this; if you have 32 bit windows the path is DIFFERENT than 64 bit windows. If you dont know if you have 32 bit or 64 bit, my program figures it out for you. So far it has been tested under Windows vista 32 and 64, Windows 7 32 and 64, and Windows 8 - I believe it was 64.

When launching Spore on Windows 7 or 8, it is common for it to crash and give the error 'Configuration Script Failed [2000]' followed by 'Could not find a needed package. The data directory is missing or corrupt. [1004]'. This is due to registry keys being deleted at every launch. To fix this, you need to enter the registry strings below to keep the right file path.

In layman's terms basically the game is trying to look for the files it needs in order to run in Folder A but Folder A does not exist therefore it throws an error. It can't find the files because the directions telling the game where to find the files are wrong, so we need to fix those directions and everything will be fine.

You must first go to your registry by looking for Regedit and running it as admin
From there you'll need to go to:

> HKEY_LOCAL_MACHINE

> SOFTWARE

> Wow6432Node (it may look different on a 32 bit machine)

> Electronic Arts

> SPORE

Now you should see some string values, some will be missing while others will be pointing to the wrong file path. If a file I mention isn't there then simply create it.
Essentially DataDir should point to your Data folder within Spore. Installoc would point to the aforementioned Spore folder and then you'd create two 32 bit word values by going to Edit then New. One should say ReIndexYesOrNo with a value of 0 and another one named InstallCompleted with a value of 1
Now I see the problem a lot of the time is that they're actually pointing to the wrong path as shown below

AppDir = SPORE
DataDir = C:\Program Files (x86)\Electronic Arts\SPORE\Data\
InstallLoc = C:\Program Files (x86)\Electronic Arts\SPORE
PlayerDir = My Spore Creations

DataDir and AppDir try to find an Electronic Arts folder and there simply isn't one (Folder A and this part only applies if you're using the Steam version) instead the file path would most likely look something like this

C:\Program Files (x86)\Steam\steamapps\common\Spore\Data

For DataDir
For the Installoc it would simply stop at Spore

C:\Program Files (x86)\Steam\steamapps\common\Spore

If you need further help here is a video I did. DO NOT copy the exact file paths I have as I don't use the same installation path for Steam that you do.

http://steamcommunity.com/sharedfiles/filedetails/?id=162604087

If all else fails take your SPORE/Spore directory folder and place it on your desktop for example and update the registry to reflect the new file path. Should work now.
Last edited by Shadow; Aug 19, 2015 @ 8:22pm
< >
Showing 1-15 of 84 comments
Ryan Jul 21, 2013 @ 1:40am 
It says there was a problem and then it closes
Ryan Jul 21, 2013 @ 1:40am 
Nvm
brittabergren Jul 21, 2013 @ 7:04am 
It stops working after 2 seconds
smonk gernade Jul 21, 2013 @ 7:23am 
Yea I loaed it and it said there was a problem and it closed
ProphetOfDio Jul 21, 2013 @ 10:15am 
NOTE TO EVERYONE HAVING PROBLEMS:
Select the app, and got to Properties.
Under Compatibility, select Run As Administrator.
It should work perfectly after that.

Using Windows 7 64-bit, and this worked perfectly for me, thanks Shatto!
Shadow Jul 21, 2013 @ 10:35am 
Originally posted by TheKido:
http://steamcommunity.com/sharedfiles/filedetails/?id=162266673
Yes this program does that for the user so he doesn't have to mess around in his registry and possibly mess something up also for the lazy and less tech savvy people :P
Shadow Jul 21, 2013 @ 10:38am 
Originally posted by ProphetOfDio:
NOTE TO EVERYONE HAVING PROBLEMS:
Select the app, and got to Properties.
Under Compatibility, select Run As Administrator.
It should work perfectly after that.

Using Windows 7 64-bit, and this worked perfectly for me, thanks Shatto!
Thanks for that. I have yet to test this on Win7 so I can add any extra troubleshooting so I'll edit the post and add your tip in there
rosaliadolly Jul 21, 2013 @ 11:38am 
IT WORKS THANKS YOU
Celestialfox Jul 21, 2013 @ 1:14pm 
I've done all of this but im still having the 1004 problem
Yea it doesn't work for me either. I ran it as administartor and the app installs and installs but I still get the errors
Shadow Jul 21, 2013 @ 2:10pm 
What is your OS?
Celestialfox Jul 21, 2013 @ 7:38pm 
Im using windows 7 64-bit
Shadow Jul 21, 2013 @ 10:42pm 
Originally posted by CarterxG3:
Im using windows 7 64-bit
Did it read your version and say it was completed?
♦ Kai ♦ Jul 22, 2013 @ 6:52am 
TY this helped so much !
< >
Showing 1-15 of 84 comments
Per page: 15 30 50

Spore > General Discussions > Topic Details
Date Posted: Jul 20, 2013 @ 7:48pm
Posts: 84