Museum of Mechanics: Lockpicking

Museum of Mechanics: Lockpicking

View Stats:
Crashes immediately on MacOS 12.2
Shows the logo, then makes a noise and crashes. Hope it can be fixed!
< >
Showing 1-15 of 17 comments
Came here to report the exact same Crash
MacOS Catalina 10.15.7 (19H1323)
shonias Jan 13 @ 10:27pm 
And on 12.01
Wolf Jan 14 @ 6:03am 
Same on Mojave 10.14.6
It looks like the Steam API isn't present in the application. The Unity plugin .dlls are there, but not steam_api.bundle.
coppin Jan 15 @ 7:53am 
Same on Big Sur 11.2.1
Johnnemann  [developer] Jan 15 @ 7:16pm 
Thanks for reporting this! I will get on this and see what I can do as far as a fix goes. Sorry for the problems!
Not sure if this is the same issue, I'm on Windows 10, the logo shows up, there's a sound of boots landing or something, my camera pans up and starts to spin, after about a couple of seconds the game crashes.
kneppis Jan 17 @ 8:15am 
Same issue with mac os 12.1. Plays the two intro logos, and directly crash half a second after displaying a room.
Last edited by kneppis; Jan 18 @ 8:13am
Johnnemann  [developer] Jan 17 @ 10:35am 
Can someone send their player log to me at johnnnemann at dimbulbgames dot com? It will be in ~/Library/Logs/Dim Bulb Games/Museum/Player.log
hacydlfb Jan 17 @ 11:02pm 
I sent. (Mac OS Monterey 12.1)
kneppis Jan 18 @ 8:13am 
Sent for Mac OS 12.1
Last edited by kneppis; Jan 18 @ 8:13am
Johnnemann  [developer] Jan 18 @ 7:40pm 
Thank you all for your logs, they were very helpful. I believe I identified the issue (an incompatibility with the input library) and have fixed it in the latest update. Please let me know if you're still seeing problems.
hacydlfb Jan 18 @ 10:47pm 
Dowloaded last update. Problem not fixed. After first launch (after update) system show me error and suggested me to download some software (i guess it's apple's developer software). I downloaded it and launch game again. Same issue - game crash after 2 load screens.

Mac OS Monterey 12.1
kneppis Jan 19 @ 2:53am 
Still same issue with MacOS 12.1. I see in player.log that it fails to load library, but the /Users/xxx/Library/Application Support/Steam/steamapps/common/Museum of Lockpicking/Museum of Mechanics - OSX.app/Contents/Frameworks/MonoEmbedRuntime/ folder doesn't exist. The framework folder only contains the files: UnityPlayer.dylib libMonoPosixHelper.dylib libmonobdwgc-2.0.dylib. I'll send you the new player.log.
Same Error in Big Sur 11.6
< >
Showing 1-15 of 17 comments
Per page: 1530 50