Crysis
Crysis > General Discussions > Topic Details
conejeitor Mar 30, 2015 @ 8:31pm
What bottlenecks Crysis nowadays?
Well, now that I finally solved the crashing issue I´m playing Crysis. This game looks like a 2014 game!. However I´m getting about 25-30 FPS, which sucks.
With MSI afterburner I can see that I´m using 60% or less of my GPU (gtx 970) and that four cores are being used (FX 8350) under 50%. So both GPU and CPU have plenty to grow. Same is said for RAM (<50%) and VRAM (30%).
So, what do you guys think is bottlenecking this game? Why is not running at 60 FPS (like Crysis 3 does in my system).
Thanks.
Last edited by conejeitor; Mar 31, 2015 @ 3:17am
< >
Showing 1-15 of 20 comments
juxstepin Mar 30, 2015 @ 11:08pm 
I think you need to turn off v-sync in crysis options. I have lower specs and get much better FPS.
AMD Athlon X-2 3.3oc / gtx 750ti 2gig /8gig ram.
Nalydyenlo Mar 31, 2015 @ 12:27am 
It could be a driver issue. I'm a Radeon user and I found that using an older GPU driver give me a 15-20 fps boost. Still, even at that, with my AMD fx-6300 and Radeon r9 270 combo, I'm only getting 30-60 fps (avg. 35+) with all settings at 'very high'. It's playable enough like that though, thanks to the motion blur, but for a really smooth experience, I put everything at 'high'. Turning v-sync off doesn't make a difference apart from giving it some nasty screen tearing.
Last edited by Nalydyenlo; Mar 31, 2015 @ 12:29am
conejeitor Mar 31, 2015 @ 3:15am 
I have everything maxed, and if I reduce the settings to high or turn off vertical sync, I don´t get any gain in FPS. It´s playable, but given my system, I expect to play most modern games over 40 FPS. It must be a driver issue right?
Nalydyenlo Mar 31, 2015 @ 4:26am 
Well it's an old enough game, and like I said, the up to date drivers for my Radeon GPU have a negative impact on performance. Going back to drivers from early 2014 helped me. Who knows, maybe it's the same kind of situation for nVidia cards.
juxstepin Apr 1, 2015 @ 2:07am 
Im using the Nvidia control panel options to set v-sync to 60 as the ingame option wants to set it to 30fps.

It seems you can set shadows to medium and get a nice boost without much visual quality loss.

I need to play around with the options some more but with everything but shadows and shaders set to high or highest gets me a almost solid 60 fps. I just recently finnished the underwater/space level and it NEVER dropped under a smooth 60fps and my god did it look and play amazing......
kingfish_ak Apr 1, 2015 @ 12:51pm 
Originally posted by conejeitor:
Well, now that I finally solved the crashing issue I´m playing Crysis. This game looks like a 2014 game!. However I´m getting about 25-30 FPS, which sucks.
With MSI afterburner I can see that I´m using 60% or less of my GPU (gtx 970) and that four cores are being used (FX 8350) under 50%. So both GPU and CPU have plenty to grow. Same is said for RAM (<50%) and VRAM (30%).
So, what do you guys think is bottlenecking this game? Why is not running at 60 FPS (like Crysis 3 does in my system).
Thanks.

it is an old archaic program. your gear is better suited for dx11, and 12 where as an older powerhouse system could play crysis at higher fps with maxxed settings, but it wouldn't be a long gaming session due to over heating. < this theory brought to you by Kingfish.\
ak
conejeitor Apr 1, 2015 @ 7:51pm 
Originally posted by juxstepin:
Im using the Nvidia control panel options to set v-sync to 60 as the ingame option wants to set it to 30fps.

It seems you can set shadows to medium and get a nice boost without much visual quality loss.

I need to play around with the options some more but with everything but shadows and shaders set to high or highest gets me a almost solid 60 fps. I just recently finnished the underwater/space level and it NEVER dropped under a smooth 60fps and my god did it look and play amazing......
Excellent! Thanks. By reducing the shadows to high I´m getting 50 fps. All the rest is in very high.
McSwifty Apr 5, 2015 @ 2:16pm 
The game is mostly CPU-lmiited... a 970 should handle this no problem if coupled with the right processor. Hell, a 670 from two years ago could do the same.

That said, 20-30fps is really low for your system. Even my Phenom II 965 coupled with a 970GTX can max the game at over 60fps, with dips into the 40s in firefights and complex scenes, at 1920x1080.

A couple things immediately come to mind.

For one, instead of setting it right to Very High settings, just use High instead and then force some of the effects (like sunshafts and such) through the config files or console. There is really no major difference between the two, but there is a pretty significant performance hit.

Second, even though the game is technically DX10-native, it was one of the earliest games to implement it, and it's not very good. Once again, you're going to take a pretty good performance hit for no real tangible benefit as far as graphical fidelity goes, and not to mention, it causes crashes and glitches in some of the later levels of the game. I'd recommend running the game in DX9 mode using the "-dx9" command line option. (Yes, even in Windows 7/8.1)

Also, as it's already been pointed out, VSync can be wonky with the game too. I'd recommend forcing Adaptive Vsync via the control panel, rather than using traditional Vsync. This will allow it to run at a full 60fps, and won't tank your frame rate down into the 30s when it dips below that.
IronChariot Apr 11, 2015 @ 4:07pm 
its still messed up that todays technology can't run a solid 60 fps. I'm getting between 40 and 60 fps with a gtx 970 coupled with a 1-5 3570k at stock. It doesnt matter if i turn the antialiasing entirely off either and put things like shadows on medium. really???
conejeitor Apr 11, 2015 @ 6:22pm 
Yeah, I thought shaddows were doing it but after lowering them I´m still getting way low fps. Way lower than for crysis 3. I think it´s just poor programing.
Did you check to see if you have power saving features enabled that are scaling your CPU speeds back or are disabling cores?

Try a program called - Process Lasso. With it you can set your PC's power mode to high performance mode and get the most out of those 8 cores. I have the fx9590 myself and found this program to keep the 8 cores fully available for whatever tasks supports them.
Superjoint420 Apr 16, 2015 @ 5:35pm 
I get well over 100fps on Crysis max settings with 4xMSAA on a FX-8320 (OC'D to 4 ghz) and a R9 290 (OC'D to 1000mhz core and 1275mhz x4 memory.)
Blue Pulasky Feb 17, 2016 @ 9:31am 
Just to add to this conversation after a while...I'm aware that this is an old thread.

My system specs are GTX970, i5-2500k (OC 4.3ghz).

I run into the same problem...low fps. In 1080p...avg was about 55/60, but in some action scenes it was going down to 35/40fps in very high.

What McSwifty said helped me a lot, switching to dx9 (AA x8) and activating adaptive v-sync in geforce panel made the crysis jump to ALMOST constant 60fps at 1440p.

I also activated FXAA and MFAA from the panel, i didn't see a huge graphic improvement, although it didn't made my fps worst.

BTW...I deactivated v-sync from everywhere and the game keeps running at 60fps lol it doesn't bothers but I couldn't benchmark the game.

Last edited by Blue Pulasky; Feb 17, 2016 @ 9:32am
JOGAN Feb 18, 2016 @ 10:38pm 
I know this is an old thread but it seems like the OP had the same issue I had when I tried to play the game today.

There seems to be a problem with the refresh rate and 1080p resolution or higher (?). To fix it I read here that you have to press alt+enter which seems to put the game in borderless full screen window mode.

Worked for me.
Last edited by JOGAN; Feb 18, 2016 @ 10:38pm
Blue Pulasky Feb 19, 2016 @ 2:23pm 
Thanks man!
< >
Showing 1-15 of 20 comments
Per page: 15 30 50

Crysis > General Discussions > Topic Details