Velvet Assassin

Velvet Assassin

View Stats:
 This topic has been pinned, so it's probably important
Eremiten [SWE] Jul 22, 2013 @ 4:54pm
How to fix critical error at startup ATI/AMD/NVIDIA
"For games that use SDK versions before 2.7.1 the PhysX Legacy Installer must also be installed."

To download this you can go here first then click a link provided in the info text.

Page to get the link to the download of the LATEST PhysX Legacy Driver [www.nvidia.com]

(This is not the one you must install, it's the one below (link to picture showing where to click). A simple Google search didn't do it in this case to get the LATEST PhysX Legacy Driver)

Picture showing where they provide you with the LATEST Legacy PhysX Driver [i.imgur.com]
(It's the link within the beautiful blue circle.)

Now go and enjoy this stealth [www.blogcdn.com] game!
Last edited by Eremiten [SWE]; Jul 22, 2013 @ 4:57pm
< >
Showing 1-15 of 210 comments
hyperrabbit Jul 27, 2013 @ 3:26am 
It works! Problem with error solved. Thank you!
Eremiten [SWE] Jul 27, 2013 @ 9:51pm 
Originally posted by hyperrabbit:
It works! Problem with error solved. Thank you!

Happy to help!
SOFBear Aug 22, 2013 @ 6:28pm 
Yup, had the same issue and this fix worked 100% Just finished the game. Addictive, sometimes a chore due to oddly spaced check point saves.
_veleron Sep 21, 2013 @ 9:37am 
Thanks! Pinned.
Sick Sep 25, 2013 @ 1:44pm 
thank you !!
Cai Cai-Vilu Oct 7, 2013 @ 3:21am 
Worked for me, game runs fine now, thanks
Troik Oct 20, 2013 @ 9:22pm 
I knew I would find the answer here, you guys are awesome! :coin:
マニアック Nov 30, 2013 @ 2:28pm 
I didn't know old games need another PhysX, tranks dude, you helped me!
hoover185 Dec 25, 2013 @ 10:00pm 
Thank you, thank you, thank you!
Pink Panties Dec 26, 2013 @ 10:38pm 
Thank you!
Adept Jan 1, 2014 @ 8:16pm 
Thank you.
oXiDe Jan 3, 2014 @ 6:15pm 
Thanks.
OMAR Jan 20, 2014 @ 8:16pm 
very ty
Nyyx Feb 2, 2014 @ 7:13am 
Works now, spank you <3
casfuen Feb 2, 2014 @ 8:29am 
thk
< >
Showing 1-15 of 210 comments
Per page: 15 30 50