Assassin's Creed

Assassin's Creed

Freezing
Everytime I try to play this game for some reason it will randomly freeze for no reason. I lowered specs thinking my computer wasnt able to handle it on highest but even then it will randomly freeze..I can't play with it frequently happening. Any solutions?
< >
Showing 1-15 of 35 comments
=AC3=Lhotse5 Oct 3, 2012 @ 8:20pm 
It's the same for me. I searched on the forums on the net and found out that it has something to do with the Ubisoft server in Montreal. The solution ? Switch Steam to offline mode, restart Steam, turn off the power on your modem or router so that it can't connect to Ubisoft, restart your game. I know it sounds a little strange but it worked for me. Text me back and let me know if it fixed it.
Link didn't work
=AC3=Lhotse5 Oct 3, 2012 @ 10:32pm 
copy & paste it on your browser, it's not a link. anyway, just do what i posted. it worked for me, it's a known issue.
juanem87 Oct 3, 2012 @ 11:51pm 
I have the same problem that you, just use the offline mode on Steam and turn of your WI-Fi or discontect your internet conection. That worrks for me
DrKhorne Oct 4, 2012 @ 12:20pm 
i have the same problem (+ my gamebad didn´t work anymore in ac) since today. yesterday everything works fine. there was a steam update today. maybe it has somethinh to do with that.
KleinMo Oct 4, 2012 @ 12:43pm 
Same problem here ._.
Gürmaci Oct 4, 2012 @ 6:36pm 
disconnecting from internet works for me too.
Anam Oct 4, 2012 @ 10:37pm 
this is happening for me as well. I'll try disconnecting from steam first, then try something so drastic as disabling my internet connection. Sounds drastic, not to mention painful.

Was working fine day before yesterday. Anyone have any idea as to when this might be fixed?
Last edited by Anam; Oct 4, 2012 @ 10:38pm
Anam Oct 5, 2012 @ 12:00am 
going offline in Steam helped the problem, but didn't eliminate it. Disabling my internet connection fixed it, though. Thanks for the tips.
Limpy Oct 6, 2012 @ 6:43am 
Block assassins creed with your firewall (probably need a better firewall than windows)

This will stop the game from connecting to ubi and therefore should stop the freezes associated with it
maxtortheone Oct 6, 2012 @ 10:27am 
Got the freezing after kill and firewall blocked the game. Didn't do it any more but now it just started to freeze at what seems to be fixed intervals.
God Oct 7, 2012 @ 5:29pm 
I have analyzed the network traffic and there is one more ip that you need to block. Maybe this IP has been added recently (I'm writing this october 2012), but in addition to adding the entries

216.98.48.53 127.0.0.1
216.98.48.18 127.0.0.1
216.98.48.57 127.0.0.1

to the hosts file, you also need to add a fourth entry:

216.98.48.133 127.0.0.1

This specifically relates to the fixed interval 60 seconds freeze bug and the freeze whenever you kill someone, collect a flag etc.

Hope this helps for the few people still playing this!
Last edited by God; Oct 7, 2012 @ 5:31pm
tan Oct 8, 2012 @ 11:33am 
Originally posted by Spiritless:
I have analyzed the network traffic and there is one more ip that you need to block. Maybe this IP has been added recently (I'm writing this october 2012), but in addition to adding the entries

216.98.48.53 127.0.0.1
216.98.48.18 127.0.0.1
216.98.48.57 127.0.0.1

to the hosts file, you also need to add a fourth entry:

216.98.48.133 127.0.0.1

This specifically relates to the fixed interval 60 seconds freeze bug and the freeze whenever you kill someone, collect a flag etc.

Hope this helps for the few people still playing this!
OMG! man! this is the best answer!
after firewall block of the game it indeed started to freeze at fixed periods of time.
and after adding these 4 ip addresses in hosts file game now runs smoothly!! and there is no need to disconnect from the internet.
thanks a lot!
i'll repost your answer to forum tread.
Please, can you give me the steps to enter this 4th IP adress please?

I'm using windows 7 64 bits

Thanks for the help
< >
Showing 1-15 of 35 comments
Per page: 15 30 50

Date Posted: Oct 3, 2012 @ 3:56pm
Posts: 35