Unreal Tournament 2004

Unreal Tournament 2004

papalazarou Jul 29, 2015 @ 5:20pm
windows 10
anyone playing this on windows 10??
< >
Showing 1-15 of 137 comments
papalazarou Jul 29, 2015 @ 5:37pm 
ok 64bit exe works but no 32bit on nvidia
Vyr'sai Jul 30, 2015 @ 12:08am 
It's crashing on me when I put it in fullscreen but windowed is fine.
Since when did Windows 10 release?
Z.Ibrahimovic Jul 30, 2015 @ 2:28am 
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:
Z.Ibrahimovic Jul 30, 2015 @ 2:28am 
Originally posted by IAmTheWalrus!:
Since when did Windows 10 release?

yesterday officially, the beta already a year ago.
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:

Works for me on Win 10 x64, GeForce gtx 560ti with newest drivers.
Vyr'sai Jul 30, 2015 @ 8:25am 
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:
Awesome!
papalazarou Jul 30, 2015 @ 10:39am 
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:



Thanks a lot, that worked perfectly :)
Zed Aug 1, 2015 @ 4:15am 
Originally posted by Captain Swagga:
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:

Works for me on Win 10 x64, GeForce gtx 560ti with newest drivers.

560ti with newest drivers?

I'm using 550 ti, and whenever I try to get the new drivers, they fail and my resolution ♥♥♥♥s up and my PC automatically begins downloading the proper drivers.
Creekster Aug 1, 2015 @ 9:27am 
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:
Unfortunately, in Windows 10 the game does not show up in windows explorer, so I cannot get to the ini file.
Z.Ibrahimovic Aug 1, 2015 @ 9:55am 
Originally posted by Creekster:
Unfortunately, in Windows 10 the game does not show up in windows explorer, so I cannot get to the ini file.

Right click on the game in your Steam library. Options > local files > browse local files

Or browse on 'ut2004' in the start menu,
Last edited by Z.Ibrahimovic; Aug 1, 2015 @ 9:55am
Creekster Aug 1, 2015 @ 10:13am 
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:
Found the ini file and changed to False. Works great!! Thank you!!
Daemonicus Aug 2, 2015 @ 2:06pm 
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:

That worked amazing. Also running the application file as administrator solved some other crashing issues for me.
MartyWF Aug 2, 2015 @ 2:59pm 
I have Windows 10 Home x64 and I changed the Unreal 2004.ini file to load opengl and now it works a lot smoother for the 32 bit.I changed the ReduceMouseLag=false mentioned earlier in this thread. Do a search for vsync and turn it off. This can give you hundreds of Frames Per Second.These tweaks completly bypass the d3d render problems. These changes should clear up a lot of D3D Renderer issues/errors too.
Here is a look at how I did it...

[Engine.Engine]
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=Engine.NullRenderDevice
RenderDevice=OpenGLDrv.OpenGLRenderDevice

Put a ";" in front of RenderDevice=D3DDrv.D3DRenderDevice

Remove the ";" to set the command for opengl rendering
RenderDevice=OpenGLDrv.OpenGLRenderDevice

The reduce mouse lag trick can optionally be done for opengl too.

[OpenGLDrv.OpenGLRenderDevice]
ReduceMouseLag=False

It should be the 10th listing below [OpenGLDrv.OpenGLRenderDevice]. So set it and save it.

You may want to tweak the cache megs elsewhere in the ini . I only found these two listed below. Set the cache to something like 64 megs or so for more performance. Here is the settings as I did them for the engine and sound performance tweaks.

[Engine.GameEngine]
CacheSizeMegs=64

[Editor.EditorEngine]
UseSound=True
CacheSizeMegs=64

Also you check in the ini for FullscreenViewport x and y. Then adjust these to your widescreen resolution ( if it's not listed in opengl combo box in the games settings). Here is what I did with mine(For my1080p monitor). Set the settings for your screen's resolution. Do not change the WindowedViewportX=640 and WindowedViewportY=480. Just change the FullscreenViewportX and FullscreenViewportY to your resolution you want.

[WinDrv.WindowsClient]
WindowedViewportX=640
WindowedViewportY=480
FullscreenViewportX=1920
FullscreenViewportY=1080

Set the FOV to your widescreen type for your resolution.
Here is my FOV Changes for my 1080p monitor:

[Editor.EditorEngine]
FovAngleDegrees=105.000000

You have to look in the [Editor.EditorEngine] for FOV and change it to you widescreen FOV. It should be the 10th one down from the [Editor.EditorEngine] listing.

Don't forget to save often while editing it too. The last thing you need is a headache redoing this whole tweak because you get distracted.

This is what I changed mine too. You have can change this in 32 bit (UT2004.ini) and the 64 bit (ut2004-win64.ini) if you want too. Dont forget to set the exe for both to permanetly run as administrator.
Cheers and good luck...

MartyWF
Last edited by MartyWF; Aug 2, 2015 @ 5:27pm
Originally posted by Z.Ibrahimovic:
There is an issue since Windows 10 build 10162 and I found out what is causing this issue.

Open your UT2004.ini located in your UT2004/System folder and find (ctrl + f to open searchbox)
[D3DDrv.D3DRenderDevice]
ReduceMouseLag=True

Change this into False and you should be able to boot the game again.
If you want to reproduce the error, go ingame to this setting and tick it on again. Instant crash :UT2004flak:


How do you get .ini file ?
< >
Showing 1-15 of 137 comments
Per page: 15 30 50