Unreal Tournament 2004

Unreal Tournament 2004

View Stats:
[SM] Striker Aug 16, 2015 @ 3:33pm
Here's how to fix the Windows 10 crash when running Direct3D mode.
This wrapper from DX8 to DX9 will solve the crash when loading UT2004 in Direct3D mode under Windows 10. http://enbdev.com/convertor_dx8_dx9_v0036.htm

Direct Download: http://enbdev.com/enbconvertor_dx8_dx9_v0036.zip

To use it, just extract the contents into /SteamApps/Unreal Tournament 2004/System/

While that works... it would be nice if Epic open-sourced the renderer like they did with UT99, so people can really make UT2004 shine.
Last edited by [SM] Striker; Aug 17, 2015 @ 12:03am
< >
Showing 1-13 of 13 comments
Originally posted by Striker:
While that works... it would be nice if Epic open-sourced the renderer like they did with UT99, so people can really make UT2004 shine.
That would indeed be nice...we can hope...
papalazarou Aug 16, 2015 @ 10:19pm 
it does work well. However i seem to have gained a rather messy AO effect, its not too bad but there all the same.
[SM] Striker Aug 17, 2015 @ 12:02am 
Originally posted by papalazarou:
it does work well. However i seem to have gained a rather messy AO effect, its not too bad but there all the same.
Just use the converter. Don't use ENBSeries to avoid that.
papalazarou Aug 17, 2015 @ 3:07am 
Originally posted by Striker:
Originally posted by papalazarou:
it does work well. However i seem to have gained a rather messy AO effect, its not too bad but there all the same.
Just use the converter. Don't use ENBSeries to avoid that.


yep that works but the gamma is now greyed ouit and its too dark, strange indeed
[SM] Striker Aug 17, 2015 @ 5:28pm 
Just adjust your gamma and whatnot in-game, should work.
papalazarou Aug 18, 2015 @ 8:36am 
Originally posted by Striker:
Just adjust your gamma and whatnot in-game, should work.

its not adjustable in game anymore, and its too dark by quite a lot. So manually doing that every time is a pain
[SM] Striker Aug 18, 2015 @ 10:11am 
Originally posted by papalazarou:
Originally posted by Striker:
Just adjust your gamma and whatnot in-game, should work.

its not adjustable in game anymore, and its too dark by quite a lot. So manually doing that every time is a pain
Works fine for me. Are you sure you're in Direct3D mode, and not in OpenGL? (which is bugged and incomplete in UT2004) Also, be sure you're not using the leaked D3D9 renderer, as it's buggy as well.

Make sure your renderer is set to Direct3D, then use the brightness slider. If it still doesn't work, reset to defaults then try again.

Also, I can't stress enough... If you're still using it- don't use ENB Series (delete d3d9.dll and the d3dx9_**.dll files), just use the converter I linked to. Don't modify it's configuration, there's no need to.
Last edited by [SM] Striker; Aug 18, 2015 @ 10:02pm
papalazarou Aug 19, 2015 @ 11:55am 
Originally posted by Striker:
Originally posted by papalazarou:

its not adjustable in game anymore, and its too dark by quite a lot. So manually doing that every time is a pain
Works fine for me. Are you sure you're in Direct3D mode, and not in OpenGL? (which is bugged and incomplete in UT2004) Also, be sure you're not using the leaked D3D9 renderer, as it's buggy as well.

Make sure your renderer is set to Direct3D, then use the brightness slider. If it still doesn't work, reset to defaults then try again.

Also, I can't stress enough... If you're still using it- don't use ENB Series (delete d3d9.dll and the d3dx9_**.dll files), just use the converter I linked to. Don't modify it's configuration, there's no need to.


thanks yes that worked like a charm :)
Captain_Tea Aug 19, 2015 @ 7:18pm 
Thanks for the fix!
Hello,

I tried this fix for my CD version, not my steam version, as I had the same errors posted here on my machine. Here is the new error I have now that I have installed this fix:

UT2004 Build UT2004_Build_[2005-11-23_16.22]

OS: Windows NT 6.2 (Build: 9200)
CPU: GenuineIntel PentiumPro-class processor @ 2396 MHz with 1023MB RAM
Video: NVIDIA GeForce GT 740M (5362)

General protection fault!

History: FD3DTexture::Cache <- FD3DRenderInterface::CacheTexture <- FD3DRenderInterface::HandleCombinedMaterial <- FD3DRenderInterface::HandleCombinedMaterial <- FD3DRenderInterface::SetShaderMaterial <- FD3DRenderInterface::SetMaterial <- RenderStaticMesh <- FDynamicActor::Render <- RenderLevel <- NvidiaLogo.myLevel <- FLevelSceneNode::Render <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

I did nothing but add the files from the provided link into my system folder, and now I have this problem. Any help at all is welcome. It should be noted that the "OpenGL Fix" and the "ReduceMouseLag Fix" have also failed to work. Before this I was receiving the
LockRect failed: D3DERR_DEVICELOST error. Now it is a General Protection Fault.


EDIT:
I fixed ALL Of my problems by simply uninstalling and reinstalling, and forcing it to run in a windowed mode at 1280X960 resolution. Not a single problem now and I didn't even need to use the patch.
Last edited by Jyrral Von Ueberwald; Aug 20, 2015 @ 11:50pm
GregH94 Aug 30, 2015 @ 2:20am 
Worked immediately. Pin this.
[SM] Striker Aug 30, 2015 @ 9:10pm 
Originally posted by Jyrral Von Ueberwald:
Hello,

I tried this fix for my CD version, not my steam version, as I had the same errors posted here on my machine. Here is the new error I have now that I have installed this fix:

UT2004 Build UT2004_Build_[2005-11-23_16.22]

OS: Windows NT 6.2 (Build: 9200)
CPU: GenuineIntel PentiumPro-class processor @ 2396 MHz with 1023MB RAM
Video: NVIDIA GeForce GT 740M (5362)

General protection fault!

History: FD3DTexture::Cache <- FD3DRenderInterface::CacheTexture <- FD3DRenderInterface::HandleCombinedMaterial <- FD3DRenderInterface::HandleCombinedMaterial <- FD3DRenderInterface::SetShaderMaterial <- FD3DRenderInterface::SetMaterial <- RenderStaticMesh <- FDynamicActor::Render <- RenderLevel <- NvidiaLogo.myLevel <- FLevelSceneNode::Render <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

I did nothing but add the files from the provided link into my system folder, and now I have this problem. Any help at all is welcome. It should be noted that the "OpenGL Fix" and the "ReduceMouseLag Fix" have also failed to work. Before this I was receiving the
LockRect failed: D3DERR_DEVICELOST error. Now it is a General Protection Fault.


EDIT:
I fixed ALL Of my problems by simply uninstalling and reinstalling, and forcing it to run in a windowed mode at 1280X960 resolution. Not a single problem now and I didn't even need to use the patch.
You were likely using the wrong version of the converter. That tends to happen if you have cubemaps enabled with the older converter. Either that, or your files were corrupted. Try using the direct link above, and see if you can finally run fullscreen in that case.
Last edited by [SM] Striker; Aug 30, 2015 @ 9:12pm
Striker,

It turns out it was just a problem with trying to run on 1600X900 or larger, so running it in a window at a lower resolutiong worked perfectly fine for me. As I actually prefer to run this game in a window, I will not be needing to use the converter. I appreciate your help.
< >
Showing 1-13 of 13 comments
Per page: 15 30 50

Date Posted: Aug 16, 2015 @ 3:33pm
Posts: 13