Half-Life: Blue Shift

Half-Life: Blue Shift

Minerva Sep 29, 2017 @ 10:53pm
General FPS Problem with Half-Life Engine
I am in distress. Over the years I've tried getting into Half Life. "Half Life" has always run absolutely fine with no bugs and no problems. Opposing Force runs fine as well. However, I noticed one of the most terrifying and reoccuring problems with running, as far as I know, Gold-Source games. In Blue-Shift, I'm at the point of the game where Barney prepares to interact with the large orange crystal on Xen.

Whenever that Crystal entitiy is in frame, the game ♥♥♥♥♥ itself. I recognized this behavior immediatly, because the majority of the Half-Life Horror Mods: "Afraid of Monsters" (Directors Cut) and Cry of Fear run like this. This pains me so so much because I've tried a lot of things to try and fix these games in order to play them as intended but ultimately failed so many times I gave up on even trying.

But back then, I figured it was the poor modding that seems to only want to work exclusively on certain systems, (All the computers that I've don't seem to have, and I've tried them on at least two, one from 2010 and another from 2014). But now that I see Blue Shift acting the same way I was hoping we could collectively pin down this problem and put it on the spotlight for all of us to pin its ears back.

To describe what actually happens when this problem occurs, whenever the bad entity is on the screen, (in this case that dame crystal), the framerate immediately drops to 10 and below, all the while the sounds stutter horrendously: the usual "pow" of the pistol is now a "p o w-w -w ch ch ch". Turn your view away from the entity the games doesn't like and the frames jump back up to their acceptable range of 30-45-60 and the sounds are normal.

I really can't say what cause this problem but now that I see it happening on more than one computer throughout different source games I was hoping that I'm not the only one suffering this problem and that there is some sort of solution other "than try a different computer", (which I actually have a XP Laptop from like 2005 or something so I can try that as a last resort, I've been told older systems run Afraid of Monsters better.)
< >
Showing 1-1 of 1 comments
Snow 344 Oct 15, 2017 @ 4:57am 
Try to check the updates of your drives. Some months ago, I had that issue to all of my GoldSrc games when I updated nvidia drivers, but then it came other update that fixed.
There's no much things to do.
You can try running in different render modes, reduce resolution, disable Vertical Sync and write on console "fps_max 999" and "fps_override 1" (Last one can make you lag in multiplayer)
< >
Showing 1-1 of 1 comments
Per page: 15 30 50