GRID

GRID

Voir les stats:
GRID > Discussions générales > Détails du sujet
How to: 1080p/1440p/1600p/4k/Surround/Eyefinity for Win7/8/10
GRiD is locked into lower resolutions than your monitor(s)? It's GRiD that fail to find the real amount of video memory available.

I found this fix on Codemaster forum long time ago (now unavailable). For windows 7 users, look at the Windows 7 section of this post. For Windows 8/8.1/10 with one monitor, see also the first section. Windows 8/8.1/10 with multiple monitors, look at the second section.

================================================
======== Windows 7/8/8.1/10 single monitor =========
========== Windows 7 multiple monitors ============
================================================


First, locate and do a backup/archive of this file:

\Steam\steamapps\common\grid\system\hardware_settings_restrictions.xml

Right clic on the original file and open it with Notepad. Scroll down to the bottom, locate this line:
<data> <res mem="270" maxWidth="3840" /> </data>

And remove it;

<data> </data>

Save and close the file. Open GRiD, go to Options, then Graphics Settings and every resolutions your pc can display should be available, including bezel compensated ones.

Here's a screenshot of my 3x1080p+bezel compensation setup in Windows 7;
http://i.imgur.com/o1YlndN.jpg

This fix have been tested at;
-1920x1080 native 1 monitor (FullHD)
-5760x1080 native 3 monitors (Nvidia Surround)
-5760x1080 native 3 monitors (AMD Eyefinity) thanks to "Harvest Lee"
-5940x1080 bezel compensated 3 monitors (Nvidia Surround +2x75px of bezel)
-2560x1440 native 1 monitor (QuadHD) thanks to "bigi"
-4k (UltraHD) thanks to "Keibou"


No confirmation at;
-2560x1600 (WQXGA)


================================================
======== Windows 8/8.1/10 multiple monitors =========
================================================


If you use more than one monitors, there is some specific limitation on both AMD and Nvidia while rendering the game with multiple screens on most recents version of Windows.

AMD Eyefinity specific fix;

-Disable Eyefinity completely -Create a new group from scratch but don't add any custom or compensated resolutions -Switch to the new group -Follow the Windows 7 instruction in this post

Nvidia Surround specific fix;

-Disable the surround setup by reverting it to "Activate all displays" -Create a new "Span displays with Surround" group from scratch but don't align the tiles (no bezel compensation, it MUST stay to 0) -Apply to switch to the new config. -Follow the Windows 7 instruction in this post.

Any compensated resolutions with Win8/8.1/10 added to the registry seems to break GRiD. The specific reason is unknow, but at least with that fix it work! :D

Thanks to "Harvest Lee", without I'm a good part of that fix would not be available. :)
Dernière modification de [RTQC]GenR-NoDataQC; 19 déc. 2017 à 18h59
< >
Affichage des commentaires 1 à 15 sur 46
thank you, sir.
Good to know that my post helped! :)
doesn't work for me the game won't start up at all when i remove the restrictions
3 Asus VG24AH monitors
2 660ti 3gb SC SLI
1 hdmi to dvi cable
2 hdmi to hdmi
You must remove only the stated lines, and save back.

If it the game fail to start, try to change the value instead;

<data> <res mem="270" maxWidth="5760[/b]" />
</data>[/code]
Dernière modification de [RTQC]GenR-NoDataQC; 16 juil. 2014 à 19h20
Tested on my side with both native and compensated resolution replacing the default one, and both seems ok. Give me an update, I will refresh my first post. :)
Dernière modification de [RTQC]GenR-NoDataQC; 16 juil. 2014 à 19h21
changing the maxwidthi only didn't work, :( , but I was able to get it to 1920x1080 when I followed these instructions on this site

http://www.switchbl8.nl/blog/2013/04/racedriver-grid-in-fullhd-1920x1080/#comment-264
, I linked this page to the guy that made that trend.

Would be nice to make use of my 3 monitors though. I posted this on Codemaster's tech help forum for the GRID series, specifically named Racedriver: GRID , but got no responds, no surprise seeing as how its the oldest game.

http://forums.codemasters.com/discussion/2752/racedriver-grid-won-t-play-5760x1080-have-log#latest
Dernière modification de Harvest Hearts; 24 juil. 2014 à 1h01
OmG my reading comprehension fail, yes it started up when i type

<data>
<res mem="270" maxWidth="" />
</data>

however in the graphics it was left blank for all the options I think I'm going to have to change the script like i did to get it to 1920 for my bezel correction 5850 on the first link i sent posted
changing the scrpit like it did to get 1920 didn't work. I restore everything to default except for change i made to restrictions.

Apparently doing it with spaces (four) allows the game to start up aswell with no difference as far as I could tell.

<data>
<res mem="270" maxWidth=" " />
</data>

back to just using your way the Graphic settings is
Detail: Custom
Resolution: Blank
Refesh Rate: Blank
Multisampling: Level 8
Vsync: off (i tried on as well)
Aspect Ratio: Normal
Gamma: 1
Dernière modification de Harvest Hearts; 24 juil. 2014 à 1h43
Well, this is really wierd. Could it be a Win8 specific problem? I'm on Win7.

I see that you already did a lot of research and you tried modifiing somes XML. For me nothing really worked until I found the fix from my first post. :(

Not sure it could help but here's my hardware_settings_info;

<graphics_card> <resolution oldHeight="1080" oldWidth="5910" vsync="1" fullscreen="true" aspect="normal" height="1080" width="5910"> <refreshRate rate="144"/> </resolution>

and my hardware_settings_config.xml;

<graphics_card> <resolution oldHeight="600" oldWidth="800" vsync="0" fullscreen="false" aspect="normal" height="600" width="800"> <refreshRate rate="60"/> </resolution>
Dernière modification de [RTQC]GenR-NoDataQC; 25 juil. 2014 à 18h02
Did you deleted both XML from your document after you modified the XML from the install directory (so news ones are created)? :)
Dernière modification de [RTQC]GenR-NoDataQC; 25 juil. 2014 à 18h06
My hardware_settings_config.xml is the same as yours,

I've never deleted the 2 xml in the doucments before but i tried it just now and there was still no difference. However, i did notice that hardware_settings_info (which was in the mydocuments) Didn't have that line you have regarding the resolution. I'll try to type one in and see if i'll work.

It might explain why the game left that setting blank and i'm left with 800x600 with no restrictions
Dernière modification de Harvest Hearts; 25 juil. 2014 à 19h09
alright I've isolated that the problem, its with the xmls in the my documents, they are not saving the correct information. when i open them up every time after i mod they don't have those lines you posted for resolution either in the hardware_settings_info or hardware_setting_config. the backups i've made of the origial xml look nothing like its current form.

I highly suspect its a Windows 8 problem. ( I only got it cause Work kept telling me to get it to work in IT)

Thanks for your help and insight though I'll try this in again the future when I reinstall Windows 7

One last try;

Delete again both files in your documents, and try to increase both the resolution and the memory from "hardware_settings_restrictions.xml"

<data> <res mem="4096" maxWidth="7000" /> </data>

Also switch back to multiple monitors, then back to Surround, but don't create any customs resolution, just to try if this isolate the problem.
Dernière modification de [RTQC]GenR-NoDataQC; 25 juil. 2014 à 21h00
< >
Affichage des commentaires 1 à 15 sur 46
Par page : 15 30 50

GRID > Discussions générales > Détails du sujet