GRID

GRID

View Stats:
GRID > General Discussions > Topic Details
How to: 1080p/1440p/1600p/4k/Surround/Eyefinity for Win7/8/10
GRiD is locked into lower resolutions than your monitor(s)? It's GRiD that fail to find the real amount of video memory available.

I found this fix on Codemaster forum long time ago (now unavailable). For windows 7 users, look at the Windows 7 section of this post. For Windows 8/8.1/10 with one monitor, see also the first section. Windows 8/8.1/10 with multiple monitors, look at the second section.

================================================
======== Windows 7/8/8.1/10 single monitor =========
========== Windows 7 multiple monitors ============
================================================


First, locate and do a backup/archive of this file:

\Steam\steamapps\common\grid\system\hardware_settings_restrictions.xml

Right clic on the original file and open it with Notepad. Scroll down to the bottom, locate this line:
<data> <res mem="270" maxWidth="3840" /> </data>

And remove it;

<data> </data>

Save and close the file. Open GRiD, go to Options, then Graphics Settings and every resolutions your pc can display should be available, including bezel compensated ones.

Here's a screenshot of my 3x1080p+bezel compensation setup in Windows 7;
http://i.imgur.com/o1YlndN.jpg

This fix have been tested at;
-1920x1080 native 1 monitor (FullHD)
-5760x1080 native 3 monitors (Nvidia Surround)
-5760x1080 native 3 monitors (AMD Eyefinity) thanks to "Harvest Lee"
-5940x1080 bezel compensated 3 monitors (Nvidia Surround +2x75px of bezel)
-2560x1440 native 1 monitor (QuadHD) thanks to "bigi"
-4k (UltraHD) thanks to "Keibou"


No confirmation at;
-2560x1600 (WQXGA)


================================================
======== Windows 8/8.1/10 multiple monitors =========
================================================


If you use more than one monitors, there is some specific limitation on both AMD and Nvidia while rendering the game with multiple screens on most recents version of Windows.

AMD Eyefinity specific fix;

-Disable Eyefinity completely -Create a new group from scratch but don't add any custom or compensated resolutions -Switch to the new group -Follow the Windows 7 instruction in this post

Nvidia Surround specific fix;

-Disable the surround setup by reverting it to "Activate all displays" -Create a new "Span displays with Surround" group from scratch but don't align the tiles (no bezel compensation, it MUST stay to 0) -Apply to switch to the new config. -Follow the Windows 7 instruction in this post.

Any compensated resolutions with Win8/8.1/10 added to the registry seems to break GRiD. The specific reason is unknow, but at least with that fix it work! :D

Thanks to "Harvest Lee", without I'm a good part of that fix would not be available. :)
Last edited by [RTQC]GenR-NoDataQC; Dec 19, 2017 @ 6:59pm
< >
Showing 46-48 of 48 comments
Melanie Jan 19 @ 12:15pm 
in the steam sub folder like you mentionned
I'm running Windows 10, 2560x1440 monitor, 1080Ti, and as noted earlier, I also had to delete the "hardware_settings_restrictions.xml" file completely, otherwise my game would either limit the resolution I could use to something really low, or crash on startup. Thanks for the help!
Originally posted by fray_bentos:
I'm running Windows 10, 2560x1440 monitor, 1080Ti, and as noted earlier, I also had to delete the "hardware_settings_restrictions.xml" file completely, otherwise my game would either limit the resolution I could use to something really low, or crash on startup. Thanks for the help!
i had the same problems with crashing after deleting that line and this was exactly what i had to do as well after exhausting the other fix suggestions. W10 as well.
Last edited by nightmare; 17 hours ago
< >
Showing 46-48 of 48 comments
Per page: 15 30 50

GRID > General Discussions > Topic Details