ELDEN RING

ELDEN RING

View Stats:
FPS FIX!!!!!
TURN OFF Hardware-accelerated GPU scheduling it made me go from 45 to 60
< >
Showing 1-15 of 38 comments
I recently turned this off myself because of people reporting stutters in other games. Haven't had a chance to try it myself in this game yet. Curious to hear if it helps others.
Blozzy Feb 24 @ 6:52pm 
On what? Control Panel?
Ayala Feb 24 @ 6:53pm 
And where is that option located?
For people asking, just search the Windows Start menu for GPU scheduling and it'll show up


Or go to Settings, System, Display, and then Graphics settings link in there.
Last edited by WhiteZero; Feb 24 @ 6:59pm
Looking forward to others reports on this.
This works... sort of. Ive gone from 45 to 55 but the game still refuses to fully utilise the gpu.

was sitting at around 40% usage before change
60-70% after the change
Last edited by Wolfbleidd; Feb 24 @ 7:05pm
Middy Feb 24 @ 7:05pm 
Mine was already off. 45-55fps outside, drops to 30 fighting the horse dude. 60 indoors.
Open Settings
Select System > Display tab.
Locate Multiple displays
Click on Graphics Settings.
Select the Change Default Graphics Settings option.
To enable the feature, toggle ON the button next to the Hardware-accelerated GPU scheduling.
Reboot your Windows device to apply the changes.

See More....
JustBazz Feb 24 @ 7:06pm 
didn't make any difference
Originally posted by Wolfbleidd:
This works... sort of. Ive gone from 45 to 55 but the game still refuses to fully utilise the gpu.

was sitting at around 40% usage before change
60-70% after the change
What's the your highest CPU core usage at? You may just be CPU bottlenecked
Originally posted by WhiteZero:
Originally posted by Wolfbleidd:
This works... sort of. Ive gone from 45 to 55 but the game still refuses to fully utilise the gpu.

was sitting at around 40% usage before change
60-70% after the change
What's the your highest CPU core usage at? You may just be CPU bottlenecked
Never been bottlenecked. But, cpu sitting around 30-40%

One other thing, unplug controller = 60fps.

plug controller back in = 35fps now
Originally posted by Wolfbleidd:
Originally posted by WhiteZero:
What's the your highest CPU core usage at? You may just be CPU bottlenecked
Never been bottlenecked. But, cpu sitting around 30-40%

One other thing, unplug controller = 60fps.

plug controller back in = 35fps now
Wow thats bizarre. And your whole CPU sitting at 40 percent doesn't tell us what your main thread looks like. Gotta check your highest used core, if you weren't already.
JustBazz Feb 24 @ 7:12pm 
Originally posted by Middy:
Mine was already off. 45-55fps outside, drops to 30 fighting the horse dude. 60 indoors.
exactly the same for me, really disappointing
Someone on reddit suggests changing your Windows Power profile to Balanced instead of High, somehow that fixed a lot of performance issues for people. Something to try at least.
urabe mikoto (Banned) Feb 24 @ 7:19pm 
It's already disabled here
< >
Showing 1-15 of 38 comments
Per page: 1530 50

Date Posted: Feb 24 @ 6:50pm
Posts: 38