Grand Theft Auto IV: The Complete Edition

Grand Theft Auto IV: The Complete Edition

Ver estadísticas:
miky_ 5 DIC 2012 a las 18:00
Graphics stuck on lowest possible, can't change
When I first loaded it up it was at highest graphics, ran fine, have an awesome laptop. Now it jsut says my graphics setttings exceed their resource limits ---> 202MB / 3011MB (so clearly I have plenty of resources left)... Any suggestions?
< >
Mostrando 1-15 de 56 comentarios
romannfs_CZ 5 DIC 2012 a las 23:23 
Question: I am using a GTX580, HD6990, or other video card with more than 2GB of dedicated video memory and GTA IV is treating my game as if my system were under spec by restricting my graphics options. What can I do?

Answer: We have heard some reports that certain video cards with more than 2GB of video memory may be causing GTA IV to believe the system is under specification even though the computer is powerful enough to run the game with higher settings.

We are in the process of looking into the issue and will update this page, if we can confirm the problem, as soon as we have more information about workarounds or a fix.

Possible workaround:

Create a text file named ‘commandline.txt’ in the main GTAIV folder and put the following statement inside it:

-availablevidmem 2.0

If that doesn't work, try increasing the number to one of the following.

-availablevidmem 3.0

-availablevidmem 4.0

-availablevidmem 5.0

-availablevidmem 6.0

etc.

Note that these command lines can be added immediately after the last quotation mark in the target parameter of the program shortcut.

Locate the shortcut to the video game on your desktop.
Right click the file and select Properties.
Under the shortcut tab, you will see an area that says Target, this will list the exact location of the file within quotation marks.
Modify the Target adding the command line variables after the last quotation mark.
Press apply and start your game via the shortcut.
If you are using Steam, please try:

Properties of game>Launch Options>Add: -nomemrestrict -norestrictions

If the issue still occurs, please be sure to attach a DxDiag file to your ticket and also let us know how much VRAM is detected by GTA at the bottom of the Graphics page.

works for me the first option 'commandline.txt' try
romannfs_CZ 5 DIC 2012 a las 23:29 
I have to laugh buy a game that is 2 years old and does not run me and I must go myself doing something reconfigure te your ass that you can not repair.I hope that GTA 5 will be better from optimized.I'm sorry for my English Czech Republics
Última edición por romannfs_CZ; 5 DIC 2012 a las 23:31
GTA IV was released in late 2008. I received mine on January 2009. It was designed for the xbox 360 and the pc version was just a supplimentary for pc gamers. Never was there a single laptop that was able to run the game during those era. It was designed for the console and desktop. So what can you expect 4 years later?
Última edición por Niko( ͡° ͜ʖ ͡° ); 6 DIC 2012 a las 0:27
miky_ 6 DIC 2012 a las 1:58 
Publicado originalmente por romannfs:
works for me the first option 'commandline.txt'

Sweet thanks, that fixed it
AHDPIOXA 6 DIC 2012 a las 5:44 
"-nomemrestrict -norestriction"
that fixed this problem for me, thanks!
(desktop, steam)
Publicado originalmente por Pop a glock:
Don't game on a laptop
I'm playing on a laptop, just check my GTA IV screenshots.
magnetmannen 6 DIC 2012 a las 14:51 
yeah i had the same problem, its really weak by rockstar to have this many bugs in theyr pc version, but it shows, if a gaming company goes to wide in its gamemaking , they forget where they came from, pc users is where they got started , and pc gaming is where they will end.
and i got all the gta games, but because the gta 4 was so buggy, im not buying gta 5.
miky_ 6 DIC 2012 a las 16:29 
Publicado originalmente por magnetmannen:
but because the gta 4 was so buggy, im not buying gta 5.

Yeah you're definitely not alone on that one
Devoldo 7 ABR 2013 a las 11:47 
This worked for me. Thank you. Bump for the sake of other people's sanity.
Devoldo 7 ABR 2013 a las 11:48 
Just add -nomemrestrict -norestrictions to launch options and all is golden!
sillytoad 22 MAY 2013 a las 2:39 
I had to go up to 25.0 before it would work... from 4000mb available to 2400mb available
PrawnAGE 22 MAY 2013 a las 5:13 
I think this happens when your gpu has more than 2048mb of vram. Glad u got it sorted
TheBlackF0X 22 MAY 2013 a las 9:23 
awesome! now i gotta try it out
L3Gi0n4R 22 MAY 2013 a las 12:23 
I have a problem with this game.I have GTX 660 and Quad Core CPU,but games run max. 25-30 FPS.
TheShadiestShade 15 JUL 2013 a las 2:09 
Publicado originalmente por miky_:
When I first loaded it up it was at highest graphics, ran fine, have an awesome laptop. Now it jsut says my graphics setttings exceed their resource limits ---> 202MB / 3011MB (so clearly I have plenty of resources left)... Any suggestions?
if you download a program that i called GeForce Experience in there you can say optimize and then it will work in the highest :D
< >
Mostrando 1-15 de 56 comentarios
Por página: 15 30 50

Publicado el: 5 DIC 2012 a las 18:00
Mensajes: 56