Grand Theft Auto IV

Grand Theft Auto IV

View Stats:
yHaNw Apr 11, 2013 @ 10:07am
[HELP!!!] GTA IV FATAL ERROR: WTV190 GTA IV FATALERROR: windowsTimerFunctionsValidator::Check() -ReadFromProtectedBuffer: QPCFAILED! - Either reboot or reinstall Gme for Windows LIVE.
i know there's a discussion about this in steam somewhere, but i'm afraid it'll be too old and people might overlook it. i'll copy + paste everything that i actually wanted to comment on that post. Any Gurus or good people out, please help!!! T-T



i have this problem as well! (i'm using windows 8 the basic one, without pro or enterprise) and i have tried everything that was mentioned in the batman AC post...

my problem is very frustrating, because i have encounter in a lot of hiccup along the way, i'll tell you my situation.

1. i downloaded gfwl from the xbox live which is the latest version, because the game seems to need it.
2. i tried installing it, but then it says it have compatibility issues. Then i put it to run in compatibility mode windows 7 and run as admin and yet it still says it have compatibility issues (hiccup number 1)
3. well, i still try to install it, and it managed to finish installing it without a problem (i presume)
4. then i click PLAY, and the game comes with the normal social club stuffs. I manage to get past the the GTAIV logo and the rockstar and rock star north logo.
5. but something bothering me was that there was no gfwl bar on top like the people mentioned.
6. ignoring that, i continue on since i just wanted to play the game. i click play, and the i can see New something at the bottom right of the screen, like it was indicating i was going to start a new mission or when i get in a car. (experience of past gta)
7. and BAM! the error come out!. after then i went through the whole night finding solution and repeating step the steps like uninstalling gfwl and re-installing it again, or keep google.

if anyone know any solution, please please please help me! and please stop linking me to the batman AC link, it didn't help me. i don't know why, but it didn't!!!

sorry for the looong and whiny post, and sorry for the bad english. =(



< >
Showing 1-6 of 6 comments
L3V147H4N Apr 29, 2013 @ 10:49am 
Hellow!!! I HAD the Exact same problem,,, im running win 8 and that error poped UP... SO this is what i did....

First, Unistall GFWL and everything related, Market CLient, Live ID, etc
Second, Install the Latest GTA IV Patch from the Rockstar Site
Third Download GFWL from Microsoft BUT before installing, Right CLick the Installer and choose compatibility for Windows Vista Service Pack 2 and run as Admin
Then and Finally, Go to the SteamApps folder/Common/GTA IV and there locate the GTAIV.exe and right Click and choose compatibility for Vista Service Pack 2,,, That worked for me, im playing right now....

It Should let u login into Windows Live at the start and then work just fine

Hope It Works For U!
yHaNw Apr 29, 2013 @ 8:27pm 
it's okay, i'm using xlive now...
christmas rat boy Aug 19, 2014 @ 2:31am 
Didnt work for me. Ive been trying to fix this for ages now...
Originally posted by L3V147H4N:
Hellow!!! I HAD the Exact same problem,,, im running win 8 and that error poped UP... SO this is what i did....

First, Unistall GFWL and everything related, Market CLient, Live ID, etc
Second, Install the Latest GTA IV Patch from the Rockstar Site
Third Download GFWL from Microsoft BUT before installing, Right CLick the Installer and choose compatibility for Windows Vista Service Pack 2 and run as Admin
Then and Finally, Go to the SteamApps folder/Common/GTA IV and there locate the GTAIV.exe and right Click and choose compatibility for Vista Service Pack 2,,, That worked for me, im playing right now....

It Should let u login into Windows Live at the start and then work just fine

Hope It Works For U!
raulparra38 Aug 19, 2014 @ 8:16pm 
what i did was installed a command line and set the grapics to medium and it worked
virgin Aug 20, 2014 @ 1:30am 
what you no unstall gta v
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Apr 11, 2013 @ 10:07am
Posts: 6