Max Payne

Max Payne

View Stats:
Max Payne > General Discussions > Topic Details
Jawmuncher Dec 6, 2012 @ 4:29pm
Error When Laumching Game
I'm trying to play Max Payne on my Alienware X51 but after the intro movie I get this error

"An error has occured in the graphics engine. Try to downgrade your screen mode and/or other settings by pressing the "options..." button in Max Payne startup dialog. Max Payne requires a DirectX 8 compatible display adapter. Please consult the troubleshooting readme in the installation folder.

Error:setFullscreen - creating the device failed:
D3DERR_DRIVERINTERNALERROR

I have not idea how to fix this and have already tried numerous things over the vourse of 2 hours.
My Specs
Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
NVIDIA GeForce GTX 660
16384 ram
< >
Showing 1-15 of 15 comments
Eremiten [SWE] Dec 25, 2012 @ 5:59am 
What happens if u install the latest patch (version 1.05) manually?
Jawmuncher Jan 1, 2013 @ 11:26am 
It was still the same issue.
However It seems that it was indeed somehow tied to the Resolution and Monitor I was using at the time. I was using a hybrid Monitor Tv which was relatively small. But now that I am using my big screen TV the resolution issue is no more. I know it makes no sense (Since all the resolutions I used on the smaller TV always had the same issue) But im glad it worked itself out.
Bayron Jan 5, 2013 @ 8:38am 
I think it had to do with AA being enabled.
Jawmuncher Jan 23, 2013 @ 8:11am 
Originally posted by Bayron:
I think it had to do with AA being enabled.

Looking back I think it migh have been.
Canadian Muffin Mar 25, 2013 @ 6:24pm 
I run the game fine, and I have a pretty bad computer.
junkiiiii Apr 21, 2013 @ 4:55pm 
This game is a "Payne" (see what I did there?) to run. I get that same error with an "D3DERR_INVALIDCALL". I've searched all over the net and found no solution. All I can say is that if I exit steam and then restart it sometimes the game will work. I don't understand why it works at times and other times it doesn't.
FatuM72 Dec 9, 2013 @ 1:54am 
i play in win 8.1 - simple disable antialiasing
tazmo8448 Dec 9, 2013 @ 2:47pm 
With Win7.1x64 I get the game fails to launch because it can not find an .exe
FatuM72 Dec 9, 2013 @ 7:50pm 
MaxPayne.exe - in "C:\Program Files (x86)\Steam\SteamApps\common\Max Payne"
check compatible with win98 and run app as administrator.
in fullHD resolution u will see the game in window, because i check 1440x900.
Next, have problem with no sound (music), u need to install pach @http://www.playground.ru/files/max_payne_vista_sound_patch-13055/@ download and install it with insruction. Enjoy! ))
tazmo8448 Dec 11, 2013 @ 3:26pm 
I got it to work by dwnldng the file conversion which is in the OP and running the [C] Conversion utility then [L] Launch and bingo it played. Didn't have to do anything else.
tazmo8448 Dec 11, 2013 @ 3:30pm 
Sorry the OP isn't in this discussion but FatuM72 has a link and that is it. It Does Work. That link is btw a russian link and I got a 404 error. But there is a SoundPatch v1.12 that does the trick. Just Google and it'll pop up.
tazmo8448 Dec 11, 2013 @ 3:31pm 
The patch was made by a developer who himself had issues with Vista when this game was released.
Dallas108 Jan 27, 2014 @ 5:35pm 
Have you tried maybe 'lunching' the game, or maybe 'lounging' it?
tazmo8448 Feb 1, 2014 @ 6:23am 
Not lately Dallas108 but 'hunching' it came to mind.
Siada-Apius Jul 17, 2016 @ 7:08am 
I had same issue. Try to set "Antialiasing = Off"

Win 10, 1920x1080, 980ti
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Max Payne > General Discussions > Topic Details
Date Posted: Dec 6, 2012 @ 4:29pm
Posts: 15