The Binding of Isaac

The Binding of Isaac

View Stats:
IUG Nov 3, 2013 @ 8:03pm
Slow framrate since upgrading to Mavericks *SOLVED*
I updated my MBPr with Mavericks and the game is basically unplayable slow now. Before the upgrade it was fine (although a bit faster if I was playing on an external monitor that didn't have the retina dpi). But since the upgrade every room is incredibly slow. It might speed up after about 3 seconds, but it's not near the speed it was before. And I only get close to the same speed if I have nothing else on the screen besides Isaac.

Has anyone else upgraded and had the same problem?
Last edited by IUG; Aug 19, 2014 @ 5:30pm
< >
Showing 1-15 of 24 comments
munsterballz Nov 3, 2013 @ 9:21pm 
YES!!! IS THERE ANY WAY TO FIX THIS?
IUG Nov 4, 2013 @ 7:36am 
I've tried to reinstall Flash, but this didn't fix it for me.
don't go into fullscreen, it definetly helps lag issues
Xavier Nov 4, 2013 @ 5:12pm 
Yep was playing normally this morning now cant play at all. Perfect considering I just bought this game the other day. I have the worst luck with games
IUG Nov 4, 2013 @ 7:50pm 
I've never used full screen on my laptop. With the retina display, the largest the screen gets is about half of the screen. Going full screen just make a black repeated-image border go around it. If I play anything smaller than the largest window size, then it's like watching myself play the game on YouTube or something equally small.

I guess that's a question. If you upgraded ot Marvericks and this is a probelm for you, do you also have a Retina screen?
Last edited by IUG; Nov 4, 2013 @ 7:51pm
Devekta Nov 4, 2013 @ 7:55pm 
Play lowest settings, lowest resolution, small window and window mode instead of fullscreen.
Hope this help's, if don't well that's probably because of flash.
Bjørn Nov 14, 2013 @ 12:26pm 
I get a slow framerate even with lowest settings windowed. 2013 Retina MBP 13", Mavericks.
IUG Nov 15, 2013 @ 6:06pm 
I think I figured it out.

I went to the application itself in /User/[MyUserName]/Library/Application Support/Steam/steamapps/common/the binding of issac/ and found the application itself. I right clicked and selected "Get Info" on the program. There was an option to run the program in "Low Resolution", so I picked that. I launched the game and it ran much faster. Before, I only got this speed by playing the game on an external monitor that didn't have the Retinia Display my Macbook Pro has, but now it plays at that speed, pre-Marvericks, without a problem.

(If you have a problem finding the "Library" folder, Apple keeps it hidden. You can either go to your User folder, and go to View Options in the View menu, and turn it back on, or you can select the Go Command (Shift+Command+G) and type ~/Library/ to open it). Let me know if this fixes it for anyone else.
IUG Nov 15, 2013 @ 6:09pm 
I just double checked. I unchecked "Run in Low Resolution" and it was slow again, so I think this is the fix.
IUG Nov 22, 2013 @ 5:45pm 
Did anyone else try this? I want to send a message to Edmund if this fixes it, to see if he'll pass it along on Twitter for anyone else who had the problem.
Pancake Rabbit Nov 25, 2013 @ 4:35pm 
That fixed it for me, thanks!!
Thank you so much! That did the trick for me on a mid-2012 mbp retina.
Yuti Jan 16, 2014 @ 3:57am 
IUG thanks! It was not a matter of the graphics!
d o c o Jun 19, 2014 @ 12:15pm 
SO glad I found this! Thanks a million!
Moondog Aug 19, 2014 @ 3:18pm 
Originally posted by IUG:
I think I figured it out.

I went to the application itself in /User/[MyUserName]/Library/Application Support/Steam/steamapps/common/the binding of issac/ and found the application itself. I right clicked and selected "Get Info" on the program. There was an option to run the program in "Low Resolution", so I picked that. I launched the game and it ran much faster. Before, I only got this speed by playing the game on an external monitor that didn't have the Retinia Display my Macbook Pro has, but now it plays at that speed, pre-Marvericks, without a problem.

(If you have a problem finding the "Library" folder, Apple keeps it hidden. You can either go to your User folder, and go to View Options in the View menu, and turn it back on, or you can select the Go Command (Shift+Command+G) and type ~/Library/ to open it). Let me know if this fixes it for anyone else.

I can't seem to find the "Low resolution" button when I click Get Info. How did you get it?
< >
Showing 1-15 of 24 comments
Per page: 15 30 50

Date Posted: Nov 3, 2013 @ 8:03pm
Posts: 24