Monaco
Monaco > Technical Problems > Topic Details
.:\-WizmaN-/:. Apr 24, 2013 @ 3:55pm
Connecting to server...
How come when my friends (invited or not) or other players try to join my lobby, they start to connect with "Connecting to server...", but then they drop from the lobby since they're unable to connect. Do we have to port forward for hosting or something? I would think hosting would work natively through Steam. Thank you in advance for anyone that helps! :)
< >
Showing 1-15 of 15 comments
I'm trying to join a game and I'm getting stuck on "connecting to server"
Swifteye Apr 24, 2013 @ 3:58pm 
It was working earlier. The servers seem to have gone down or something.
AndyN.  [developer] Apr 24, 2013 @ 4:16pm 
Hmm, we "shouldn't" require port forwarding. There might be NAT settings that prevent players from connecting. Are you unable to connect at all, or are you only unable to connect to a certain person?
Meepsauce Apr 24, 2013 @ 4:20pm 
Currently getting this, unable to connect to a friend but another friend can connect to him. Shouldn't be under a strict NAT though. It shows me as in the lobby, but I get "connecting to server" forever.
AndyN.  [developer] Apr 24, 2013 @ 4:21pm 
I've seen these symptoms before but I do not know the cause. In the past, it was a result of NAT settings. Is your friend located in a different region?
Meepsauce Apr 24, 2013 @ 4:22pm 
Same region, the friend that can connect to him is in the same region too.
Howl Apr 24, 2013 @ 4:23pm 
I'm experiencing problems as well. Sometimes when I connect it says "Server quit the game" or after I finish the dialogue and become ready the server times out.

This happens nearly every time.
Last edited by Howl; Apr 24, 2013 @ 4:23pm
Woppits Apr 24, 2013 @ 4:25pm 
A friend and I are having this issue too, we can't connect to each other. It will briefly show him or I join the other's lobby but then they drop out. My Steam ports are all open and the firewall isn't running, we live about 40 miles from each other so we're in the same region (though I'll have him check his Steam region settings when he gets unAFK). Very annoying problem because the game is awesome and we want to team up for it.

I'll know tonight if this is just a problem between him and I or if my other two teammates have the issue too.
.:\-WizmaN-/:. Apr 24, 2013 @ 4:29pm 
As for me and my friends, just as Violet said, we appear in the lobby then disconnect a few seconds later. If my friends and I join a public lobby made by someone else, then we can connect fine. However, if we make our own lobby, public or private, none of us can connect. We're also located in the same region (US West and East).

I'm going to assume at this point, it's most likely a NAT / Port Forwarding issue, like you said AndyN. What ports does Monaco: What's Yours Is Mine use? I will try port forwarding them on my router to see if that helps.
Last edited by .:\-WizmaN-/:.; Apr 24, 2013 @ 4:30pm
Meepsauce Apr 24, 2013 @ 4:33pm 
Restarted my router, he restarted his game and it connected. No idea. Sometimes my router can be fussy when assigning ports and doesn't like to keep them open. It worked now though.
.:\-WizmaN-/:. Apr 24, 2013 @ 4:35pm 
Weird, my friends and I can now connect to each other despite having not needed to forward any of our ports. It seems Steam Community was encountering some problems earlier (since it went offline a few minutes ago). And seeing as how it works now, I'm going to assume that Steam was the source of the problem.

As a suggestion, AndyN, your developers should look into the coding behind using SteamWorks in Monaco so that the game lobbies in-game still run and do not "timeout" whenever Steam goes down. I encountered a lot of timeouts during the Steam community downtime a little while ago when connecting to many different public lobbies. I think if that small issue can be resolved, then that would make the game experience much better for everyone - that and some of the small lag issues encountered (e.x. for moving around once everyone is actually in-game).

Having said all of that, Monaco is an amazing game and I really hope to see more amazing content from you guys in the future!

Anyways, thanks everyone for your replies! If there's any more related discussion or questions to add, please feel free to comment on it here.
Last edited by .:\-WizmaN-/:.; Apr 24, 2013 @ 4:49pm
AndyN.  [developer] Apr 24, 2013 @ 4:35pm 
What happens if you try to join a second time after failing to connect the first time?
Deriaz Apr 24, 2013 @ 4:39pm 
Friends and I are having the same issue. All ports are correctly forwarded, and I've been able to host other games for them in the past. In Monaco they connect, then drop. When trying to join a second time, it just does the same thing -- connects for a few seconds, then drops.

Small update: We've tried someone else hosting. I am in Canada, the friends are back in the US. When I hosted, they could not connect. When one in the US hosts, the other US can connect, but I cannot. (We have a third USA friend, but he's still downloading.) Don't know if that helps, but, it was worth noting, I felt.

Update 2: All 3 US friends can connect to one another with ease, no matter who is hosting. I remain the only one unable to connect.

UPDATE 3! : Restarting Steam and verifying cache seemed to work, even though nothing was downloaded. Not sure what the heck's up with that, but, we seem to be in a lobby. On to breakin' out of prison. . .
Last edited by Deriaz; Apr 24, 2013 @ 4:55pm
.:\-WizmaN-/:. Apr 24, 2013 @ 4:43pm 
@ AndyN

We received the same "Connecting to server..." error no matter how many times we connected (to public or private lobbies) earlier. However, seeing as how Steam is now online again, everything is working properly as it should be - with a little added lag once everyone hops in-game (though, I'm thinking that might just depend on the host's internet connection, but I'm not entirely sure). Anyways, I hope that helps!
Last edited by .:\-WizmaN-/:.; Apr 24, 2013 @ 4:48pm
AndyN.  [developer] Apr 24, 2013 @ 5:00pm 
Honestly, this might also be a steam thing too. There are times when steams matchmaking server doesnt work for us either.
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Monaco > Technical Problems > Topic Details
Date Posted: Apr 24, 2013 @ 3:55pm
Posts: 15