Solasta: Crown of the Magister

Solasta: Crown of the Magister

View Stats:
Myzzrym  [developer] Mar 31, 2021 @ 1:53am
Known Issues - Spring Update edition!
Let's compile all the bugs you guys found in the Spring version!

Crashes / Infinite Load:
If you encounter crashes / Infinite Loading screens, here are a few things to check:
  • Make sure you verified game files on Steam
  • Do not save when no characters are selected, it will create a corrupted save file! This notably happens when you just entered a new level, you need to click the button on the top left under your party's portrait to select your party before saving. Might also happen right after you finish a fight.
  • Exiting a map and / or saving while a spell is active may cause issues. Make sure you aren't saving while a spell is active (Darkness, Mage Armor, Dancing Light, etc etc...)
  • If a certain save file doesn't load, try restarting Solasta and loading it again. If it still doesn't load, the save file might be corrupted due to saving when the game is already "broken" (not visible to the player, but something poopy happened behind the scene). That mean you'll have to load a previous save :(
  • Specific to the French version: Opening the Brimstone Viper Bestiary causes a crash to desktop.
Potential Blockers:
  • If you close a confirmation pop-up immediately as it appears (for instance you press escape right as you're asked if you want to leave the area), confirmation pop-ups will no longer appear - meaning you'll be stuck in a location, since you won't get a confirmation message asking you if you want to leave the area when stepping on Exit Areas or when interacting with a door. To fix it, quit the game completely and relaunch it (simply loading a save doesn't fix it)
  • After talking to the Council on your return from Wizard's Tower, you must go to the residence immediately. If you don't (for instance, you long rest at the tavern before going to the residence), you will be stuck inside the residence and won't be able to leave, effectively ending your run. To fix it, load a previous save and go directly to the residence after talking to the council. 
  • In the Lawkeeper Background Quest, clicking "No" when asked to travel to the sewers will permanently block you from accessing the sewers, thus blocking the quest. To fix it, reload a previous save. 
  • Do not go to back to "Imperial Ruins" on the World Map if you don't have "The Collector" side quest active - without that side quest in your journal you will be stuck once you arrive there. 
  • In Tower of Magic, if you do the "Research the Crown" side quest before the "Magister's Amulet" side quest, the puzzle of "Magister's Amulet" side quest won't work. To fix it, simply leave Tower of Magic and return there later.
Lag / Performance Issues:
  • Auras such as the Paladin's Aura of Protection or the Battle Cleric's Herald of Battle seem to make the game lag more and more as time passes.
Game-Overs:
  • Using the teleporter to go to Wizard's Tower causes an instant game-over.
  • If you click end turn exactly when "Victory" appears, you will trigger a game over. Don't ask me why, I have no idea. But I did find that funny when QA told me about it. 
  • Characters who drop to 0 max HP due to Defilers' Vampiric Touch can't be resurrected, forcing a game over.
Items, Spells & Powers:
  • Paladins can't use scroll of Raise Dead
  • Scroll of Freedom of Movement casts Fire Shield, scroll of Hold Person casts Misty Step, Scroll of Misty Step casts Magic Weapon
  • Decisive Strike doesn't stun long enough
  • Amulet of Health currently doesn't require attunement (it should)
  • Poisonous Bolt recipes are missing their correct name
  • Warhammer +1 currently requires attunement (it shouldn't)
  • Reading a recipe book when you already know the recipe still consumes the book
  • Pressing the escape key instead of the "abort" button when trying to move a proxy spell (spiritual weapon, flaming sphere...) does not refund the Bonus Action.
  • +2 Quarterstaff only costs 2 silver and the unidentified & identified names of the item are swapped.
  • Domain Spells are not considered as valid spells when using scrolls, such as Faerie Fire for the Sun Domain Cleric
  • Scrolls of Grease and Sleet Storm can be found / bought but are not usable for now
  • Shield can currently be cast even while silenced
Other bugs:
  • In Tower of Magic, the "Magister's Amulet" side quest will spawn 2 elementals very far from you which unfortunately won't do anything so you'll have to hunt them down by running to them. Which is very tedious and we totally hate it too, so don't worry it's not intended.
  • Characters are able to walk in the air in certain places in the broken fort in Caer Lem.
  • Monsters may also sometimes decide to run back and forth instead of attacking a character. Which is of course not intended, as all monsters are ordered to violently maul any adventurer they encounter by their DM overlord. 
  • In the Dungeon Maker, the "Mood" parameter isn't saved properly and will always revert to "Crypt".
  • Captain Verissa Ironshell is missing lip sync
  • Rolling 20 on a death saving throw skips the character's turn instead of letting them play
  • Goblin Cutthroats have +15 to hit instead of +5
  • Custom graphic settings revert to the previously selected preset setting after quitting the game
  • Crafting sometimes take longer than what is shown on the UI
Last edited by Myzzrym; Apr 2, 2021 @ 7:52am
< >
Showing 1-5 of 5 comments
CannonFodder Apr 16, 2021 @ 2:01am 
I can't load my saved game from yesterday. All the local files verify OK on Steam. Game was saved in latest release and loaded in latest release (0.5.42).

Now I read this, "Do not save when no characters are selected, it will create a corrupted save file". Then (and maybe worse) the game window is closed (but process not terminated) and Solasta won't re-launch until PC is rebooted.

I don't know if this is the cause of my corrupted save file or not, but regardless, how can you release a build with a critical known bug like this and not fix it for weeks?
Marier8718 Apr 18, 2021 @ 4:55am 
Heya pals, Marier here for a quick comment on the bugs I've encountered in the character creation menu.

1) When you create a character, in the ancestry (1st part of the menu), if you click on «cancel», you get some gibberish instead of the usual memo about being sure to cancel. Happens 100% of the time, whatever the ancestry I'm on at the moment I cancel.

2) Could've been more of a game breaking thing, but I wanted to make myself a dwarf paladin (normal should be -1 move) but then, I clicked on the ranger, so I clicked again on the paladin and BAM, I get a +1 move. Also happens with the fighter. This seems to get corrected when clicking on any Background right on the next menu.

3) I made myself a Human Cleric of Pakri and chose the Insight domain. When I arrived at the Spells menu, I went to see the effect of the Sparkle Cantrip and as of it's spell effects, it is said : «Rules/&AlterationFormLightUpFormat». Also, in it's properties, it is written : «Tooltip/&TagLightUpTitle». I don't know if it continues to happen after starting the campain since I didn't choose these.


That's it for now :) This game is most probably the best render I've seen of an actual tabletop RPG. Thank you so much for the great work you put out there!

I wish I could pin some screenshots, but there you go, Steam being what it is. Hope it actually helps the whole Early Access thing :)
Last edited by Marier8718; Apr 18, 2021 @ 4:56am
bud88 May 20, 2021 @ 10:19pm 
when a two handed character picks up a shield as loot it sometimes unequips one of his swords and puts him holding shield in off hand that he picked up

on the law is the law quest its possible to stealth to the chest and loot before the fight which breaks the quest as it expects you to loot the proof after the fight
Last edited by bud88; May 20, 2021 @ 10:33pm
sactrust1 May 27, 2021 @ 10:34am 
the quest to give merton the sword does not show over his head quest ! and it sends me into some loop, also prices changed dramatically for sell? Items for sale now not allowed? Trying to buy from shop keeper locks up... I did the steam file check, still no love??? Thanks Great game, with patch don't have the tearable lag i had for 3 days
darxone77 May 30, 2021 @ 6:36pm 
my game just randomly crashes after a while. Now into the second location -Ruined Tower, the game just crashes a few minutes into the game...
< >
Showing 1-5 of 5 comments
Per page: 1530 50

Date Posted: Mar 31, 2021 @ 1:53am
Posts: 5