View Stats:
Bastion > Technical Support > Topic Details
simendsjo Apr 14, 2013 @ 7:41am
No go on linux
I'm using arch linux x64 (steam is still x86) on an Lenovo x220.
The game starts, but I have no sound, and the "subtitles" or whatever it is is stuck with the same message at the bottom of the screen.
In other words, the game doesn't work for me.

Unless this is fixed very soon, I'd rather have my money back (should have tested the demo first, but got it recommended from a friend) - any idea how I should go forward? I'm new to steam.
< >
Showing 1-6 of 6 comments
simendsjo Apr 16, 2013 @ 12:45pm 
Originally posted by Greenbikerdude:
I don't want to be rude, but I really hate it when people use things like arch and can't even choose a good title or give us proper information. Also do not cry for a refund immediately, because it doesn't run on the first try.

I guess it is a problem with your installation rather than the game itself. So here are some things we would need to give a better( in this case ANY) answer:
- which multilibs are installed?
- alsa/oss/pulseaudio/jack what do you use for sound?
- is sound muted?
- console output from running bastion
- do you have sdl installed?
- which graphics driver are you using?
- does it work in a 32bit chroot? (only if you have already one)
- which games from steam do you have and run?

It's not you who is rude, it was I. I totally agree, and usually think a bit further before writing in frustration :)

- multilibs: Not sure what you mean. I'm using the regular multilibs package
- sound: Not really sure.. Using curses based AlsaMixer, and that states "ALSA" on system information. Cannot see much useful stuff through lsmod thogh
- muted: Of course not :))
- console output: Forgot to check, and I uninstalled it. I'll reinstall and paste console /log output.
- installed sdl: I have 1.2 and 2.2 for 32-bit and 1.2 for 64-bit. But it's using it's own/steam supplied SDL right?
- graphics driver: Intel: intel-dri 9.1.1 (might have been updated since I tried Bastion)
- chroot: I don't use chroot
- working games: Unwritten Tales (both), FTL, Frozen Synapse, Journey Down Under
- other games: The Cave - much worse than Bastion. Just a black screen.
Randomonium Apr 21, 2013 @ 8:01pm 
On Ubuntu 12.10 x64, using an ATI 7800 with fglrx - this game completely rules. So, it's not Linux that it has issues with, it's your config.
Last edited by Randomonium; Apr 21, 2013 @ 8:01pm
Reif May 1, 2013 @ 7:36am 
I second what Randomonium said.
Running (X)ubuntu 13.4(pure xfce wm/dm), native steam client with beta update. Also on an AMD system(A10 to be a bit more precise). Also using the fglrx drivers(currently on 13.4 from AMD's website)

You just need to check all your dependencies and drivers are installed and working properly.
Patagonicus42 May 6, 2013 @ 2:53am 
With alsa I had to


to get the sound to work on Gentoo. Probably the same on Arch.
bfops Dec 31, 2013 @ 9:18am 
Same problem here on x86-64 Arch. Interestingly, I have sound if I launch ~/.local/share/Steam/SteamApps/common/Bastion/Linux/Bastion.bin.x86 directly, but not if I launch through Steam.

This is a dual-boot machine, and everything runs fine under Windows.

- which multilibs are installed?

multilib/lib32-alsa-plugins 1.0.27-1
multilib/lib32-atk 2.10.0-1
multilib/lib32-attr 2.4.47-1
multilib/lib32-bzip2 1.0.6-1
multilib/lib32-cairo 1.12.16-1
multilib/lib32-curl 7.33.0-1
multilib/lib32-dbus 1.6.18-1
multilib/lib32-e2fsprogs 1.42.8-1
multilib/lib32-elfutils 0.157-1
multilib/lib32-expat 2.1.0-1
multilib/lib32-flac 1.3.0-1
multilib/lib32-fontconfig 2.11.0-1
multilib/lib32-freetype2 2.5.2-1
multilib/lib32-gcc-libs 4.8.2-7
multilib/lib32-gdk-pixbuf2 2.30.1-1
multilib/lib32-glib2 2.38.2-1
multilib/lib32-glibc 2.18-11
multilib/lib32-gtk2 2.24.22-1
multilib/lib32-harfbuzz 0.9.24-1
multilib/lib32-icu 52.1-1
multilib/lib32-intel-dri 10.0.1-1
multilib/lib32-json-c 0.11-1
multilib/lib32-keyutils 1.5.8-1
multilib/lib32-krb5 1.11.4-1
multilib/lib32-libasyncns 0.8-6
multilib/lib32-libcanberra 0.30-4
multilib/lib32-libcanberra-pulse 0.30-4
multilib/lib32-libcap 2.22-2
multilib/lib32-libcups 1.7.0-1
multilib/lib32-libdrm 2.4.50-1
multilib/lib32-libffi 3.0.13-1
multilib/lib32-libgcrypt 1.5.3-1
multilib/lib32-libgpg-error 1.12-1
multilib/lib32-libice 1.0.8-1
multilib/lib32-libjpeg-turbo 1.3.0-4
multilib/lib32-libldap 2.4.38-1
multilib/lib32-libltdl 2.4.2-12
multilib/lib32-libogg 1.3.1-1
multilib/lib32-libpciaccess 0.13.2-1
multilib/lib32-libpng 1.6.7-1
multilib/lib32-libpulse 4.0-6
multilib/lib32-libsm 1.2.2-1
multilib/lib32-libsndfile 1.0.25-2
multilib/lib32-libssh2 1.4.3-1
multilib/lib32-libtiff 4.0.3-2
multilib/lib32-libtxc_dxtn 1.0.1-5
multilib/lib32-libvorbis 1.3.3-1
multilib/lib32-libx11 1.6.2-1
multilib/lib32-libxau 1.0.8-1
multilib/lib32-libxcb 1.10-1
multilib/lib32-libxcomposite 0.4.4-1
multilib/lib32-libxcursor 1.1.14-1
multilib/lib32-libxdamage 1.1.4-1
multilib/lib32-libxdmcp 1.1.1-1
multilib/lib32-libxext 1.3.2-1
multilib/lib32-libxfixes 5.0.1-1
multilib/lib32-libxft 2.3.1-1
multilib/lib32-libxi 1.7.2-1
multilib/lib32-libxinerama 1.1.3-1
multilib/lib32-libxrandr 1.4.2-1
multilib/lib32-libxrender 0.9.8-1
multilib/lib32-libxt 1.1.4-1
multilib/lib32-libxtst 1.2.2-1
multilib/lib32-libxxf86vm 1.1.3-1
multilib/lib32-llvm-libs 3.3-1
multilib/lib32-mesa 10.0.1-1
multilib/lib32-mesa-libgl 10.0.1-1
multilib/lib32-nspr 4.10.2-1
multilib/lib32-openssl 1.0.1.e-2
multilib/lib32-pango 1.36.1-1
multilib/lib32-pcre 8.33-1
multilib/lib32-pixman 0.32.4-1
multilib/lib32-sqlite 3.8.2-1
multilib/lib32-systemd 208-1
multilib/lib32-tdb 1.2.12-1
multilib/lib32-util-linux 2.24-1
multilib/lib32-xz 5.0.5-1
multilib/lib32-zlib 1.2.8-1

- alsa/oss/pulseaudio/jack what do you use for sound?

alsa and pulseaudio

- is sound muted?

Nope. Works with all other Steam-on-Linux games.

- console output from running bastion

Can I get this when launched from Steam? Again, I only seem to have this problem when launched through Steam.

- do you have sdl installed?

extra/sdl 1.2.15-5
extra/sdl_image 1.2.12-3

- which graphics driver are you using?


- which games from steam do you have and run?

On Linux, I've run FEZ, TF2, and Trine 2 with no problems.
Last edited by bfops; Dec 31, 2013 @ 9:21am
Neko Jan 7, 2014 @ 2:53pm 
Had the same problem, fixed it by installing lib32-alsa-lib, lib32-alsa-plugins and lib32-libpulse from multilib.

I'm using pulseaudio with Awesome WM & Gnome integration.
Last edited by Neko; Jan 7, 2014 @ 2:55pm
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Bastion > Technical Support > Topic Details
Date Posted: Apr 14, 2013 @ 7:41am
Posts: 6