View Stats:
Bastion > Technical Support > Topic Details
Devi710 May 11, 2013 @ 1:29pm
Mouse Lag in Linux
I can't play the game in Linux because the extreme mouse lag.

In the Main Menu, the mouse moves about 3 or 4 seconds late. The Steam support FAQ mentions disabling "ATI HotKey Poller" in Windows, but I can't find that option in Linux.

Ubuntu 13.04 64bit (fresh install)
ATI 5450 with the latest proprietary drivers installed from ATI website
< >
Showing 1-15 of 16 comments
Devi710 May 11, 2013 @ 10:53pm 
I switched to the open source drivers, and everything is OK. No more mouse and keyboard lag.
bazukas Jul 1, 2013 @ 6:53am 
Having same problems on Ubuntu 12.10 with AMD Radeon HD 6700M (13.6 beta drivers).

Any ideas on how to fix this?
Devi710 Jul 1, 2013 @ 7:04am 
Not that I know of. The only way I was able to fix it was uninstalling the proprietary drivers and using the open source ones.
I have archlinux up to date and catalyst 13.6 and my system affected by this bug too. However I cant install FOSS driver because of pure 3D perfomance on my card. I think developers should take effort on fixing that
Devi710 Jul 13, 2013 @ 5:53am 
Yeah, it runs too slow with the open source drivers and it doesn't work with the proprietary ones. I can't play this game until there is a fix.
I tried to downgrade catalyst to 13.4 and xorg to 1.13 but unfortunately this does not fix the problem is it developer's email? does smb already messaged them?
Szklanka Kompuntu Jul 19, 2013 @ 1:19am 
I also have this problem, extreme mouse (and later keyboard) lag even in the menu. I'm playing on gentoo 64bit, 13.4 ati drivers. When I run Bastion the X server also seems to use up a lot of resources. Has anyone found a solution? The game is completly unplayable for me atm. :<
Szklanka Kompuntu Jul 20, 2013 @ 10:34am 
Alright, I more or less got it to work properly. After reading the FAQ somewhere on these forums I addded the -nofixedstep option to the launch options. This did help quite a bit and the game was playable, but the input was still laggy.
Now I set the launch options to start the game in a different X server and it works well even without the magic option. The only remaining problem is the resolution can't be changed now and it's low, but I can live with that. If anyone wants to do this too, the following command in "Set Launch Options" should work:
xinit %command% $* -- :1
All the magic symbols are needed afaik, but I didn't check. If this doesn't work, try changing the 1 into 2 or some other small numbers.

It seems it was mostly an issue with fluxbox for me, so this won't necessarily help you guys.
Devi710 Jul 21, 2013 @ 3:52pm 
Thanks for posting your results Szklanka. I'll give it a try next time I decide to install the propriatery drivers.
Davey Darko Jul 23, 2013 @ 8:22pm 
I'm running on Mint 64bit with Catalyst 13.6 on my Radeon HD 6450. Mouse lag is terrible, I hope the devs fix this, I'm not willing to revert to the open source drivers.
Chuck Daniels Jul 25, 2013 @ 2:32am 
Same thing here, ArchLinux with Catalyst drivers 13.6 and extreme mouse lag. I sent a mail to support two days ago but no answer yet, I'll post here something if they reply.
I mailed them too a month ago - no reply
it seems like some of the recent updates fixed the problem for me
Szklanka Kompuntu Aug 16, 2013 @ 3:20pm 
Damn, you made me hope for better resolution, but nah, still doesn't work for me. :/
Davey Darko Sep 8, 2013 @ 3:06pm 
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Bastion > Technical Support > Topic Details
Date Posted: May 11, 2013 @ 1:29pm
Posts: 16