Age of Empires® III: Complete Collection

Age of Empires® III: Complete Collection

AOE3 won't even install or load up
Yeah, such as the title says. I have no damn idea what the hell is going on with this game, but I bought it for $9.99 before it got bumped up to $19.99. I been wanting this game for AGES! I'm running Windows 7 Ultimate 64 bit, with an EVGA GTX 460 1 GB GDDR 5 graphics card, with 6 gigs of RAM. There were 5 steps of the set up, and it didn't even finish them when I get the error message that's something like "AOE3.exe has stopped working". I don't even get to ANY start up screen or anything. Hell, the thing never even starts. I've tried going to the Steam common folder where it was installed (or so it would look like), I run the .exe launcher in Admin mode, but it crashes again with the same error message. Now, before anyone even says for me to run Steam in Admin mode, I can't even do THAT. I have no idea why, but my Steam crashes when I try loading it up after I put it in Admin mode. No one else uses my computer, it's in my room, so there's no other account on it. I am up to date with my graphics card and whatnot.

Does ANYONE know what's going on and how to fix it? Oh, sorry, I forgot to mention I am using a duel core.
最近の変更はDeathbysnusnuが行いました; 2012年11月23日 13時09分
< >
1-4 / 4 のコメントを表示
=|Lexx|= 2012年11月28日 13時15分 
Try to verify game-cache. Its an option in the perferences of the game in steam.

I don't know what kind of setup You are talking about but this game should only ask You for the CD-Key and for accepting the EULA (license).

Usually steam loads all important stuff like directX, net.framework and the like on itself if it broke up on one of this steps .. maybe you can try to uninstall all framework and directx stuff and let it reinstall again?

I verified game cache, doesn't work. And the game NEVER asked me for ANY CD KEY lmfao The game works whenever it wants to for some odd reason, though right now, it refuses to work, and has refused to work for a few days now x.x
Have You had such problems with other games?
Try reinstalling the game. If You have a low internet-connection. Backup the game (thorugh steam or just copy-paste the game-folder in a save place).
I guess there went something wrong while the directX, net.framework installation stuff. This usually pops up the first time You first start the game.

Be sure to understand, that the original Game-Development team does not longer exist, this game was not initially made for steam and most of the players don't have problems at all (like me). If You are so unfortunate to have trouble, it's not like it happens regularly.
You can ask for some support from MS Ryz0n. He's (She's?) here on the forums and is the best (and only?) connection to those, whoever are responsible on microsoft for this game comming on steam.
Well, the only other game that's giving me problems is Borderlands 2, but so far, that seem sto be running all right. I have no idea why this game isn't working properly. It works sometimes for a day, and then it gives me the same problems for God knows how long T___T Both Borderlands 2 and AOE 3 says the same thing when I try to load them "(game).exe has stopped working" or whatever. I have a perfect internet connection, I'm connected directly to the internet modem/router via ethernet cord. I've tried reinstalling it time and again, and it still gives me the same problem lols I've done the same with BL2, as well, but that also gives me problems =( And yeah, who the hell let this game on Steam lmfao I don't know why this is doing this, but eh. I'll try to look for that person and message him/her personally, and ask for some help. I'm not exactly computer savvy, but my boyfriend is LOLS I'll wait till he's available until I contact this person, so he can help me with the reply. XD
< >
1-4 / 4 のコメントを表示
ページ毎: 15 30 50

投稿日: 2012年11月23日 12時55分
投稿数: 4