FINAL FANTASY VIII - REMASTERED

FINAL FANTASY VIII - REMASTERED

View Stats:
Windows 10 UPDATE 2004 low fps problem WITH FIX!
How many of you are having the low 21-22 fps problem?
Post here let our voices be heard or they'll never fix it, i bought it yesterday excited to play it again after so many years but this gives the same bad vibes from the original pal ps1 version running super slow.

Edit:
There is a temporary fix found and posted by the username FatedCourage, here i'll guide you the steps for this fix until square fixes it themselves.

1. Ok first up what you're gonna need is SpecialK which can be downloaded from https://github.com/Kaldaien/SpecialK/releases/tag/sk_0_10_2
and AutoClicker https://sourceforge.net/projects/orphamielautoclicker/ (I explain later why you need something like this).

2. Open the specialk archive you just downloaded and extract both SpecialK32.pdb and SpecialK32.dll into your Final Fantasy VIII Remastered main folder and rename SpecialK32.dll to opengl32.dll

3. Boot up your game and press CTRL+SHIFT+BACKSPACE or Start and Select if using gamepad to open up menu, in the Frame Limiter Advanced setting tick the Sleepless Window Thread and Disable all but active API in the render compatibility settings.
https://imgur.com/fFdNLzy

But for some reason the game is still stuck on 27 fps when not inputing any key from the keyboard or mouse (don't ask me why as i have no idea)

4. That is when AutoClicker comes into play, download from link above, open it and change the settings as follows, remember to Stop(F6) before you quit the game.
https://imgur.com/cZqoEkM

Enjoy.
Last edited by ATemplarZ; Sep 13 @ 10:59am
< >
Showing 1-14 of 14 comments
Yep. Happening to me. Can't find anything to fix it.
Adequate Sep 13 @ 8:15am 
Posting here in the hopes of the issue getting traction. I have the same issue now post update, looking at the other thread that had this issue before the Windows update, none of their fixes worked.
ATemplarZ Sep 13 @ 10:51am 
I updated the first post for anybody that wants a temporary fix, i tested it for a couple of hours and seems to be working fine.
strife Sep 20 @ 5:46am 
Bought this game today just to have this exact thing happening to me. Trying your fix but not too hopeful
Kaldaien Sep 20 @ 8:48am 
Damn... as the author of that software, this is disappointing.

Not that my software fixes the problem, I'm happy to have a solution, but that the software's behaving this way in the first place :-\

Square Enix's port quality, or lack thereof, never ceases to amaze me. How many times have they re-released this game now, and every version has stupid compatibility and design issues.

-----
Let's please not give Square Enix a pass on this. The issue may have only showed up for users after a Windows Update, but the design is bad and has been since the game shipped. Microsoft is excused from this, Square Enix deserves all blame.
Last edited by Kaldaien; Sep 20 @ 8:51am
Neo Sep 20 @ 9:19am 
This is what happens when you lose the source code to the original game. You can only do so much and they're bound to have problems.

Should've just remade the whole game from the ground up like they did with Final Fantasy 7...
Instead, we get Final Fantasy XVI that no one asked for.
I'm glad to see people using the SpecialK fix I suggested for this...cough...quality port. I'd also like to point out that if you use the most up to date version of SpecialK then you might not even need to enable the "Sleepless Window Thread" option. Just inject and disable all renderers not in use. I'm still not sure why or how it isn't always injecting properly as I've not had that problem with either version of FF8.
Ray Von Sep 21 @ 11:40am 
Exact same issue. Fix outlined in OP doesn't work for me, and Steam support won't even let you submit a ticket to highlight the issue because "Unfortunately, Steam Support cannot provide the best assistance with games made by other companies.". Which translates from 'cannot provide the best assistance' to 'cannot provide any assistance'. Joke.
Omallis Sep 26 @ 4:27pm 
Happening to me too. The game runs in slow motion and no options changed fixes it. The original FF8 runs just fine however
I've also been having the same FPS Problem
You also use Remote Play on your phone and the cancel the connection. The game will continue to run at 30 fps. Odd fix
Rhyten Oct 10 @ 1:26am 
Originally posted by Juan Gonzales:
You also use Remote Play on your phone and the cancel the connection. The game will continue to run at 30 fps. Odd fix
I tried doing that but as soon as I open the overlay to disable remote play the game completely ignores my controller.
Hernok Oct 10 @ 5:54am 
Originally posted by Rhyten:
Originally posted by Juan Gonzales:
You also use Remote Play on your phone and the cancel the connection. The game will continue to run at 30 fps. Odd fix
I tried doing that but as soon as I open the overlay to disable remote play the game completely ignores my controller.

That worked for me. You need to have your controller conected to your pc, start the game with the steam link, then from the pc, acces to big picture and cancel the connection.
Last edited by Hernok; Oct 10 @ 5:56am
Rhyten Oct 13 @ 4:06am 
Originally posted by Hernok:
Originally posted by Rhyten:
I tried doing that but as soon as I open the overlay to disable remote play the game completely ignores my controller.

That worked for me. You need to have your controller conected to your pc, start the game with the steam link, then from the pc, acces to big picture and cancel the connection.
But as soon as I press the big picture mode button it doesn't show, I can hear the sounds of the big picture ui. Then my controller stops working.
My solution is to just close the steam link app from my phone and play without ever opening the big picture overlay. Better than 22 fps.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50