FINAL FANTASY VIII - REMASTERED

FINAL FANTASY VIII - REMASTERED

View Stats:
FPS slowdown during certain scenes
Will you please fix this? I don't want to play FF8 underwater.

==EDIT==

This fix mitigated the problem somewhat, but it still isn't a complete fix..

In Nvidia Control Panel>Nvidia Advanced 3D Image Settings>Global Settings, make sure that FXAA is set to OFF, Max Frame Rate is set to 60 FPS, and that Vsync is set to ON. The game should run at a normal framerate now.

For AMD/Radeon Users, see the Marked Answer below.
Last edited by Spooniest; Jul 26 @ 8:15am
< >
Showing 1-15 of 16 comments
Koby Jul 20 @ 11:32am 
This is apparently an issue caused by the Windows 10 May 2020 update titled 2004.

Nvidia is releasing an update that is rumored to fix such an issue, but unknown if it truly does or what non-Nvidia users will do.

But it wasn't Square-Enix at least. No update to the game has happened.
Originally posted by Unknown Caliber:
Fix for slow gameplay.
Works for me. May or may not work for you.

Force 60 fps as maximum frame rate.
The video shows AMD but should work for NVIDIA.
Set Frame Rate Target Control to 60 for AMD.
Set Max Frame Rate to 60 for NVIDIA.
Also made a new topic for the sake of visibility.

This video shows before and after twice with frame rate in top left corner.
https://www.youtube.com/watch?v=7VHuNYRi_TQ

Indeed, walking around in the location which you are walking around in (The Directory/Elevator of Balamb Garden), with these settings dialed in on the Nvidia Control Panel's Advanced 3D Image Settings instructed to make the Max Frame Rate 60 FPS, does not produce slowdown...

...However, the Front Gate of Balamb Garden, when you enter from the world map, still does. Proceeding to the next screen, and then returning to the Front Gate neutralizes this behavior.

However, every time I enter from the world map, everything is underwater again. It appears to be situationally-dependent, whether the game will detect the proper framerate, though I can't speculate as to what is happening.

I do notice, however, that some locations have slowdown when entered from certain other locations, and some don't. I've really had just about enough of being PC Game Devs' free, unpaid slave labor beta tester, when all I wanted was to play a game. I realize that my vitriol is worse than useless, but a forum is for expressing what's on my mind, and this is me, expressing MY self.

==EDIT==

I think we have a winner.

In Nvidia Control Panel>Nvidia Advanced 3D Image Settings>Global Settings, make sure that FXAA is set to OFF, Max Frame Rate is set to 60 FPS, and that Vsync is set to ON. The game should run at a normal framerate now.
Last edited by Spooniest; Jul 23 @ 9:30pm
Neo Jul 26 @ 7:54am 
Originally posted by Spooniest:
I think we have a winner.

In Nvidia Control Panel>Nvidia Advanced 3D Image Settings>Global Settings, make sure that FXAA is set to OFF, Max Frame Rate is set to 60 FPS, and that Vsync is set to ON. The game should run at a normal framerate now.

Nah, I followed all settings you said both in Nvidia global settings or the Program settings specific to this game. Doesn't make a shred of difference to the slow moving characters.
Originally posted by Neo:
Originally posted by Spooniest:
I think we have a winner.

In Nvidia Control Panel>Nvidia Advanced 3D Image Settings>Global Settings, make sure that FXAA is set to OFF, Max Frame Rate is set to 60 FPS, and that Vsync is set to ON. The game should run at a normal framerate now.

Nah, I followed all settings you said both in Nvidia global settings or the Program settings specific to this game. Doesn't make a shred of difference to the slow moving characters.

Upon playing further into the game using the aforementioned fixes, yes you're right. It seems to depend on what graphical elements are either being used or could potentially be used in a given pre-rendered background.

One background is made to run at normal speed by the fix, many others still consume too much of whatever is the chokepoint here and will still be slowed down. I did notice that this FPS limiting effect seems similar to what FF8 (even on the original PSX) does when you are in the middle of a CGI cutscene, where you are permitted to move the main character. Perhaps this information might be enlightening to someone who comes along with more tech know-how than me.
Neo Jul 26 @ 8:51am 
I was loading my save file at the end of Act 1 (I'm not calling it Disc 1). When the party was about to climb the Presidential Palace. I did the fixes in this post, and it doesn't make a difference there.

If it's depending on what graphical elements being used, I guess that Deling City part isn't one of them.
Spooniest Jul 26 @ 12:58pm 
Originally posted by Koby:
This is apparently an issue caused by the Windows 10 May 2020 update titled 2004.

I am not so sure this is the case. When I discovered that it was happening, I got a wild hair up my place-where-the-sun-don't-shine and decided to downgrade back to Windows 7.

... It made no difference. That tells me it's the GPU drivers, most likely.
Neo Jul 26 @ 4:28pm 
Originally posted by Spooniest:
Originally posted by Koby:
This is apparently an issue caused by the Windows 10 May 2020 update titled 2004.

I am not so sure this is the case. When I discovered that it was happening, I got a wild hair up my place-where-the-sun-don't-shine and decided to downgrade back to Windows 7.

... It made no difference. That tells me it's the GPU drivers, most likely.

But there were some reports that when they rollback the updates to Windows 10 version 1909, the game runs normally, even if it's using the same GPU driver.
Originally posted by Neo:
Originally posted by Spooniest:

I am not so sure this is the case. When I discovered that it was happening, I got a wild hair up my place-where-the-sun-don't-shine and decided to downgrade back to Windows 7.

... It made no difference. That tells me it's the GPU drivers, most likely.

But there were some reports that when they rollback the updates to Windows 10 version 1909, the game runs normally, even if it's using the same GPU driver.

Then I don't know why Windows 7 Professional would be having the same issue... I'm stumped.
Neo Jul 26 @ 6:05pm 
Originally posted by Spooniest:
Then I don't know why Windows 7 Professional would be having the same issue... I'm stumped.

Was it always an issue for Win7 Pro from the start? Or did it just start happening around the same time as everyone else?

I don't think it's any update from Win 7 though, since Microsoft stopped supporting Win 7 for a while now and no more updates.

If it is a GPU driver, then it's probably something to do with both the driver and the OS together.
Spooniest Jul 27 @ 12:16am 
Originally posted by Neo:
Originally posted by Spooniest:
Then I don't know why Windows 7 Professional would be having the same issue... I'm stumped.

Was it always an issue for Win7 Pro from the start? Or did it just start happening around the same time as everyone else?

I don't think it's any update from Win 7 though, since Microsoft stopped supporting Win 7 for a while now and no more updates.

If it is a GPU driver, then it's probably something to do with both the driver and the OS together.

Since you seem to have missed it the first time, I will try to make it abundantly clear:

1. I encountered this issue.
2. I uninstalled Windows 10, and went back to Windows 7 Pro.
3. This did not fix the issue.
Use Steam Link with a mobile device, It's the only way to 100% fix this without ♥♥♥♥♥♥♥ anything up. Once I did that, the slowdowns went away and the game runs like any other FF8 version.
Neo Aug 1 @ 4:42pm 
Originally posted by r3d33m3r:
Use Steam Link with a mobile device, It's the only way to 100% fix this without ♥♥♥♥♥♥♥ anything up. Once I did that, the slowdowns went away and the game runs like any other FF8 version.

I need to learn how to do that...
Originally posted by r3d33m3r:
Use Steam Link with a mobile device, It's the only way to 100% fix this without ♥♥♥♥♥♥♥ anything up. Once I did that, the slowdowns went away and the game runs like any other FF8 version.

... You mean only play the game with Steam Link, or after running it once this way it works right back on PC Locally?

= EDIT =

Sorry, that isn't correct.

Screenshot 1: (Moto E4 Plus, Steamlink)

https://imgur.com/uW7SwOg

Note the fps counter in the upper right reads 31, the normal framerate for FF8.

Screenshot 2: (Moto E4 Plus, Steamlink)

https://imgur.com/Ybe5GhE

Now, when I step outside, I know it looks like the same location from earlier, but this is actually a separate background in the game's code, that has crickets chirping in the background. It is the hallway to Squall's dorm room, at night. It happens here, and also before, when you come back from the fight with Granaldo on Disc 1 and Zell is there.

The framerate has dropped to 11 fps.

Now, I did what you said, and booted the game back up locally on Windows.

Screenshot 3: (Windows Desktop)

https://imgur.com/8cMMyKy

Same result as #1 above.

Screenshot 4: (Windows Desktop)

https://imgur.com/Vs02vFP

Same result as #2 above.

I do find this all extremely irritating, but I'm not going to take it out on you, cuz it's not your fault. You, like me before you, thought you'd found a fix for this.

It's also not nice to take out how you feel on people, even if the way you feel was caused by them, at any rate.

I hope we can find a real solution to this problem eventually.
Last edited by Spooniest; Aug 2 @ 3:13am
Alrighty, I figured something out...

Setting the in-game resolution to 640x480 wasn't enough, so I tried setting my GPU resolution to 640x480 and running the game in Borderless Windowed Mode, with the in-game resolution to match.

This gets it bumped up to between 21-24 fps which is at least acceptable.
Neo Aug 3 @ 4:13am 
Originally posted by Spooniest:
Alrighty, I figured something out...

Setting the in-game resolution to 640x480 wasn't enough, so I tried setting my GPU resolution to 640x480 and running the game in Borderless Windowed Mode, with the in-game resolution to match.

This gets it bumped up to between 21-24 fps which is at least acceptable.

I don't think that is acceptable. That's the same resolution as the PS1 version. And it's still running at slower frame rate than the original.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50