Snakebird Primer

Snakebird Primer

View Stats:
[Linux] Problems launching (semi-solved: need some files from original Snakebird)
First up: OMFG yay, more Snakebird! This has absolutely made my day.

I do seem to be having some trouble launching the Linux version, though. The game seems to open a fullscreen window very briefly before exiting. It does create a "prefs" file, and has this inside its Player.log: https://gist.github.com/98891595f89e0f48446b146f7c090840 (using gist because I don't think it'll inline very well here).

I tried launching it directly from the commandline (as opposed to Steam) which seemed to fail in just the same way.

Computer Information: Manufacturer: Unknown Model: Unknown Form Factor: Laptop No Touch Input Detected Processor Information: CPU Vendor: GenuineIntel CPU Brand: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz CPU Family: 0x6 CPU Model: 0x4e CPU Stepping: 0x3 CPU Type: 0x0 Speed: 2800 Mhz 4 logical processors 2 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported AES: Supported AVX: Supported CMPXCHG16B: Supported LAHF/SAHF: Supported PrefetchW: Unsupported Operating System Version: "Arch Linux" (64 bit) Kernel Name: Linux Kernel Version: 4.20.1-arch1-1-ARCH X Server Vendor: The X.Org Foundation X Server Release: 12003000 X Window Manager: IceWM 1.4.2 (linux-gnu/x86_64) Steam Runtime Version: steam-runtime-beta-release_2019-01-10 Video Card: Driver: Intel Open Source Technology Center Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2) x86/MMX/SSE2 Driver Version: 3.0 Mesa 18.3.1 OpenGL Version: 3.0 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x8086 DeviceID: 0x1916 Revision Not Detected Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 1920 x 1080 Primary Display Size: 13.54" x 7.60" (15.51" diag) 34.4cm x 19.3cm (39.4cm diag) Primary VRAM Not Detected Sound card: Audio device: Conexant CX20724 Memory: RAM: 11415 Mb Miscellaneous: UI Language: English LANG: en_US.utf8 Total Hard Disk Space Available: 20030 Mb Largest Free Hard Disk Block: 6282 Mb VR Headset: None detected Recent Failure Reports:
Last edited by apocalyptech; Feb 21 @ 7:42am
< >
Showing 1-15 of 17 comments
Just a case of the Steam API file having a wrong name/location. Should be easy for the dev to fix :)

For now, you can re-name it and put it where it wants to play (from the log file).
Well, in this case the problem was that the files were flat-out missing. I'd checked the original Snakebird, and it didn't have those files either, so I wasn't sure if those messages were just a red herring or something.

However, I did find a couple files that Snakebird had which Snakebird Primer doesn't: Snakebird_Data/Plugins/x86/libCSteamworks.so and Snakebird_Data/Plugins/x86/libsteam_api.so

I copied those over (though of course the dir name for this one is "SnakebirdPrimer_Data") and now it launches fine! So yeah: if you've got a Snakebird install, copy those over and you should be good.

One other issue I had was that in fullscreen it seems to just give me a totally-white screen - graphics are completely missing. Since I like doing puzzle games in windowed mode anyway, I altered my "prefs" file (~/.config/unity3d/Noumenon Games/Snakebird Primer/prefs) like so:

<pref name="Screenmanager Fullscreen mode" type="int">3</pref> <pref name="Screenmanager Resolution Height" type="int">900</pref> <pref name="Screenmanager Resolution Width" type="int">1600</pref>

Obvs. the actual resolution can change to whatever you want, but the "3" for windowed mode is the important bit.
Thanks to a gift, I can confirm it is indeed missing the Steam API file. I've emailed the developer and pointed them here.
Bronsky Feb 21 @ 3:36pm 
This is also happening to me
Are the devs working on this? Did someone contact them about it? This game flat out won't start at all. Pretty major bug!

[Steamworks.NET] Could not load [lib]steam_api.dll/so/dylib. It's likely not in the correct location. Refer to the README for more details. System.DllNotFoundException: steam_api at (wrapper managed-to-native) Steamworks.NativeMethods:SteamAPI_RestartAppIfNecessary (Steamworks.AppId_t) at Steamworks.SteamAPI.RestartAppIfNecessary (AppId_t unOwnAppID) [0x00000] in <filename unknown>:0 at SteamManager.Awake () [0x00000] in <filename unknown>:0 [/cpde]
Last edited by Wuffyhumps; Mar 2 @ 7:59pm
This is happening for me too, though the above instructions helped getting it to start. Unfortunately the map screen doesn't work so my daughter can't play past the first level.
Sounds like the developer should really read this really awesome summary of how to compile/package games for Linux:

https://gist.github.com/flibitijibibo/b67910842ab95bb3decdf89d1502de88

Obviously the packaging part isn't relevant unless they release this on GOG where they need the GOG installer, but the rest of it is totally relevant, telling you what libraries need to be included along with your game.
Last edited by Wuffyhumps; Mar 3 @ 7:21am
Oh they did do that properly but just forgot some Steam files? My bad then. Still a great read, though! :3
Liam said the developer was hoping to have the patch out by this weekend but missed it, so hopefully it should be fixed soon!

https://www.gamingonlinux.com/articles/casual-puzzle-game-snakebird-primer-is-out-with-linux-support.13584/comment_id=149718

Thanks Liam and Noumenon Games! Snakebird is one of my favorite games! :3
The game now loads after the patch, but the game screen is completely white. The company logo and menu are not visible.
Originally posted by Wuffyhumps:
The game now loads after the patch, but the game screen is completely white. The company logo and menu are not visible.
I emailed the dev about it.
Bronsky Mar 4 @ 10:35am 
I can confirm the white screen issue
For now, delete your prefs file in the Unity folder or edit it to set it manually. It sets the res to 1x1.
Oh yep, oops, a "fresh install" (aka deleting your prefs) works great! Only the silly Unity3D NVIDIA graphical bug across the bottom of the screen now. I don't recall the solution for that, is it a Unity3D patch/update?
What the eff? Now the corrupted pixely-looking stuff across the bottom of the game is gone, and all I did was close and re-open the game. I can't get the issue to re-appear...maybe it will come back, maybe it won't. It's the same bug I've seen in certain other games before such as the map in Slime Rancher. I know Liam knows what I'm talking about! :D

Weird, will keep a lookout for it and see if I can reproduce it...

Regardless, thanks Noumenon Games devs for the Linux support and for the quick fix!!! Awesome game as always! <3
Last edited by Wuffyhumps; Mar 4 @ 8:42pm
< >
Showing 1-15 of 17 comments
Per page: 15 30 50