This game is now available on Steam!

Thanks for your help in getting this game selected for distribution via Steam. More information including a link to the Steam store page can be found below.

Real Heroes: Firefighter
Scientifically Proven  [developer] Oct 10, 2012 @ 7:05am
Real Heroes: Firefighter DEMO
First Person Action/Shooter

FREE DEMO at - http://download.cnet.com/Real-Heroes-Firefighter/3000-7441_4-75791581.html

Reviews :

IGN.com - “Real Heroes: Firefighter definitely feels like a much different experience than the traditional FPS affair” and it’s “solid and impressive”. Nominated by IGN.com for "Shooter of the Year"

Gamespot.com - “Real Heroes: Firefighter is a very respectable, unique take on life as a firefighter” full of “tense expeditions into burning buildings”. “…an intense action game that would appeal to gamers of all ages.”

Kombo.com - “All in all, Real Heroes is about giving you an unforgettable experience.”

Extremegamer.ca - “The gameplay is intense and packaged into a fun campaign” and “the game industry needs more inspirational games like Real Heroes: Firefighter.”

If you enjoy the demo please VOTE! By pressing the THUMBS UP BUTTON you help our game get added to Steam!

Last edited by Scientifically Proven; Oct 11, 2012 @ 4:15pm
< >
Showing 1-10 of 10 comments
Psycho Oct 13, 2012 @ 2:09pm 
Sorry, it didn't work for me: "Game.exe has encountered a problem and needs to close. Sorry for the inconvenience"

I suspect a shader issue - my machine is subpar (ATi AGP X850 256Mb) - I am currently rebuilding.

Accompanying data for crash:
<?xml version="1.0" encoding="UTF-16"?> <DATABASE> <EXE NAME="Game.exe" FILTER="GRABMI_FILTER_PRIVACY"> <MATCHING_FILE NAME="Game.exe" SIZE="3614208" CHECKSUM="0x1AF9C03C" MODULE_TYPE="WIN32" PE_CHECKSUM="0x377D0F" LINKER_VERSION="0x0" LINK_DATE="03/22/2012 20:37:01" UPTO_LINK_DATE="03/22/2012 20:37:01" /> <MATCHING_FILE NAME="mss32.dll" SIZE="450560" CHECKSUM="0x426AA60" BIN_FILE_VERSION="7.2.2.0" BIN_PRODUCT_VERSION="7.2.2.0" PRODUCT_VERSION="7.2c" FILE_DESCRIPTION="Miles Sound System" COMPANY_NAME="RAD Game Tools, Inc." PRODUCT_NAME="Miles Sound System" FILE_VERSION="7.2c" LEGAL_COPYRIGHT="Copyright (C) 1991-2008, RAD Game Tools, Inc." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x0" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="7.2.2.0" UPTO_BIN_PRODUCT_VERSION="7.2.2.0" LINK_DATE="04/01/2008 07:23:49" UPTO_LINK_DATE="04/01/2008 07:23:49" VER_LANGUAGE="English (United States) [0x409]" /> <MATCHING_FILE NAME="unins000.exe" SIZE="1063198" CHECKSUM="0x5B1E148D" BIN_FILE_VERSION="51.52.0.0" BIN_PRODUCT_VERSION="0.0.0.0" FILE_DESCRIPTION="Setup/Uninstall" FILE_VERSION="51.52.0.0" VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x60000" UPTO_BIN_FILE_VERSION="51.52.0.0" UPTO_BIN_PRODUCT_VERSION="0.0.0.0" LINK_DATE="06/19/1992 22:22:17" UPTO_LINK_DATE="06/19/1992 22:22:17" VER_LANGUAGE="Language Neutral [0x0]" /> </EXE> <EXE NAME="kernel32.dll" ...not relevant, snipped/> </EXE> </DATABASE>

Last edited by Psycho; Oct 13, 2012 @ 2:11pm
Scientifically Proven  [developer] Oct 15, 2012 @ 8:46am 
Thanks for the feedback. We will look into it.
Flava Clown May 1, 2013 @ 4:31am 
The Demo doesn't work for me either, no error message, nothing, it just keep showing the rotating (icon) logo.
My specs: http://pastebin.com/EuCq71ch

edit: I've seen a post where you mention the .netFramework here is what I've installed
{LINK REMOVED}

I'll install version 4.5 now to see if that helps.

edit 2: I've installed .netFramework 4.5 and started Windows Update, which found some updates for other .netFramework versions.
It still won't go any further than the "loading screen", while using 50% CPU power, there were also some hard disc activity and I've waited for a reasonable time to see if something is going to happen, but still nothing.
Last edited by Flava Clown; May 1, 2013 @ 5:47am
Scientifically Proven  [developer] May 1, 2013 @ 11:54am 
Flava, thank you for the additional info. We are working on updated libraries now and will hopefully have a new build/patch available soon. Thank you for your support.
Flava Clown May 1, 2013 @ 12:11pm 
If you want me to try a test build or play around with the actual build then let me know:
http://flavaclown.de/contact.php
Scientifically Proven  [developer] May 13, 2013 @ 4:46pm 
For those having issues. Did you install the game into the default directory? (program files) or a custom directory? If you did install into a custom please try a default installation and let us know. Thank you.
Flava Clown May 14, 2013 @ 9:37am 
I had it in a custom directory, uninstalled it (with RevoUninstaller to be sure that nothing is left) and then (re-)installed it in the default directory, it still won't go any further than the "loading screen".
I've tried also to run the game.exe as admin, still the same.
Scientifically Proven  [developer] May 14, 2013 @ 12:16pm 
Thanks for the feedback. Will update ASAP.
Miranda Jun 14, 2013 @ 7:29am 
i love this game ! :D
XGN GEN0CYDE Jun 21, 2014 @ 11:43am 
man a lot of people are having issues with their game. My demo ran just perfectly.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50