Mount & Blade: Warband

Mount & Blade: Warband

The Last Days of the Third Age
 This topic has been pinned, so it's probably important
Swyter  [developer] Apr 18, 2016 @ 2:11pm
Official Mac OS X Install Guide
This will show you how to install the Warband version of The Last Days of the Third Age in macOS. Just make sure that the three latest .7z files from https://tldmod.github.io are already in your Downloads folder.


PART ZERO -- HOW TO OPEN THE TERMINAL

Open the «Go» menu in the Finder and select «Utilities», then click on the «Terminal» icon.

We will go line by line, just copy-paste the various commands in the Terminal and press Enter. I will explain what it does first to avoid looking sketchy.

PART ONE -- TEMPORARILY INSTALLING THE UNARCHIVER

This switches your Terminal to your temporary directory (the one that gets flushed every time you reboot), then downloads the unar command-line utility (from the same guy that makes 'The Unarchiver') and extracts it in that very same folder:

cd /tmp && curl -L 'https://theunarchiver.com/downloads/unarMac.zip' -o unar.zip && unzip -o unar.zip

Don't worry, it's only two tiny programs (lsar and unar) that will go away the next time you shutdown your Mac. They leave no trace behind.

This opens the Warband Mods folder in the Finder so that you can delete the «TLD» folder if already exists. If not, carry on:

open ~/'Library/Application Support/Steam/steamapps/common/MountBlade Warband/Modules/'

PART TWO -- INSTALLING THE MOD

Next up we are going to extract the mod in that very same place. Just ensure that the three latest .7z files from https://tldmod.github.io are already conveniently stored in your Downloads folder.

Let's switch to the Downloads folder, where the compressed files are.

cd ~/Downloads

1. Extract the standalone TLD 3.5 release for Warband:

/tmp/unar -D -f -o ~/'Library/Application Support/Steam/steamapps/common/MountBlade Warband/Modules' TLD_3.5_wb.7z

2. Extract the latest Warband nightly patch (the one that comes with the latest updates) and, you guessed it, overwrite yet again:

/tmp/unar -D -f -o ~/'Library/Application Support/Steam/steamapps/common/MountBlade Warband/Modules' `find . -name 'TLD_3.5_wb_*' | sort -r -u | head -n 1`

PART THREE -- FIXING WARBAND

The mod is now technically installed, if the Warband engine worked as intended we shouldn't have to do any of the following workarounds.

1. First fix the font by... overwriting Native's:

cd ~/'Library/Application Support/Steam/steamapps/common/MountBlade Warband/Modules/TLD/' && cp -f ./Textures/font.dds ../../Textures/

cp -f ./Data/font_data.xml ../../Data/

2. Then you can fix the collision bodies so that you can actually hit baddies:

cp -f ./Data/skeleton_bodies.xml ../../Data/


That's it. Open Steam like your normally do and use Warband's Configure utility to change the selected mod to «TLD». If you followed this guide properly then the game should launch and reach to the main menu.

Have fun in Middle-Earth!
Last edited by Swyter; Oct 7 @ 8:46am
< >
Showing 1-15 of 140 comments
Woder Aug 20, 2015 @ 6:09am 
Originally posted by Kham:
Hi all,

Here is a potential fix for those playing on Mac or Linux:

  1. Download the zip here
  2. Go to your Steam Workshop Folder (Steam --> SteamApps --> Workshop --> Content --> 48700 --> 299974223)
  3. Unzip the Contents of that zip file (GLShaders folder) within that folder. [/li]
  4. So you should see a Folder named GLShaders copied over
  5. Play

Please test it out and see if it fixes your issues.
Good sir Khan, After we unzip the files and such where do we put the GL Shaders. Do we put in textures? Or just the whole mods Folder?
Kham  [developer] Aug 20, 2015 @ 6:14am 
Put the folder, GLShaders into the Mod folder.

So, /299974223/GLShaders
Hymeros Aug 20, 2015 @ 6:21am 
i really dont have that in my steam content, i dont have steam in any library at all. not on mac.
Kham  [developer] Aug 20, 2015 @ 7:08am 
You have to help me out then, I don't have a mac.

Try to look for where you installed Steam. Once you found the folder, let me know what folders are inside.
It Broke all my modules.
Kham  [developer] Aug 20, 2015 @ 10:06am 
You have to put the GLShadess only WITHIN the TLD directory, not your Mount & Blade Warband Directory.

Like I said here:

Go to your Steam Workshop Folder (Steam --> SteamApps --> Workshop --> Content --> 48700 --> 299974223)
dikky_papran Aug 20, 2015 @ 11:32am 
The addition of the GLShaders folder makes the game crash upon opening it. I played around a little and it starts without the "techniques.xml" but is missing a ton of textures, and crashes upon attempting to play. maybe it is something specifically in the "techniques.xml"?
Jormundgand Aug 20, 2015 @ 2:47pm 
On Linux: before adding the shaders, the main menu would load and I would be able to pick "new game", after which the game would just crash. After adding the shaders, the game spawns a black windows, which stays black. No crash on the black screen; couldn't interact with anything though.
Last edited by Jormundgand; Aug 20, 2015 @ 2:48pm
jankmaster98 Aug 20, 2015 @ 3:44pm 
DId exactly that for my mac copy, the mod crashes when I try to open it
File path Library-application support- steam-steam apps-workshop-content-48700-299974223. I'm prrey sure i did it right, as I downloaded the file and placed in the last numbered folder.
Kham  [developer] Aug 20, 2015 @ 3:53pm 
It looks like this potential fix is really not a fix :(

I apologise, just wanted to try it out.

So for those with Mac / Linux, Steam Workshop won't be an option until Taleworlds decides to whitelist these shaders.

You can play on Mac / Linux by performing the steps here[tldmod.github.io]
Jormundgand Aug 20, 2015 @ 4:15pm 
No complains from my side -- hard work should always be appreciated.

The instructions doesn't appear to fix anything though -- unless I messed up, it's exactly the same as subscribing + installing the shaders (i.e. black screen).
Last edited by Jormundgand; Aug 20, 2015 @ 4:24pm
Frank Fei Aug 20, 2015 @ 5:30pm 
not working :( i cannot open the game my friend
Valar Melkor Aug 20, 2015 @ 6:52pm 
It's alright, guys. There's a fix that works for Mac/Linux, but the best part is that it works with every Warband mod. Kham spread the word. Basically, go into that same TLD directory, then go to textures and move the file font.dds to trash. This is a guaranteed working fix that helps the font show up
Captain Von Baron Aug 21, 2015 @ 8:29pm 
sirpukington your a genius
Captain Von Baron Aug 21, 2015 @ 8:29pm 
oh never mind
< >
Showing 1-15 of 140 comments
Per page: 15 30 50