Este jogo agora está disponível no Steam!

Agradecemos a sua ajuda em selecionar este jogo para ser distribuído pelo Steam. Mais informações, incluindo um link para a página na loja Steam, podem ser encontradas abaixo.

Hammerwatch
Xphere Omega 8/ago/2013 às 1:22
Abnormal CPU usage
Hammerwatch(1.06)'s CPU usage seems too high and abnormal for me.

It sucks up one of my CPU core power and make the core usage to almost 100%.
I've changed several settings but turned out it's not the problem of settings.

And one of my friend doesn't undergo this kind of problem(core usage is really low in his system), so maybe it's the problem between my system and Hammerwatch.


Some of my system specs are:

CPU : i7 3820@3.6G
GPU : GeForce 780 x2(SLI on or off)
O/S : Windows 7 64
HDD : SSDs
...and so on.


Any idea why this happen or suggestion?
Anybody experiencing this kind of problem?
Exibindo comentários 13 de 3
< >
Heart Invader 8/ago/2013 às 2:36 
Is the game using the gpu at all? I had a problem where my computer would use all the cpu, because it wouldn't use the graphics card. When i made it use the graphics card, it was all fine. Try configure hammerwatch to use your gpu on max performance.
FalseTraitor 13 de jul às 21:48 
Escrito originalmente por MadManners:
Is the game using the gpu at all? I had a problem where my computer would use all the cpu, because it wouldn't use the graphics card. When i made it use the graphics card, it was all fine. Try configure hammerwatch to use your gpu on max performance.

@MadManners

can you pls tell me how you configured the game to use gpu? I have an ATI graphics card.
A Man From Reno 19 de set às 10:24 
I have this same issue, and there doesn't seem to be a way to tell the game to configure to use GPU instead of CPU. I don't know if that's the issue, but what I HAVE discovered is that the graphics settings are what's causing 50% CPU usage on a quad-core processor (Core2 Quad Q6600 Kentsfield - old, but games only need good GPUs since its generation).

I started experimenting. If I turn the graphics to minimum (except resolution - 1600x900), the game runs smooth and uses 10-20% CPU (still ridiculously high, no other game is even close). As I add in things, this increases. Light stuttering (frameskip every ~2 seconds) begins at around 45% CPU, and heavy stuttering (BIG frameskip at same rate) begins when I hit 50% and *keep* turning on more graphics options. It seems like 50% is the highest my computer is willing to allow the game to go -- even though it's consuming a bit of each core and not 100% of 2 of them and the other 50% is on System Idle Process -- so it starts cutting out more frames. I have annoying frameskipping even without the old-school graphics post processing options. So I experimented with what I like and am willing to sacrifice and have ended up with consistent ~40% usage. Sadly, the lighting option had to go. I really liked how that helped the game look.
Exibindo comentários 13 de 3
< >
Por página: 15 30 50