This game is now available on Steam!

Thanks for your help in getting this game selected for distribution via Steam. More information including a link to the Steam store page can be found below.

Frozen Hearth
DemiGoth Oct 25, 2013 @ 10:46pm
Game not starting
Like most, I bought the game through Groupies. I think this game has HUGE potential!
I installed the game just now, but unfortionately, after the update & patch process, the game is not launching. I get the launch button, and pressing it results in a void() action :( Any help..?
Showing 1-15 of 24 comments
< >
Pixel Killer Oct 27, 2013 @ 3:39pm 
I am also unable to get the game to launch. I do not get any error it just never launches and nothing is listed in running processes that would indicate the game is running. I am patched and registered. I am running on Windows 8 x64 with an AMD Radeon HD6800
jonhuggs Oct 28, 2013 @ 12:30am 
The same thing happens to me I'm on windows 8 also, I filled out a support ticket on their website and will comment back here when it gets resolved
]v[eta[_ Oct 28, 2013 @ 3:29am 
Same here
epiphanygames  [developer] Oct 28, 2013 @ 2:26pm 
Thats really weird never had that happen before. What if you try the executable instead of the launcher.
DemiGoth Oct 28, 2013 @ 2:29pm 
Not starting when I run the .EXE file alone. I did check with taskmanager, but the EXE is run for a VERY SHORT time (<1s).
Like john above, I'm running an AMD Phenom X6 1090T and use a GTX460 in SLI with Win 7 x64. My bet is that it's either the AMD processor bugging or the x64 Windows...

BTW, also made a ticket already on your site ;-)
Last edited by DemiGoth; Oct 28, 2013 @ 2:29pm
epiphanygames  [developer] Oct 28, 2013 @ 2:44pm 
Thanks for sending your specs through, this narrows it down for us. I haven't gone into work yet so haven't checked the tickets. We will get this fixed asap.
DemiGoth Oct 28, 2013 @ 2:47pm 
Originally posted by epiphanygames:
Thanks for sending your specs through, this narrows it down for us. I haven't gone into work yet so haven't checked the tickets. We will get this fixed asap.

I'll high-jack my wife's laptop tomorrow (11pm here now) and test the game there as well. That one uses an Intel CPU with Win 7 x64 as well. It should narrow things down a lot if it runs there or not ;-)
Pixel Killer Oct 28, 2013 @ 3:10pm 
FWIW, I have tried running the exe alone as well as in compatability mode for XP etc but it still will not launch. Thanks for jumping on this, it is very much appreciated.
DemiGoth Oct 28, 2013 @ 11:42pm 
FH runs 'normally' on my wife's laptop (Celeron CPU and Intel graphics). This means that the problem for not running the game should be the AMD architecture.
epiphanygames  [developer] Oct 29, 2013 @ 4:30am 
Does your wife have windows 8?
DemiGoth Oct 29, 2013 @ 6:59am 
Originally posted by epiphanygames:
Does your wife have windows 8?
Nope, Win7 x64
epiphanygames  [developer] Oct 30, 2013 @ 12:55pm 
So we have tracked down the issues, and are working on a solution.
DemiGoth Oct 30, 2013 @ 12:59pm 
Originally posted by epiphanygames:
So we have tracked down the issues, and are working on a solution.
Cool! Can't wait to play & test!
Pixel Killer Oct 30, 2013 @ 2:14pm 
Originally posted by epiphanygames:
So we have tracked down the issues, and are working on a solution.

Good news, thanks for keeping us upto date.
7dustfan Oct 31, 2013 @ 3:07am 
I was having this problem too. I was installing the game to another drive with my other games and not using the default install drive and path. I finally gave up and installed to my C drive and it works. But if you could fix this so it works when changing the install path I would appreciate it.
Showing 1-15 of 24 comments
< >
Per page: 15 30 50