GameMaker: Studio
 
Find, play, and make games easily
Discover, rate, and download the best player-created games made in GameMaker: Studio for free. Or try making your own and share with the community. Click here to learn more.
GproKaru 1 Nov 13, 2012 @ 4:51pm
(resolved but still needs fixing) Game not updating in steam workshop
I've tried literally everything besides removing the item and re-uploading it to try and fix this but so far nothing has worked. I've done the exact same process numerous times before to upload and update projects but it doesn't seem to update anymore.

[edit]

One other thing I noticed. It seems like the game is uploading, but it's uploading the same older version over and over even though changes have been made. So far I haven't figured out how to fix this.
Last edited by GproKaru; Nov 17, 2012 @ 5:19am
Showing 1-8 of 8 comments
< >
pxNeon 1 Nov 13, 2012 @ 5:31pm 
I've had this problem too. Game Maker Studios basically uploads the game in the background, so you'll have to wait a while till it actually updates. Don't keep trying to update, just do it once and wait a bit, like half an hour, and come back to your game page to see if the time has changed for your newest revision.

I wish they had a progress bar or something on the bottom so that we can know when Steam updates, but I guess we'll have to wait till they update the IDE for that.
GproKaru 1 Nov 13, 2012 @ 6:32pm 
I actually figured out what was going on. I was literally waiting 3 hours for one run because I thought the same thing as you. (That it would take a set period of time to upload) Which it does take time and it doesn't specify but I found out that aparently I have to change the export target to windows first and create a zip and THEN change to steam to upload it.
Darkrain 2 Nov 13, 2012 @ 8:56pm 
None of the above works for me. I have to just keep uploading over and over until eventually one gets through.
Bigboy  [developer] Nov 20, 2012 @ 7:45am 
We think we might have found the cause, but we're still investigating.... please bear with us...
Kerrigor 7 Nov 20, 2012 @ 9:53am 
Good to hear (y)
pxNeon 1 Nov 21, 2012 @ 3:43pm 
Awesome, glad to hear. :D
'Geddon Nov 25, 2012 @ 10:42am 
Any updates to this issue? I first noticed this was happening to me three days ago and is still occurring. And I mean an actual Dev fix, not the workaround described by the OP.

EDIT: The work around does work for me, but would still like to know if there is a for sure resolution.
Last edited by 'Geddon; Nov 25, 2012 @ 11:23am
Scorcher24 5 Nov 25, 2012 @ 2:31pm 
Yeah could really use a fix. Would like to update my game but the workaround did not do it for me.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50