Strike Suit Zero
 
New ships, weapons, missions, and more
Discover new ships, weapons and missions for Strike Suit Zero, created by others in the community. Or use the XedMod editor to create and share your own, or to create entirely new games. Click here to learn more and to get started.
Apex 3 Jul 30, 2013 @ 10:34am
Mod Creation - What are the biggest obstacles preventing you from modding?
Hi Everyone

It's been a bit quiet on the mod discussion boards and we haven't seen many mods go up. So what we want to know is this:

What are the main obstacles or challenges preventing you from creating mods?

Are the tools just too confusing?
Are the tutorials/videos too difficult to follow?
Is the scripting too confusing?
Are we not offering enough support? ( If so in which areas? )

Looking forward to hearing back from you guys so we can address these problems and helping you to make some mods!

Cheers
Showing 1-15 of 33 comments
< >
[TAW] tah;rox Jul 30, 2013 @ 10:47am 
What I want: To get an infinite level (like in SSI) with the missiles changed to a ridiculous ammount.

What I know: I can get a preset level, change prefabs around, and that is pretty much it. I dont know where the values are to change, for example 30 max missiles (SSMode) to 100. Getting an infinite enemy waves level, etc.

That is pretty much why I stopped trying, I looked around for the FAQs but I still can't figure out how to work it, so I was waiting for the pro modders to do something with it.
Apex 3 Jul 30, 2013 @ 10:58am 
Hi tahrox

If you are referring to the swarm missiles in mech mode the values you are looking for are in "Painting Missile Behaviour" on the Weapon_Missile_Mech prefab.

Does this help? :)
[TAW] tah;rox Jul 30, 2013 @ 11:10am 
Yes, will try later on. Also, any way to turn Z into SSI (I mean, make endless waves)?
Last edited by [TAW] tah;rox; Jul 30, 2013 @ 1:53pm
「Soma」 Jul 30, 2013 @ 1:31pm 
Still crashes at startup or shortly after startup across 26 of the 50 computers at my workplace.

[TAW] tah;rox Jul 30, 2013 @ 1:54pm 
I had problems with a pretty old version of W7, you might want to check that.
Apex 3 Jul 31, 2013 @ 3:01am 
Originally posted by (CBG) tahrox:
Yes, will try later on. Also, any way to turn Z into SSI (I mean, make endless waves)?

Yes, you could create a simple implementation using a loop in a state.

Last edited by Apex; Jul 31, 2013 @ 3:02am
[TAW] tah;rox Jul 31, 2013 @ 9:30am 
Originally posted by Apex:
Yes, you could create a simple implementation using a loop in a state.

Thanks mate!
Apex 3 Jul 31, 2013 @ 9:37am 
If you require any more help just ask.

Also if you have any ideas of how we can make creating mods easier we'd would love to hear them.
Last edited by Apex; Jul 31, 2013 @ 9:37am
「Soma」 Jul 31, 2013 @ 9:41am 
Quite a few people still can't even launch the program. Why not start with that?
Bluestone  [developer] 4 Jul 31, 2013 @ 10:02am 
Originally posted by 「 Soma 」:
Still crashes at startup or shortly after startup across 26 of the 50 computers at my workplace.

What is the difference between the machines where the tool crashes, and the machines where it works?
Do you have at least .NET 3.5 installed on all the machines?
What kind of crashes are you getting, is there any debugging information you can provide?

Thanks..


「Soma」 Jul 31, 2013 @ 10:14am 
Originally posted by Bluestone:
Originally posted by 「 Soma 」:
Still crashes at startup or shortly after startup across 26 of the 50 computers at my workplace.

What is the difference between the machines where the tool crashes, and the machines where it works?
Do you have at least .NET 3.5 installed on all the machines?
What kind of crashes are you getting, is there any debugging information you can provide?

Thanks..

All of the machines are running Windows 7 ULT
All of the machines are running the latest version of .Net
All of the machines are current with updates

It crashes when loading resources
All machines crash at the same point in loading
Very few crash at the same spot as another machine

The only differences are the programs installed on them. Unfortunately, as I am not at work, I am unable to provide any significantly detailed information. I tested it in such a manner after getting frustrated that none of my 4 home computers would launch it.
Wong Aug 21, 2013 @ 1:24pm 
Maybe the modders just aren't there... which is a sad thought. :\
a friendly cup of coffee Aug 30, 2013 @ 5:23am 
Already posted this in the official mod forums, but since the steam patch on the 28th Xedmod Project/Run (f5) and Project/Test (f6) are broken for me and only open the Launcher window. So i guess right now i'd say that's the biggest obstacle for me.

Would be interested if that's a common issue or just something on my end. :)
Last edited by a friendly cup of coffee; Aug 30, 2013 @ 5:27am
a friendly cup of coffee Aug 30, 2013 @ 5:25am 
Addendum: technically i can still "test" using a batch file with SSZ.exe -ModTools "dir", but that takes forever and i don't receive any debug output at all.

Hope i'm not too late for this, only just bought SSZ and SSI... :(
Last edited by a friendly cup of coffee; Aug 30, 2013 @ 5:27am
Apex 3 Aug 30, 2013 @ 8:32am 
Hi Rcw

I have just directed our tools guy to your post and he will investigate the issue asap.
Last edited by Apex; Aug 30, 2013 @ 9:48am
Showing 1-15 of 33 comments
< >
Per page: 15 30 50