Team Fortress 2
Have you got what it takes?
Create and submit new items (such as hats, weapons, badges, boots, and more) for consideration to be incorporated into the actual game. Click here to learn more.
jnazaren 2 Dec 21, 2012 @ 1:29pm
Trouble With Testing Item
I created a new bat for the scout in Blender (using obj format), UV wrapped it, and compiled it with itemtest (source sdk), only to see that my model was too small on the test server- couldn't see it at all. I then resized the bat in blender to fit the sized of the scout model I imported and then exported the bat again, compiled it, but when I went to test it, I got a bit ERROR sign above my head on the test server, even though the model loaded perfectly in HLMV (half- life model viewer). Why is this happening??? Is it because I made the stem (holding place) of the bat a little too thick? I tried importing it through the new import tool (beta), but tf2 crashed as soon as I clicked "preview". Can anyone help???
Showing 1-15 of 20 comments
< >
Pogo 44 Dec 23, 2012 @ 4:46am 
Error usually means missing or corrupt model, re-export it from blender and compile again.

To make sure you get the sizes right, you could try to decompile existing models and import them into blender for comparison.

The first few steps of this might help you out.
http://forums.steampowered.com/forums/showthread.php?t=1536668
jnazaren 2 Dec 23, 2012 @ 9:34am 
Thank you so much for the advice! I have gotten the model into the game (using the itemtest map) but instead of moving with the scout's hand, the bat just stays in mid- air, hovering just above the scout's line of sight in front of him. This is probably because I haven't attached it to an armature, but when I tried to do so, itemtest gives me the error- "joint [joint name] is not in the item's list of transform joints. This is illegal.". I am really confused with attaching the item to an armature and "skinning" it in blender. How do I compile qc files manually???
Pogo 44 Dec 30, 2012 @ 9:11am 
http://www.kritzkast.com/tf2_mod_guide

Check through some of the blender based tutorials there, helljumpers and mnemos are probably most useful for you.
jnazaren 2 Jan 4, 2013 @ 6:25pm 
These tutorials by helljumper are for making hats, which I've learned from experience are completely different from scout bats. I checked out some tutrials on reskinning bats, but this just involves wrapping the same model with a different material- NOT changing the shape of the model. I have been advancing in both software (now using helljumper's software) and progress on this model, but still am having a lot of trouble with getting the bat INTO THE SCOUTS HAND. Is there any tutorial that is specifically targeted towards bats or covers this? The "trial and error" process I'm currently on is getting to be a real pain. :(
Professional Spycrab Hunter 7 Jan 5, 2013 @ 4:35am 
First of all, NEVER use itemtest (i.e. the one in the SDK) for anything that's not a hat (IMO, don't use it at all, not even for hats). Just compile them manually like in HellJumper's tutorial which Pogo already mentioned.

Second, HellJumper's tutorial works for everything, also weapons, the process is essentially the same. Make sure the bat is assigned to the right bones (in this case is only "weapon_bone" ) and that the filepath in the .QC puts the files in your "models/weapons" folder instead of the "models/player/items" folder. I've never ever done this before but I asume this is the general modus operandi.
jnazaren 2 Jan 5, 2013 @ 10:56am 
I'm not using itemtest anymore, and have done exactly everything as stated by helljumper, and have gotten the bat to appear, but still it is floating just above or near the scout's hand. Is there any way to fix this?
Professional Spycrab Hunter 7 Jan 5, 2013 @ 11:30am 
Seems like it doesn't register as a weapon. I've never done it before myself but as far as I know it should work. Are you sure the .qc puts your models in the weapon folder?
jnazaren 2 Jan 5, 2013 @ 8:45pm 
Yes- I checked that. When I decompiled the model of the original (stock) in- game scout bat and edited its qc file with notepad++, there was a line that determined what the directory/ name of the final .mdl file was going to be. The bat I made even bagan to move with the scout's hand when I parented it to the weapon bone, signaling that the parenting worked, but for some reason, it always turns up near or around the scout's hand, instead of being in it.
Professional Spycrab Hunter 7 Jan 6, 2013 @ 5:10am 
I think the problem is in the .smd then. Go to Object Mode and press N. Make sure that all the values of Transform, Rotation and Scale (in your case probably only Transform) are 0. Then go to Edit mode and reapply the Transformation. Decompile another bat and try to mimic it's placement.
jnazaren 2 Jan 6, 2013 @ 8:47am 
for some strange reason, whenever I try to decompile a model (using GCFScape and studiocompiler) it always gives me a message saying it could not open the parts/smd file that was the actual bat model itself. It only decompiles the smd files containing the animated armatures, so I never actually got to see the position of an original bat. The position of my bat model in edit mode is completely different from the bat's position in object mode. Moving the edit mode version will also mess up the position of the object mode version.
Professional Spycrab Hunter 7 Jan 6, 2013 @ 9:43am 
Decompiling with GUIStudioMDL? That won't work, you need to use MDLDecompiler. Make sure that when you open the .mdl file with Notepad++ the first line says IDST, and not IDST0, otherwise it won't work.
Last edited by Professional Spycrab Hunter; Jan 6, 2013 @ 9:44am
jnazaren 2 Jan 6, 2013 @ 11:05am 
I decompile with studiocompiler (which is made by the same person and has mdldecompiler built into it) and compile with guistudiomdl
jnazaren 2 Jan 7, 2013 @ 1:12pm 
IT WORKED!!!!!!!! Finally! I completely mimicked the position of the other bat and I believe that did the trick. The only thing I have to do now is get the chekered pattern off and a texture on. I already have the tga, vmt, and vtf files for the model- what folder do I put them in so that they appear?
Professional Spycrab Hunter 7 Jan 7, 2013 @ 2:04pm 
You don't need the Targas, only the .vmt and vtf. files. In the tf folder (where you also made the models folder), make a folder called materials, make a folder in that called models, in that weapons and there you are. I think. Haven't done it before.
Last edited by Professional Spycrab Hunter; Jan 7, 2013 @ 2:04pm
jnazaren 2 Jan 8, 2013 @ 12:00pm 
OK- I have compiled it and gotten one of the skins (red) to work. Even though HLMV loads my two skins and adds them to the dropdown list of skins, why isn't my blue skin working??? (In the material directory of my model, there are 4 files- 2 vtf's and 2 vmt's)
I added the $texturegroup variable to my qc file, but everything stays exactly the same.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Dec 21, 2012 @ 1:29pm
Posts: 20