Team Fortress 2
 
Have you got what it takes?
Create and submit new items (such as hats, weapons, badges, boots, and more) for consideration to be incorporated into the actual game. Click here to learn more.
polysketch 1 Dec 11, 2012 @ 12:19am
Publishing ERROR - totally stucked
Hello guys,

My first item has been compiled with ItemTest, everything works brilliantly in my testroom. I haven't created any other item with this same name either. Also checked workshop and it also doesn't have such item with the same name from other creators...

....however publish my item online leads to this error: "failed to publish file! check to see if you have another item that has the same name!"

I've followed tutorial here: https://developer.valvesoftware.com/wiki/Itemtest and I am not a newbie in 3d modeling world either.

Additional things I tried already:
1) "Import.." Beta publishing option. Specifying everything and as soon as hitting a "Preview" button - ends up with windows message that hl2.exe is not responding no more, and it crashes.

2) locating every single file containing my item name in Steam directory on my HDD, deleting it, then importing it one more time. Same error message about another item having the same name.

3) Installed fresh copy of TF2 on another computer and tried to import - same error again.

4) Created new item with ItemTest and named it totally differently during the process.. Item works fine in my testroom, but as soon as I try to publish it - same error again.

5) Disabled Steam Cloud synchronization for TF2

6) Manually deleted everything from E:\Program Files (x86)\Steam\userdata\*number*\

7) Verified Integrity of Game Cache, Defragmented Cache files

8) Messaged support, but it is already 72 hours and still no answer. No idea how long does it take here usually? Additionally - emailed Robin Walker through TF2 staff contacts form.

9) Created totally new account, uninstalled Steam (wiped it from HDD first), restarted computer, created item with itemtest under newly created account, tried to publish - again the same error!

10) Installed Windows XP x86 from zero on another computer (just to make sure it is not a problem of particular Win7 installation I tried initially), installed Steam, TF2, SDK. Created item (unique name again) with ItemTest, tried to publish, and guess what - the same error again.

To be honest - no idea what else can I try. Forum search revealed several others having the same issue reported previously over the time, but funnily enough - there was no answer posted in any of those threads.

Running on win7 64x

Greatly appreciate your time helping me out, Thanks


SOLVED:
***********
It turned out that you have to have a premium account before uploading anything to TF2 Workshop. Loaded 5EUR to my account, bought a backpack item and my account changed its status to Premium. From that point on - no more errors of this kind.

Will also write this to TF2 staff so this information is included in Workshop FAQ and/or TOS.
Last edited by polysketch; Dec 13, 2012 @ 12:09pm
Showing 1-15 of 15 comments
< >
Poghost 34 Dec 11, 2012 @ 2:23am 
You seem to have covered every angle with your error tracking, support should be your best bet, if not go straight to the tf2 team and try to get an answer. The only thing you haven't done is refreshing the steam content.
Go to your steam folder and delete everything apart from steam.exe and your steamapps folder, then launch steam and let it download the client again. Should only take a few minutes. It could also be a back end problem at valve with the workshop service, though someone else should have noticed by now.
polysketch 1 Dec 11, 2012 @ 2:32am 
Thanks Pogo for your input, I bet your suggested thing would happen anyway during the full reinstall which I mentioned on point 9.
Poghost 34 Dec 11, 2012 @ 2:35am 
May have done yeah. I suspect it's a backend problem then.
Out of curiosity what is the item name and what are the zip and preview images called?
polysketch 1 Dec 11, 2012 @ 2:54am 
zip file is automatically created by ItemTest and is always named exactly as I specify the item's name on Itemtest's item creation first step. So for example if i choose my_greatest_item then zip file will be my_greatest_item.zip

Preview image file - well, didnt thought it might matter, but it is just cover.jpg

EDIT: naming it my_greatest_item.jpg is not helping either
Last edited by polysketch; Dec 11, 2012 @ 3:08am
polysketch 1 Dec 12, 2012 @ 2:21am 
Not quiet sure it is a Steam's backend issue either, since I see some new items being added to workshop while i am since experiencing the same problem.
Poghost 34 Dec 12, 2012 @ 5:07am 
If steam support aren't getting back to you then try email the tf2/workshop team directly - if you don't have an address for anyone there just ask to be forwarded there
polysketch 1 Dec 12, 2012 @ 7:09am 
not sure how long should I wait for support, second day already, no sign of anything yet... is there any particular person I should email about this from tf2 team directly? Somewhere on the forums I've already found somebody saying to email Robin Walker, which I already did couple of hours ago. Thanks.

P.S. Also added 10) to my initial post
Last edited by polysketch; Dec 12, 2012 @ 7:13am
polysketch 1 Dec 13, 2012 @ 12:36am 
DAY3, still no news from support or any TF2 staff who might shine a light on this in some way.

Therefore with the feeling of "if I will not solve the quest, nobody else will do it for you" started to think maybe there's something wrong with my model?

To trace down the problem, I've opened Blender and did the following: added simple sphere object, did 3 LODs, saved each as separate .obj, created 24bit TGA texture without alpha channel, compiled everything with ItemTest (works fine in testroom again) and tried to upload, ... no wonders - same error :)

At this point, it would be very helpful if I could share the ZIP file created by itemtest and some fellow TF2 item creator might try to upload it from his/her account. If he would be facing the same error - then the problem would clearly be in the model. At least that would give further direction where to look at. So .. if somebody feels up for this - would truly appreciate your input.

Thanks.

Last edited by polysketch; Dec 13, 2012 @ 12:36am
Poghost 34 Dec 13, 2012 @ 12:55am 
Add me and I'll try upload it tonight - if you emailed robin then he'll forward it to someone who can hopefully help.
polysketch 1 Dec 13, 2012 @ 1:03am 
umm.. unfortunately cannot add you, add button is greyed out and it says: "Some features of the Steam Community become available once you have games in your Steam account." - well TF2, SDK - that's all i currently need from Steam and both are in my account :). Is there any other way I could connect with you?
Last edited by polysketch; Dec 13, 2012 @ 10:43am
Poghost 34 Dec 13, 2012 @ 6:25am 
That might be your problem - if you have only a limited account, some features of steam are not available to you. This might even include the workshop. If you can, try to buy something from the steam or mannco store to get rid of the limit on the account.
If it doesn't work, add me as a friend and I'll try upload for you.
polysketch 1 Dec 13, 2012 @ 10:28am 
Hmm, very interesting twist... I am pretty sure I've re-read the Workshop FAQ several times, it didn't mention this aspect in any form.
Last edited by polysketch; Dec 13, 2012 @ 12:10pm
polysketch 1 Dec 13, 2012 @ 12:10pm 
Mystery solved. It turned out that you have to have a premium account before uploading anything to TF2 Workshop. Loaded 5EUR to my account, bought a backpack item and my account changed its status to Premium. From that point on - no more errors of this kind. Thanks Pogo for brilliant assistance.
Omny87 3 Jul 7, 2013 @ 6:52pm 
Hey, I have a premium account and I'm getting the same error as you. I can't upload anything.
blackcap2™ 2 Jul 7, 2013 @ 10:52pm 
Same with me. :(
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Dec 11, 2012 @ 12:19am
Posts: 15