Sid Meier's Civilization V
 
Create and Discover New Worlds
Maps, Scenarios, Interface, and so much more. Explore the modding world of Civ V, and when you’re ready, download the SDK to create and upload your own.
xela_alpha May 4 @ 8:43am
Trouble with a Mod.
Ok. This is probably the wrong place for this, but this is my first time posting here, so I figured I'd give it a shot.

I am currently working on a mod to add a new civilization to the game. I've gotten the basics of the civ (everything but UU/UB, Icons and a picture of the guy) put down, I've built the mod, turned everything on in the action thingy, saved it, and it shows up in the mod list, but when I go to select a country, my new civ isn't there. Any ideas?
Showing 1-6 of 6 comments
< >
lshipp 11 May 4 @ 9:04am 
no UU or UB or no U Improvement. Every civ has to have a total of at least two uniques. They can be any combination of UU/UB/UI, but the civ MUST have two
xela_alpha May 4 @ 10:31am 
Ohhhhhhhhhhh....Thanks. I'll try that and see if it helps.
xela_alpha May 4 @ 12:46pm 
@Ishipp: Unfortunately, that didn't work. I can't find anyhting wrong with what I have, but I am new at this, so...

At least now I have my unique stuff out of the way...any other suggestions?
dabeastlybeast 8 May 4 @ 3:02pm 
Have you tried looking at the logs? They can be really helpful in finding typos and syntax errors. Here's a tutorial on how to enable and check them. http://forums.civfanatics.com/showthread.php?t=487482&highlight=Logging
xela_alpha May 4 @ 7:41pm 
@dabeastlybeast: Thanks...I'll give that a try.
lshipp 11 May 4 @ 8:46pm 
yeah, OK, sorry. If your civ is not showing at all AND you can scroll through the other civs to make a selection from the list, then mostly likely the game is aborting your mod. you'll need to follow dabeastlybeast's advice and see what you get when you enable logging. Some part of your mod is not acceptable, most likely I would think in the definition of the civ itself, or the leader, since you get nothing in-game. The game set-up screen is in-game, for this purpose,
Also look for accidental repeats of commands in your XML.

A friend of mine had his whole world wonder mod abort on loading because he had two <PortraitIndex> commands (even though they were set to the same value) in his XML definition of the wonder. Once I saw the second command in his XML is was obvious where the problem was. His world wonder is now on the steam workshop and has about 1,000 subscribers. The point ? DON'T GIVE UP !!

And also think about a sign-up over at civfanatics. the people over there are generally willing to help if you ask, and zip a copy of your logs and/or your mod. Don't be afraid to try them out. They won't be trading secreet emails back and forth and laughing at you because you made a mistake they think is basic-level stuff.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: May 4 @ 8:43am
Posts: 6