Portal 2
 
Community maps. For science.
Welcome to Aperture Laboratories, home of the Perpetual Testing Initiative. Easily create, share and play test chambers authored by and for the Portal 2 community. Do your part! Contribute to Science!
Geekii Bookworm 3 Feb 19 @ 3:00pm
P2 Authoring Tools doesn't run the map
Alrighty, firstly, thanks for reading, I'm really hoping I can get some help here. I'm new to map-making, so far I've made 3 using the workshop. I've played a few really great maps made by others of this wonderful community, and it was very obvious that they were made using the authoring tools, so, I decided, why not learn myself?

I downloaded the tools via steam, and I followed: https://developer.valvesoftware.com/wiki/Level_Design_Introduction_(Portal_2)/Your_First_Level

this guide to start me out. I did everything that was listed, and I am going to assume I did it correctly. However, when I try to run the map, I can't, and I have no clue as to why.

Is it because it's attempting to launch the game when, according to steam, I'm already "playing" the authoring tools?

I run Windows 7, and my OS is, I beleive, a 64 bit. Any help at all would be appreciated. I don't want to publish the map to the workshop for obvious reasons, one being it isn't a playable map, since I followed the instructions of the URL above, two being, even if it WAS an actual map, I'd want to test it out myself first.
Showing 1-15 of 19 comments
< >
ƦɅƉ∑LIƬE 101 Feb 19 @ 3:50pm 
yuou probable have a leak in your map all maps must have all walls fully enclosed if they do not the map will not run
Geekii Bookworm 3 Feb 19 @ 3:52pm 
I'm pretty sure I've got the walls fully enclosed, but I'll check again.
ƦɅƉ∑LIƬE 101 Feb 19 @ 3:53pm 
also make sure that only the walls are outside nothing else
Geekii Bookworm 3 Feb 19 @ 4:20pm 
I'm pretty sure I fixed it, but I'm getting this red message, which I was getting before: LoadPortals: couldn't read c:\program files <x86>\steam\steamapps\common\portal 2\sdk_content\maps\tutorial101.prt
TeamSpen210 12 Feb 19 @ 4:26pm 
That's a leak. Go to map(I think)→ Load Pointfile. There'll be a red line running from outside the map to the inside. Add a brush to fill the hole.
Geekii Bookworm 3 Feb 19 @ 4:30pm 
When I try to do that, it tries to load a file called: tutorial101.lin which there isn't one.
Last edited by Geekii Bookworm; Feb 19 @ 4:30pm
iAndy 8 Feb 19 @ 5:04pm 
That's a vvis error. The real error is happening on the first part.

The part before the loadportals error message will tell you.. just scroll up in the window and look for other red/yellow text. If it says something like "LEAKED!" that means there's a hole in the level. You also need at least 1 entity (preferrably an info_player_start) to compile the map.

It's good you don't want to publish it until it's ready, too many bad maps are out there by people just publishing to test with friends, but not setting to friends only.
Last edited by iAndy; Feb 19 @ 5:07pm
Geekii Bookworm 3 Feb 19 @ 5:06pm 
I saw yellow text, but I figured the problem was the red. I'll try again and let you know what I find. From what I can tell though, I don't have any holes. I have the player start, though. How can I find out about the holes? I look using the 3D camera and there's nothing.
Geekii Bookworm 3 Feb 19 @ 5:08pm 
I see two yellow lines, the topmost one says: ConVarRef gpu_level doesn't point to existing ConVar

The second just says: ****leaked****
iAndy 8 Feb 19 @ 5:09pm 
If you have any holes, it will create that lin file that wasn't found, so it's probably something else that's causing it. One thing you'll get to know about hammer and the compliers is they are very picky about certain things. You always want to create the map on the grid (you can reduce the grid pretty small for little corners and stuff), and try to keep corners clean and the meeting points between brushes flush (don't use 2 different angles when meeting a brush with another brush). Also avoid convex (or complicated) shapes (think pacman) with brushes.. if you want something convex shaped, use more than 1 brush.
iAndy 8 Feb 19 @ 5:11pm 
yeah ***leaked*** means there's a hole in your map. When you go back into the editor try the map > load point file option again. You should see a red line on the level somewhere. Make sure you have the same filename for the map as the one you just rendered.
Geekii Bookworm 3 Feb 19 @ 5:16pm 
I tried the option, it says there's no file with the .lin ending. I took a screenshot: http://imageshack.com/a/img842/1316/olog.png

Also, I know it looks like there's two holes on either side, but there isn't. Since I followed the tutorial, I've got gray and orange textures, so I can distinguish the ceiling and floor from the sides.
iAndy 8 Feb 19 @ 5:20pm 
it really looks like there's 2 holes there. if you look at the front and top views, I can see the roof and floor brushes, but there's nothing on the sides. If there is something there, it's only 1 px wide and that could be causing your problem. If that's not the problem, you can send me the vmf and I'll tell you what's wrong for sure.
Geekii Bookworm 3 Feb 19 @ 5:28pm 
I'm trying to make the other sides, but I guess I'm just getting confused because it's a 2D view while the camera is 3D. I'd really appreciate you taking a look - how can I send it to you?
iAndy 8 Feb 19 @ 5:38pm 
I can kinda walk you through on how to make the sides:
hit Shift-S to make sure you're in select mode, select one of your orange walls,
then hit shift-B to go into brush mode. In the top view make a square along the top of the green square (might turn into grey lines at this point).
then hit Enter on the keyboard.
It will draw the brush with whatever texture you have selected.
Now do the same to the other side.

The reason it makes perfectly heightend walls that you don't have to modify is because you select the wall first. If you just draw a square in brush mode it will make it 1 square in the axis you don't have control over and you have to modify that after drawing it.

I'm pretty sure that's what your problem is on the level, but if you still want to send it to me, just go to mediafire.com and upload it there, and send me the link from it.
Last edited by iAndy; Feb 19 @ 5:39pm
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Feb 19 @ 3:00pm
Posts: 19