Portal 2
 
Community maps. For science.
Welcome to Aperture Laboratories, home of the Perpetual Testing Initiative. Easily create, share and play test chambers authored by and for the Portal 2 community. Do your part! Contribute to Science!
KevinXavier 7 Jun 19 @ 4:46pm
(FIXED) Problem: "env_projectedtexture"
I'm having a problem rendering the shadows of env_projectedtexture. It's kind of hard to explain, but here's a picture so that you can get what's going on: http://steamcommunity.com/sharedfiles/filedetails/?id=273030779
Last edited by KevinXavier; Jun 20 @ 5:18am
Showing 1-12 of 12 comments
< >
iAndy 8 Jun 19 @ 4:51pm 
Do you have your settings turned down so dynamic shadows are off?
KevinXavier 7 Jun 19 @ 4:52pm 
Do you mean the settings of the entity? I'm going to check real quick.
EDIT: I noticed that you meant the Portal 2 settings, and I checked it to have it turned to very high quality. Yet I still have that issue.
Last edited by KevinXavier; Jun 19 @ 4:55pm
TeamSpen210 12 Jun 19 @ 5:48pm 
Make sure "render in fast reflections" is on, I think that's used for projected textures as well as goo. Check the settings and flags for the projected texture too, make sure it has things like "light world" on.
KevinXavier 7 Jun 19 @ 6:05pm 
Okay, I will try as soon as I return to my laptop.
Konke 2 Jun 20 @ 4:20am 
I'm not sure but it doesn't look as the projected texture is on at all. Do you have any other light from the window? It looks like it, and perhaps that's the light we can see on the image you posted.

Have you tried to compile the map with HDR to see how the light looks?

Have you enabled the projected texture through a trigger? If you have any other projected textures then you have to manually enable them with triggers. Instances like arrival or departure elevators have projected textures, so in those cases you need your own trigger for your own projected texture.
Konke 2 Jun 20 @ 4:45am 
I could do a quick check if you'd send me the file. No promises I'll solve it though.
KevinXavier 7 Jun 20 @ 4:46am 
Originally posted by TeamSpen210:
Make sure "render in fast reflections" is on, I think that's used for projected textures as well as goo. Check the settings and flags for the projected texture too, make sure it has things like "light world" on.
I checked and there is no property that says "render in fast reflections." "Light world" is on, but the effect still exists.
KevinXavier 7 Jun 20 @ 4:50am 
Originally posted by Konke:
I could do a quick check if you'd send me the file. No promises I'll solve it though.
I'm sorry, but I am preventing copyright.
Konke 2 Jun 20 @ 5:59am 
Just got back to the desk. Did you fix the problem or do you want me to check the map? Don't worry, I have no interest in stealing anyone else's work. You have copyright on everything you create I assume.
KevinXavier 7 Jun 20 @ 8:32am 
Originally posted by Konke:
Just got back to the desk. Did you fix the problem or do you want me to check the map? Don't worry, I have no interest in stealing anyone else's work. You have copyright on everything you create I assume.
The things that I create are not copyrighted.
Konke 2 Jun 20 @ 9:13am 
At least in Sweden I'd say I have copyright on my work, can't speak for other regions. However, it seems that you've solved the problem and that I no longer need to check it for you. Cheers
TeamSpen210 12 Jun 20 @ 11:12am 
The fast reflections property is on things like prop_dynamics.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50