Dragon Priest Mask Quest Markers
344 commenti
< >
David 6 ore fa 
wich one is the one near marthal and lybrinthia sry idk how to spell them
olderthanyou85 12 lug, ore 12:59 
Finally figured out what to do with the Wooden Mask. I can't wait to see whats behind the door. If you will forgive my slowness, thumbs up.
Turn_on_a_Dime  [autore] 10 lug, ore 19:30 
See: http://www.uesp.net/wiki/Skyrim:Quest_Items#Glass_Claw

@Neptune: Try unsubbing and downloading the mod from the Nexus instead
Is anyone else having the same problem?
d_mckenzie4 10 lug, ore 12:48 
cant find glass claw
[IP] Neptune (Purple Heart) 9 lug, ore 1:14 
No, it's fine until it gets to this one, then it says "Skyrim Launcher has stopped working".
Turn_on_a_Dime  [autore] 9 lug, ore 0:16 
The launcher just worked fine for me .. :(
Turn_on_a_Dime  [autore] 9 lug, ore 0:11 
:( :( :(
Does it give some kind of error message .. ?
[IP] Neptune (Purple Heart) 8 lug, ore 23:14 
Uh, the launcher crashes upon trying to update this mod.
Turn_on_a_Dime  [autore] 8 lug, ore 20:46 
Ok, I uploaded the cleaned one to Steam as well now.
Turn_on_a_Dime  [autore] 5 lug, ore 17:33 
@The Gambler: Haha, thanks, but I'm not looking for donations for my Skyrim mods. If someone wanted to donate, I would prefer they send money to people who make *big* mods and put enormous amounts of time into them.

@FirstWorldMatt: I can't help you if that's all the information you give me. Have you killed a dragon priest? Have you moved the mod to the bottom of your load order?
FirstWorldMatt 5 lug, ore 12:23 
its not working for me
The Gambler 5 lug, ore 10:07 
Your quest marker mods are just the best! If my pay was more lenient, I would definitely donate.
stsh 3 lug, ore 10:32 
This is very helpful. Worked perfectly.
Turn_on_a_Dime  [autore] 2 lug, ore 19:18 
I think I cleaned the version on the Nexus, but not this one.
Need to update it ...
TT 2 lug, ore 13:46 
LOOT says: •Warning: Contains 6 ITM records. Clean with TES5Edit.
emilss1995 29 giu, ore 6:45 
lol
ScornfulTree 28 giu, ore 6:45 
fanks!
ItzNotMason 27 giu, ore 3:08 
so good
Jnz 23 giu, ore 15:49 
really useful
exneste 20 giu, ore 13:54 
It's so useful
Turn_on_a_Dime  [autore] 11 giu, ore 18:18 
Yeah I guess my system is not very reliable :(
The difficult part is trying to put quest markers on something that *already exists* in the game is not part of any quests. So if it tells you to get the wooden mask too early, that means the mod *thought* that some of the priests are already dead. Not sure why :(
Dr. Mask Wolf 11 giu, ore 13:32 
So just to let you know, not all of the quest markers will activate so I only have 5 masks and it tells me to put on the wooden mask.
Kuroll 10 giu, ore 9:45 
its close to labyrinthion but a little further to the right so not even on the ruin grounds
Turn_on_a_Dime  [autore] 10 giu, ore 8:42 
So, not close to any of the dragon priests, as marked here (in blue)?https://imgur.com/gallery/SVDbh
Kuroll 10 giu, ore 3:10 
the marker was on map and radar. i didnt have any other quest on and it pointed into nothing. it was somewhere close to morthal
Turn_on_a_Dime  [autore] 9 giu, ore 18:55 
You are not the first one to report this (second or so, I think), and the last one also didn't tell explain enough to help me in diagnosing the issue.
Around where was it in the world? Near which landmarks? Was the marker just pointing to a blank space (was there a marker in the world or only on the map)?
Kuroll 9 giu, ore 18:47 
somewhere near a dragon but to far away to be a priest. and at the exact spot was nothing
Turn_on_a_Dime  [autore] 9 giu, ore 17:47 
Where did they lead you to?
Kuroll 9 giu, ore 15:43 
some markers lead me to places with nothing at all
Mew Mew 7 giu, ore 23:03 
I seem to be having some bugs in general and I have no idea what may be causing them, so it may not be a problem with the mod. I also got a notice to start the misc. quest "Investigate the ruins of Arkngthamz" for no apparent reason, and one kid I ran across is acting like his parents are both dead when his mom is still very much alive and well. I added and updated a few mods so it's hard to say what's causing the issues, though none of the new stuff should be making kids think their parents are dead.
Turn_on_a_Dime  [autore] 7 giu, ore 18:19 
Hmm, normally it's meant to only start once a dragon priest has been killed, *or* when loading up a game where one is already dead.
Mew Mew 7 giu, ore 12:06 
There seems to be a tiny bug with this. Nothing major but I figured I'd mention it anyway. I just installed this so that I can find all the masks later, and as soon as I loaded up the game I got the quest notice about finding all the masks. Thing is, I just started a new game recently and haven't killed or encountered any dragon priests yet. The description makes it sound like it shouldn't start until after I encounter a priest. Again, not really any big deal but just thought I'd mention that the quest triggered for me without having found any priests yet.
mwade19 24 mag, ore 11:00 
Trun yes you can
Turn_on_a_Dime  [autore] 22 mag, ore 18:19 
Even if you use them to get the 9th mask, you can still retrieve the other masks, can't you?
Urangalo 22 mag, ore 13:07 
Final prize is shit. Use the markers to find all 8 then keep them.
~MIB~ 13 mag, ore 10:22 
Nice
mwade19 11 mag, ore 16:47 
It was useful
Turn_on_a_Dime  [autore] 4 mag, ore 18:17 
If you kill Nahkriin, and have his mask, then you've killed a dragon priest, no?
mwade19 4 mag, ore 17:50 
It looks cool but you should of made a beater pic I all most didn't find it
HARBINGER 4 mag, ore 9:34 
what if u get this mod after u fing Naakhriin but dont remember if you killed a dragon priest??
Turn_on_a_Dime  [autore] 3 mag, ore 17:42 
No, that sounds strange ...
MGSBoca 3 mag, ore 5:27 
I have found 7 of the requisite masks....including Labyrinthian...a marker is pointing to Forehorst near Riftin, correctly, but there is one (no other active quests selected incidentally) in the mountains not far from Morthal. I went to this site and there is nothing but snow, rocks, etc, and no "black marker" to any unvisited sites. Any ideas what this might be? Thank you.
Turn_on_a_Dime  [autore] 22 apr, ore 15:18 
The quest should activate if a mask-carrying dragon priest is already dead, or when you kill one
belokonin30 22 apr, ore 10:18 
Where to get the job on the mask,you can't activate them.
Turn_on_a_Dime  [autore] 20 apr, ore 18:46 
@yannik.schulz: You should use something like nexus mod manager to activate the mods
SU-33 20 apr, ore 2:14 
Very useful! Thanks!
yannik.schulz 20 apr, ore 1:48 
I have all plugins of the mods in Nexus, but I don´t know what I have to do with that files, if I want to install the mods from steam in Nexuss.
Turn_on_a_Dime  [autore] 16 apr, ore 21:25 
One of the priests is inaccessible until you get some way through the main quest - a marker towards him is impossible. Another is inaccesible until some way through the College of Winterhold - he is inside labyrinthian, the dungeon nearby where you assemble the masks.
javiayars 16 apr, ore 19:27 
One of mine pointed to an area in the forest next to where you would go to assemble all of the masks. I also have six of the eight and have no other markers to indicate where the other two are.
thunderingb00m 16 apr, ore 13:42 
but ill try it again