Dragon Priest Mask Quest Markers
343 Kommentare
< >
olderthanyou85 Vor 3 Stunden 
Finally figured out what to do with the Wooden Mask. I can't wait to see whats behind the door. If you will forgive my slowness, thumbs up.
Turn_on_a_Dime  [Autor] 10. Juli um 19:30 Uhr 
See: http://www.uesp.net/wiki/Skyrim:Quest_Items#Glass_Claw

@Neptune: Try unsubbing and downloading the mod from the Nexus instead
Is anyone else having the same problem?
d_mckenzie4 10. Juli um 12:48 Uhr 
cant find glass claw
[The Imperfect Gamers] Neptune 9. Juli um 1:14 Uhr 
No, it's fine until it gets to this one, then it says "Skyrim Launcher has stopped working".
Turn_on_a_Dime  [Autor] 9. Juli um 0:16 Uhr 
The launcher just worked fine for me .. :(
Turn_on_a_Dime  [Autor] 9. Juli um 0:11 Uhr 
:( :( :(
Does it give some kind of error message .. ?
[The Imperfect Gamers] Neptune 8. Juli um 23:14 Uhr 
Uh, the launcher crashes upon trying to update this mod.
Turn_on_a_Dime  [Autor] 8. Juli um 20:46 Uhr 
Ok, I uploaded the cleaned one to Steam as well now.
Turn_on_a_Dime  [Autor] 5. Juli um 17:33 Uhr 
@The Gambler: Haha, thanks, but I'm not looking for donations for my Skyrim mods. If someone wanted to donate, I would prefer they send money to people who make *big* mods and put enormous amounts of time into them.

@FirstWorldMatt: I can't help you if that's all the information you give me. Have you killed a dragon priest? Have you moved the mod to the bottom of your load order?
FirstWorldMatt 5. Juli um 12:23 Uhr 
its not working for me
The Gambler 5. Juli um 10:07 Uhr 
Your quest marker mods are just the best! If my pay was more lenient, I would definitely donate.
stsh 3. Juli um 10:32 Uhr 
This is very helpful. Worked perfectly.
Turn_on_a_Dime  [Autor] 2. Juli um 19:18 Uhr 
I think I cleaned the version on the Nexus, but not this one.
Need to update it ...
TT 2. Juli um 13:46 Uhr 
LOOT says: •Warning: Contains 6 ITM records. Clean with TES5Edit.
emilss1995 29. Juni um 6:45 Uhr 
lol
ScornfulTree 28. Juni um 6:45 Uhr 
fanks!
ItzNotMason 27. Juni um 3:08 Uhr 
so good
Jnz 23. Juni um 15:49 Uhr 
really useful
exneste 20. Juni um 13:54 Uhr 
It's so useful
Turn_on_a_Dime  [Autor] 11. Juni um 18:18 Uhr 
Yeah I guess my system is not very reliable :(
The difficult part is trying to put quest markers on something that *already exists* in the game is not part of any quests. So if it tells you to get the wooden mask too early, that means the mod *thought* that some of the priests are already dead. Not sure why :(
Dr. Mask Wolf 11. Juni um 13:32 Uhr 
So just to let you know, not all of the quest markers will activate so I only have 5 masks and it tells me to put on the wooden mask.
Kuroll 10. Juni um 9:45 Uhr 
its close to labyrinthion but a little further to the right so not even on the ruin grounds
Turn_on_a_Dime  [Autor] 10. Juni um 8:42 Uhr 
So, not close to any of the dragon priests, as marked here (in blue)?https://imgur.com/gallery/SVDbh
Kuroll 10. Juni um 3:10 Uhr 
the marker was on map and radar. i didnt have any other quest on and it pointed into nothing. it was somewhere close to morthal
Turn_on_a_Dime  [Autor] 9. Juni um 18:55 Uhr 
You are not the first one to report this (second or so, I think), and the last one also didn't tell explain enough to help me in diagnosing the issue.
Around where was it in the world? Near which landmarks? Was the marker just pointing to a blank space (was there a marker in the world or only on the map)?
Kuroll 9. Juni um 18:47 Uhr 
somewhere near a dragon but to far away to be a priest. and at the exact spot was nothing
Turn_on_a_Dime  [Autor] 9. Juni um 17:47 Uhr 
Where did they lead you to?
Kuroll 9. Juni um 15:43 Uhr 
some markers lead me to places with nothing at all
Mew Mew 7. Juni um 23:03 Uhr 
I seem to be having some bugs in general and I have no idea what may be causing them, so it may not be a problem with the mod. I also got a notice to start the misc. quest "Investigate the ruins of Arkngthamz" for no apparent reason, and one kid I ran across is acting like his parents are both dead when his mom is still very much alive and well. I added and updated a few mods so it's hard to say what's causing the issues, though none of the new stuff should be making kids think their parents are dead.
Turn_on_a_Dime  [Autor] 7. Juni um 18:19 Uhr 
Hmm, normally it's meant to only start once a dragon priest has been killed, *or* when loading up a game where one is already dead.
Mew Mew 7. Juni um 12:06 Uhr 
There seems to be a tiny bug with this. Nothing major but I figured I'd mention it anyway. I just installed this so that I can find all the masks later, and as soon as I loaded up the game I got the quest notice about finding all the masks. Thing is, I just started a new game recently and haven't killed or encountered any dragon priests yet. The description makes it sound like it shouldn't start until after I encounter a priest. Again, not really any big deal but just thought I'd mention that the quest triggered for me without having found any priests yet.
mwade19 24. Mai um 11:00 Uhr 
Trun yes you can
Turn_on_a_Dime  [Autor] 22. Mai um 18:19 Uhr 
Even if you use them to get the 9th mask, you can still retrieve the other masks, can't you?
Urangalo 22. Mai um 13:07 Uhr 
Final prize is shit. Use the markers to find all 8 then keep them.
~MIB~ 13. Mai um 10:22 Uhr 
Nice
mwade19 11. Mai um 16:47 Uhr 
It was useful
Turn_on_a_Dime  [Autor] 4. Mai um 18:17 Uhr 
If you kill Nahkriin, and have his mask, then you've killed a dragon priest, no?
mwade19 4. Mai um 17:50 Uhr 
It looks cool but you should of made a beater pic I all most didn't find it
HARBINGER 4. Mai um 9:34 Uhr 
what if u get this mod after u fing Naakhriin but dont remember if you killed a dragon priest??
Turn_on_a_Dime  [Autor] 3. Mai um 17:42 Uhr 
No, that sounds strange ...
MGSBoca 3. Mai um 5:27 Uhr 
I have found 7 of the requisite masks....including Labyrinthian...a marker is pointing to Forehorst near Riftin, correctly, but there is one (no other active quests selected incidentally) in the mountains not far from Morthal. I went to this site and there is nothing but snow, rocks, etc, and no "black marker" to any unvisited sites. Any ideas what this might be? Thank you.
Turn_on_a_Dime  [Autor] 22. Apr. um 15:18 Uhr 
The quest should activate if a mask-carrying dragon priest is already dead, or when you kill one
belokonin30 22. Apr. um 10:18 Uhr 
Where to get the job on the mask,you can't activate them.
Turn_on_a_Dime  [Autor] 20. Apr. um 18:46 Uhr 
@yannik.schulz: You should use something like nexus mod manager to activate the mods
SU-33 20. Apr. um 2:14 Uhr 
Very useful! Thanks!
yannik.schulz 20. Apr. um 1:48 Uhr 
I have all plugins of the mods in Nexus, but I don´t know what I have to do with that files, if I want to install the mods from steam in Nexuss.
Turn_on_a_Dime  [Autor] 16. Apr. um 21:25 Uhr 
One of the priests is inaccessible until you get some way through the main quest - a marker towards him is impossible. Another is inaccesible until some way through the College of Winterhold - he is inside labyrinthian, the dungeon nearby where you assemble the masks.
javiayars 16. Apr. um 19:27 Uhr 
One of mine pointed to an area in the forest next to where you would go to assemble all of the masks. I also have six of the eight and have no other markers to indicate where the other two are.
thunderingb00m 16. Apr. um 13:42 Uhr 
but ill try it again
thunderingb00m 16. Apr. um 13:42 Uhr 
if you mean krosis you are mistaken