Invisible Shield Fix
52 kommentarer
< >
☽LEGACY 10 timer siden 
FINALLY
Thanks... I freaking love this mod... :D
Ramirez  [skaper] 15. jul @ 11:05am 
Klick on the green subscribe button, the Skyrim launcher will download it automatically on the next start.
Бродяга_Сонный 15. jul @ 9:07am 
как скачать?
Ramirez  [skaper] 9. mai @ 5:56am 
This mod doesn't touch the mannequins in any way. Also I checked my House, there is all fine. I'm afraid I can't really help at this.
Theshadow869 [TWB] 8. mai @ 9:33am 
Worked, but mannequines at my house (hearthfire add on) were mucked up. One had its leg in a weird position, and another was floating quite a distance from its pedestal. Might want to fix this.
[FR] Leproutos 18. apr @ 3:03pm 
Thank you man !
wayan_gd 15. apr @ 10:26pm 
how to download it?
fosley 20. mar @ 10:09pm 
I love ebony armor if I'm going heavy, so I was rather disappointed when my shields disappeared. This mod fixed the problem perfectly, thanks much. :)
green.bratishka 25. feb @ 6:07am 
спасибо, давно искал!
\KK/ anno3397 16. feb @ 11:15am 
Ok thanks :)
Ramirez  [skaper] 15. feb @ 7:28am 
@anno3397 It works with Dragonborn, and it should also work with your problem. Otherwise just uninstall the Mod. :)
\KK/ anno3397 15. feb @ 3:33am 
@Ramirez Did it work with Dragonborn also? And will it work if for ex. my Thieve Guild Hood looks normal but my Ebony Shield is invisible?
M1k3 L1z4rD 6. feb @ 5:25am 
my dark brotherhood hood doesnt show when equipped, can you fix that?
crazyalpacka64 12. jan @ 12:24pm 
Thx man this was bothering me so much :D
Lich Dire Wolf 24. des, 2013 @ 9:24am 
Very nice man ,you made a person with OCD happy again. Everything is running smooth ,but the shield (ebony) kind of enters inside of the arm a little bit. (OCD strikes again) Besides that everything is perfect ,great job!
Volfied1 20. nov, 2013 @ 5:08pm 
excellent work. installed the mod and the shields were instantly fixed.
I am having a glitch with certain helmets on hearthfire maniquins, any chance of a mod to fix that too?
Tjaktar 16. okt, 2013 @ 8:52am 
My daedric sword turned invisible too, not sure if it's the same bug
ShadowStab 25. aug, 2013 @ 7:11pm 
thanks
CaptJackSp 25. jul, 2013 @ 9:57am 
Thanks! It's perfect so far.
[FgcA] TonyMax 18. jun, 2013 @ 7:48pm 
Thanks!
EpicPwner 30. mai, 2013 @ 1:42pm 
Thanks!
Ramirez  [skaper] 31. jan, 2013 @ 8:20am 
@OndAtRa RodenTia should be fixed after update. thanks for reporting!
OndAtRa RodenTia 31. jan, 2013 @ 12:38am 
khajiit male (and maybe female)
Ramirez  [skaper] 30. jan, 2013 @ 2:46pm 
@OndAtRa RodenTia which race? Can't find something unusual.
Ramirez  [skaper] 30. jan, 2013 @ 9:14am 
@OndAtRa RodenTia I'll change that asap.
OndAtRa RodenTia 30. jan, 2013 @ 8:23am 
Ramirez, what about Penitus Oculatus Helmet ?? It's invisible too.
toby.smith.1990.ts 27. jan, 2013 @ 4:15pm 
Thank-you for this mod. Working perfectly so far. Keep up the good work :-).
RadKit 10. des, 2012 @ 6:48pm 
Thank you, this mod fixed my invisable ebony shield.
Zientos 7. des, 2012 @ 1:01am 
Yes it was for the Nord Race. Amulet is working perfectly now. Thank you very much for this fix and quick reply.
Ramirez  [skaper] 3. des, 2012 @ 11:33am 
@Zientos Did you mean for the Nord Race?
Should be fixed now, after downloading the update.
Ramirez  [skaper] 3. des, 2012 @ 11:18am 
@Zientos I'll have a look.
Zientos 2. des, 2012 @ 5:15pm 
Could you also fix Amulet of Zenithar?
1junjosh 17. nov, 2012 @ 3:56am 
Thank you so much!!!!!!
Ramirez  [skaper] 17. nov, 2012 @ 2:30am 
@1junjosh you are right!
I added the Thieve Guild Leader Hood to the Fix, it should work after downloading the update.
1junjosh 17. nov, 2012 @ 1:55am 
I would be grateful if you replied, Ramirez.
1junjosh 17. nov, 2012 @ 1:55am 
The thieve's guild master hood doesn't work on the vampire. My character goes bald. Please fix.
Inspectah13 15. nov, 2012 @ 1:32pm 
I moved it all over the load order to no avail. I then turned off all my other mods but when i do that i get the same issue others have mentioned, when I select a save to load it goes into the loading screen then the game will just CTD. However I don't know if that is from this mod or if one of my other mods broke my saves when I prevented it from loading to be fair. Thank you for your quick response to my first post though, it was much appreciated.
Ramirez  [skaper] 15. nov, 2012 @ 3:48am 
@Inspectah13 It should work, also with the newest version of Skyrim.
Try to move the .esp in the load order to an other position, maybe the bottom of the list.
Inspectah13 15. nov, 2012 @ 3:06am 
I really wanted this to work but I still can't see my ebony large shield. The .esp is in the data files folder and I see it in the data on the launcher, but the shield is still invisible.
f.f.86 19. okt, 2012 @ 5:42pm 
Thanks very much. I just turned vampire to enter the sould cairn, and this no shield thing was bugging me out. Thanks for saving me tampering with the CK myself.
cantonbean 12. okt, 2012 @ 12:07am 
Great mod as this was driving me metal and no other fix exists. I don't want to install mods but seeing as developers didn't bother to fix this when releasing Dawnguard (unbelievable) your work sir is a blessing! No idea what others are on about as mod does exactly what supposed to!
Ramirez  [skaper] 24. aug, 2012 @ 6:08am 
Fixed Thieve Guild Hoods for Vampires.
Nimrod 20. aug, 2012 @ 9:38am 
works perfect, thanks!
Hidden Gunman 19. aug, 2012 @ 11:47pm 
Many thanks, very appreciated.
Sword Saint 17. aug, 2012 @ 5:44pm 
i got this problem with my blades shield
Chosen Mimes 14. aug, 2012 @ 2:06am 
exactly what i was looking for! thanks
Nubkakes 8. aug, 2012 @ 2:25pm 
thanks for the great mod. works amazing. no crashes or anything. something is up with the 2 others below me.
Bear 7. aug, 2012 @ 2:21pm 
Crashes game
zhemos 5. aug, 2012 @ 1:48pm 
I subscribed to this mod, It installed fine. When im at the select screen, the game just shuts down. I wouldn't call it crashing. But something is definitely wrong with this mod.
Ramirez  [skaper] 5. aug, 2012 @ 11:24am 
Yea, that's nearly impossible.