Spell Eraser
62 Comments
< >
Atlas Maltael Jul 11 @ 1:15pm 
well it may not have fixed the bound sword spell but at least its erased i thank you for this mod.
Atlas Maltael Jul 11 @ 1:07pm 
this might help me every time i use bound sword the game crashes ill use this mod to fix it.
i hopeit works.
҉  IncinerateChicken May 16 @ 5:06pm 
Fantastic. Thanks for making this.
YourfavoriteSnorlax Apr 17 @ 9:10pm 
Shouts to???
americus22americus33 Feb 10 @ 6:28pm 
never mind i found it
americus22americus33 Feb 10 @ 6:26pm 
is there one that eraces dragon shouts r is this the mod?
light grimm17 Jan 4 @ 9:17am 
perfect !!! XD
GingersGoRawr Nov 30, 2013 @ 8:46am 
@altinms That's really weird, do you have any mods that affect quests? Try dissabeling all of your mods and then starting a new game (keeping your old) and see if there is still a problem, if not, then it's probably a mod. It could also just be a glitch resulting from your previous mods and mod faliures. Really wish I could help, and unfortunately I for me with the whole magic menu failure going back to the previous save isn't an option, I have no idea what happened to it, but it's really annoying, Best of luck with your questing problems.
altinms *woof woof* Nov 26, 2013 @ 2:10pm 
@GingersGoRawr: I ended up having to delete the save the spells were stuck on. Since then I found no problem after words on any of my other saves. As of right now it's been concluded that it's from a WIP mod I had previously subscribed to. The mod itself was buggy but after removing it the spells stayed in my invintory, causing my game to crash everytime I loaded. I am now running into a problem where the Jarl of windhelm or certain other characters are not at thier story places. Like, the Jarl of whiterun will be IN dragonsreach, but not at his throne. And when I try to start the story he'll say his line but then he won't move to talk to his house carl or anything. The only way to advance the story is waiting a few days and then he starts Bleak falls burrow quest with his diolague and the quest gets stuck there since his court wizard won't give me the quest diolague. Any ideas?
Eps  [author] Nov 26, 2013 @ 2:42am 
Yes, it is.
TheBatSwagg Nov 14, 2013 @ 12:02pm 
It's still possible to relearn the spells right? From like spell tomes and such?
GingersGoRawr Oct 28, 2013 @ 8:23pm 
Altinms unfortunately I am here trying to fix that problem. No one has found a legit solution to it yet, though a lot of people suggest fast traveling, sleeping, learning a new spell, and even just curing any disseases. Unfortunately so far non of these things have worked for me, but I havent been able to try sleeping yet. If you happento find a sollution, I beg you to let me know. This problem has had a detrimental effect on my game and I haven't been able to move past the certain point I am stuck in. (I can't load a new save and would prefer not to restart... again) If you know of a solution or have an idea please message me.
altinms *woof woof* Oct 28, 2013 @ 2:10pm 
Hello! I try to use this mod but ANOTHER mod I used along time back which I unsubscribed to now crashes me when I try to enter magic! I don't remember which mod it was or how to find it, or the spell/powers ID. How can I fix this?
SU-33 Aug 18, 2013 @ 3:29am 
Useful! Thank you.
Eps  [author] Aug 16, 2013 @ 12:10pm 
OK, I see, that was on another website (skyrimfans.ru I think?). Anyways, you have my permission. Just make sure it's clear you're not the original author in the description.
Wehrwolfmann Aug 16, 2013 @ 11:39am 
Russian fans do not subscribe to the plug-ins in the workshop, where the description in English ((
Wehrwolfmann Aug 16, 2013 @ 11:34am 
Not seen in the workshop I was Russian version of your plugin, so I ask. I found a few lines of text in a plugin, like to move and lay solely for the Russian community. Allow me, please
Eps  [author] Aug 16, 2013 @ 11:28am 
I think someone already did that? Check to make sure it's not already on that site.
Wehrwolfmann Aug 16, 2013 @ 10:37am 
Hello Can I get you permission for the Russian version in the workshop with the description in Russian your amazing plugin? I will show you as the author and a link to a page put nexus. Waiting for an answer.
DEATHLORD58 Jul 29, 2013 @ 6:22pm 
cant get it to load any sugestions
ElderGamer1 Apr 21, 2013 @ 12:27am 
I have to say your Spell Eraser works great. I had something like this for Oblivion and It's so good I have it for Skyrim..Thanks for making it so easy to delete spells!
Eps  [author] Apr 17, 2013 @ 10:11am 
A lot of people requested one for powers and shouts, so I created a second mod, Power Eraser, where the process is reversed - a spell that you cast from your hand that erases your equipped power/shout.
pikmonwolf Apr 15, 2013 @ 7:41pm 
Awesome, I hated having that guy from the colleges magic heating spell that is only usefull for that quest.
|-ICE-| Sheogorath[SCM] Apr 15, 2013 @ 2:56pm 
BUUUTTTT, now he has a power eraser too :) You are a great modder and the fact your willing to make your own videos is devastaing for other modders. Good job.
Eps  [author] Feb 23, 2013 @ 1:36am 
Yes, that's the case.
Sir Render Feb 22, 2013 @ 9:04pm 
I will assume this is just spells, not powers then?
Even so this is very useful, thanks
Eps  [author] Feb 21, 2013 @ 10:21am 
That would take too much time and it would only work for vanilla spells and powers.
Toltuk Feb 21, 2013 @ 3:43am 
can you make a version that wipes the entire list of spells and powers?
doctor Feb 15, 2013 @ 8:30am 
ok found it. thanks
Eps  [author] Feb 15, 2013 @ 7:00am 
Look in the Magic menu under Powers.
doctor Feb 14, 2013 @ 12:52pm 
yeah i tryed it and didnt find anything. thats why im asking.
Eps  [author] Feb 14, 2013 @ 12:03pm 
I can't see why it should not. All the mod does is add a Power. You access it like any other Power through whatever interface you're using.
doctor Feb 13, 2013 @ 7:23pm 
hey does it work with skyui
hawoc Jan 27, 2013 @ 3:44am 
ok thanks
Eps  [author] Jan 27, 2013 @ 3:33am 
@bnarskeren It should. Provided that you learned the spell via a Spell Tome or other one-time method. If the modder implemented it as "Add on game load", it will keep re-adding it.
hawoc Jan 27, 2013 @ 3:22am 
does this work for mod spells aswell???
blckruc47 Jan 22, 2013 @ 9:27pm 
Great idea. Great mod.
Pumpkin Mouse Oct 14, 2012 @ 4:27pm 
awesome! exactly the type of helpful mod I'm looking for.
Benjy52 Oct 3, 2012 @ 3:18pm 
Now I get an answer :)
Eps  [author] Sep 21, 2012 @ 3:22am 
@Benjy52 Hwat? :|
Benjy52 Sep 20, 2012 @ 4:44pm 
LOL no one answered me.
Dajelly Sep 13, 2012 @ 3:32am 
k thanks for the help
Eps  [author] Sep 12, 2012 @ 3:26am 
I can't even begin to imagine how trying to remove an unremovable spell could possibly cause graphical glitches. It would have to be something on Beth's side.
Dajelly Sep 11, 2012 @ 3:12am 
well tried erasing the first healing and fire spell and like u said they wont delete so now when any fire or heal spell used has black lines around the fingers and the outlining the spell itself tried deleting mod and reinstall the game itself with no luck. any help be awsome
Eps  [author] Sep 11, 2012 @ 2:14am 
What kind of fixes?
jconsort Jun 24, 2012 @ 4:10pm 
Many thanks..tired of having to look up the console command to unclutter the spell list..this is perfect.
Benjy52 Jun 17, 2012 @ 8:24pm 
Spell Eraser : E R A S E R .
UninformedLuddite Jun 10, 2012 @ 5:06pm 
Why would you want to erase shouts and/or only use one? I have found sitting back chilling on a mountainside whilst my big pet rampages a lot fo fun
AdmiralTails Jun 8, 2012 @ 9:27am 
Of course, if you only want one shout, then other shouts' presence in the menu would hardly matter, you wouldn't be going into the menu to change.
carma_178 Jun 8, 2012 @ 6:35am 
ok thanks