The Harbinger's Armory
53 Comments
< >
Zim  [author] May 24 @ 10:52am 
w.kersten..sorry pal, if that's the case there's nothign i can do this end
w.kersten May 24 @ 8:47am 
Tried everything. Loaded the game again. Subscribed again (only this one). Started the game over again. Still not working.
w.kersten May 21 @ 8:13am 
yes i know how to do that. The armour is working fine. No mod conflict detected. Try to subscribe the mod again. Thanks
Zim  [author] May 21 @ 6:14am 
w.kersten....I've had a look a the mod in the creation kit, everything seems to be working fine this end...does the armor not work either? It's possible there's a mod conflict, though i think it's more likely the mod has downloaded incorrectly. if that's the case, i recommend re-downloading it. Do you know hoe to do that?
w.kersten May 21 @ 4:25am 
I don't get the advantages of better archery etc
Zim  [author] May 20 @ 10:46am 
w.kersten...what part doesn't work?
w.kersten May 20 @ 10:41am 
gauntlets don't work any suggestions
ROAM Apr 30 @ 3:14pm 
Neither worked. ^^; Oh well.
Zim  [author] Apr 30 @ 2:53pm 
roamingwhirlwind...might also be worth unsubscribing, removing the mod from your computer, and then re-subscribing so that you can re-download the mod. might have downloaded wrong and that could be causing the problem
Zim  [author] Apr 30 @ 2:52pm 
roamingwhirlwind...could be anything I'm afraid, usually a mod conflict. Try moving the mod to the bottom of the load order...if that doesn't work, try putting it to the top. never know
ROAM Apr 30 @ 1:42pm 
Mount of Ysgramor Shield and Axe don't work. Any tips?
baconraptor Mar 30 @ 3:12pm 
boots and helmet please
Rhadamanthos Mar 8 @ 10:48am 
Very awesome, I very much liked this
COOLBREEZE Jan 21 @ 9:30pm 
outstanding mod. the only issue i had was that i brought my follower into the armory and they became stuck and wouldn't follow me out. Fixed it by dimissing the follower and waiting from him to exit before me.
PuppetPal_HoneyBee Jan 14 @ 2:29pm 
nice mod could use an enchanted helmet, the weapons from oblivion are cool but a little overpowered imo. thumbs up
Callum the Chameleon Dec 13, 2013 @ 5:02pm 
that is sick
KingOfCreepers42 Oct 19, 2013 @ 7:07pm 
Cool mod
Victoryguard Oct 18, 2013 @ 3:20pm 
Had to get it, thanks for making the awesome for the Fighter inclined ;-)
Askaree Oct 17, 2013 @ 9:54am 
I like your mod. The only suggestion I have is can you complete the Harbingers set with boots and helm?
Ulquiorra schiffer Oct 16, 2013 @ 3:36pm 
for get my other post XD
Ulquiorra schiffer Oct 16, 2013 @ 3:36pm 
k ty
Zim  [author] Oct 16, 2013 @ 12:38am 
VastoLordKnight....sorry to say it, but im coming to the end of modding for the time being....ive only a few more mods coming out, and i don't wanna extend that any more for now.....sorry mate
Ulquiorra schiffer Oct 15, 2013 @ 6:15pm 
could u improve the arcmage out fit
robinclayton79 Oct 12, 2013 @ 9:05pm 
awesome.....just getting back into skyr, mod works great for me. thanks for the awesome addition to the greatest game ever.
Zim  [author] Oct 7, 2013 @ 12:28pm 
Beard Manly....yeah the chests are all safe. Everyone starts somewhere, why not give modding a try? I already use jorrvaskr as a player home....but you might like this mod: http://steamcommunity.com/sharedfiles/filedetails/?id=109953717&searchtext=companions
Beard Manly Oct 7, 2013 @ 12:21pm 
perhaps this is a stupid question, but are all the new chests and stuff safe?

I wish I could mod. I just want to buff up the companions so they can level with you and are essential, and Jorrvaskr can be a player home after becoming Harbinger, and you can get Armor of Ysgramor in addition to the shield and Wuuthrad, and Beast Form can actually be useful, and you can get trained up to 90 in all combat skills, man that is asking a lot.
Gol Zin Oct 3, 2013 @ 10:11pm 
very nicely done!
thesword Oct 3, 2013 @ 4:50am 
can you pls and some harbringers boots there are only the chestarmor and the gauntlets
Zim  [author] Oct 2, 2013 @ 5:39pm 
Danre's Infrerno....I don't experience this problem on my system....the greatswords point the normal way for me....as a result, i can't fix your problem because it's not a probelm with my system....
DragonSamurai360 Oct 2, 2013 @ 5:30pm 
cool mod cant wait to try it
Dante's Inferno Oct 2, 2013 @ 2:53pm 
When placeing greatswords on the weapon racks they are reversed, as in they point up into the air above the rack instead of pointing down to the floor. could you please fix the racks so they work properly? thanks ^^
diego.martin Oct 2, 2013 @ 8:45am 
Thanks
twhelan65 Oct 2, 2013 @ 4:47am 
Yeah, Dragon Rising didn't help. I'm going to continue using this mod though and if I stumble upon a solution I'll let you know. Thanks.
Fortitude Sep 29, 2013 @ 1:10pm 
this mod looks awesome I already loved the companions, now I love them even more
crazyscot2012 Sep 29, 2013 @ 1:10pm 
Very nice! I really like this mod, I just wish that there were Harbinger's boots and helmet as well.
darknessangel133 Sep 29, 2013 @ 11:30am 
it took me like 3 seconds to download lol
Brotherhood Paladin Sep 29, 2013 @ 8:57am 
@Deadcurze Zim has had problems uploading to the Nexus in the past, so I don't think you will see a Nexus release. But, then again, I can't really speak for Zim.
Deadcurze Sep 29, 2013 @ 3:36am 
This looks like an awesome place to store my weapons in, although I personally think that it would be even better if you uploaded this mod to the skyrim nexus aswell! I do not use the steam workshop to download mods because the workshop auto updates them, which has caused quite a lot of problems for me in the past!

PS: If you decide to put it on the nexus please let me know so that I can download it!
Zim  [author] Sep 29, 2013 @ 12:38am 
twhelan65....i don't think that's the problem, I haven't completed Dragon Rising either and it works for me just fine. I think the problem must be the racks themselves...maybe another mod is causing a clash or something. Don't think there's anything I can do :(
twhelan65 Sep 28, 2013 @ 3:38pm 
Hi Zin, so the regular weapon and sheild racks take Wuth & Ysg as well as anything else. I just had a thought (imagine that, lol), would the ability to display these be dependant on completing Dragon Rising? I would test this with another character if I had one. You probably won't get to many level 64 characters with this problem if in fact this is the case! Actually, another thought (whoa, I'm on a roll lol), I'll go test it by completing Dragon Rising!
Brotherhood Paladin Sep 28, 2013 @ 1:51pm 
I see the Armory is doing well, Zim. Great job.
twhelan65 Sep 28, 2013 @ 7:12am 
Thanks Zim. I didn't think of that. I'll let you know.
Grump"The Hammer"gro-Maul Sep 28, 2013 @ 6:12am 
Good idea, I always thought it was strange that there is a mount (in the stairwell) for Wuuthrad in Jorrvaskr but it wont accept it. Subscribing now and going to go check it out.
maxx130 Sep 28, 2013 @ 4:30am 
I know i've had problems with the shield mounting askew (not flush) on shield placs either vanilla or other mods
DeadSilence Sep 28, 2013 @ 2:15am 
you have skype??
if you do im serrex899
and thanks for a good mod :D
Zim  [author] Sep 27, 2013 @ 11:12pm 
DeadSilencsce....all the info is in the description....it's accessed via a trapdoor in the Harbinger's Bedroom
Zim  [author] Sep 27, 2013 @ 11:12pm 
twhelan65....right. that i can't explain im afraid.....you say Ysgramor's Shield won't mount either? Because it seems very odd to me that these two things alone should get messed up........have you tried putting the shield onto one of the other two shield racks? because knowing what happens then would be very helpful
DeadSilence Sep 27, 2013 @ 12:45pm 
where is this???
i mean where can i find this "armory"??
twhelan65 Sep 27, 2013 @ 6:39am 
I get am activate option but pressing e does nothing. Of course I equipped them first - nothing. tried not equipping them - nothing. I tried leaving Jorrvaskr and saving, going to clean save and trying all options again - nothing. They just stay in my hands.
Zim  [author] Sep 26, 2013 @ 10:26pm 
twhelan65...oh dear, I've no idea what could be causing that...when you say they don't take them, do you not even get an activate option, or do the artifacts fall on the floor when you try to use it?